Tech Support Forum banner

Erratic/High CPU Usage When Modem Connected

1879 Views 2 Replies 2 Participants Last post by  FourtyCaliber
Hi All. My name is Tony. I've been having some problems with my computer for about the past 6 months or so. First, I am on a dial-up connection because that's all I can afford at the moment because I lost my job about 2 years ago. But, then again, I'm cheap and have always had a dial-up connection. I have a Sony Vaio Laptop, AMD Athlon XP 1500+ processor, and 512MB Ram (that's all it will take). Running Windows XP Home. I haven't downloaded any Service Packs, yet, because it is hard on dial-up. I have downloaded some of the other Critical Updates. BUT, all of this started when I had all of the Service Packs and updates (SP3). It was running fine for quite some time with WinXP Home SP3. I reinstalled Windows about 3 months ago because of this problem.

That's how I first noticed there was something not right with my computer/connection. I used to use Firefox (exclusively) and it was very fast, even on my dial-up connection. Then I started noticing that when I would click a link on any page, at random times, nothing would happen for quite some time (amount of time would vary). I've reinstalled and tried most of the Firefox versions including the latest and greatest. I've been to the Sony website and downloaded all of the latest drivers. I was fully up to date with everything when this all started.

I use Avira AntiVirus (up to date). I have ran scans with Spybot, AdAware, SuperAntiSpyware, MalwareBytes, you name it. I haven't found any malware with any of them. Ewido did find "Alexa". But, Ewido isn't supported anymore.

I downloaded Process Explorer and have noted that everything seems fine when I am not connected (through dial-up) to the Internet. My CPU Usage is only about 3.88% and is steady in that case. As soon as I dial-up and get connected, my CPU Usage soars to anywhere up to 30% or 40%, up and down, and the graph in the "CPU Usage History" becomes very erratic, like a sharp saw-tooth pattern. It's smooth before I dial-up.

I had my phone line replaced from the pole to my house and from the pole to the "hub". It was checked by the technician for noise and was good. I have unhooked all other devices from other jacks in my house and the problem persists.

Here's the other indicator that something has "changed": I used to be able to go to Shoutcast, just about 5 months ago, and I could listen to a station with a lower bitrate (say 32kbps, or even 40kbps) and I could listen to the station uninterrupted for hours with no buffering after the station started. Now, it buffers every 10 seconds or so.

Sometimes, the modem (connection) just goes dead and the modem doesn't send or receive any data and I have to disconnect and then dial-up again. Sometimes when I go to disconnect my connection the modem takes one or two minutes to do so.

I've noticed that when I click a link, sometimes when nothing happens, that there is no CPU activity at all. Right now the CPU Usage History in Process Explorer looks like a bad EKG chart. It's all jagged and erratic continuously.

I have no idea if this is a bad modem or something else? The modem does connect at good speeds (49kbps - 50.6kbps) all the time. That is always what I have connected at.

Anyone have any ideas?


More Info: The other thing I forgot to mention that also in Process Explorer, under Interrupts>Properties, the CPU Usage History is a continuous "jagged", "erratic" "saw-tooth" line and the CPU Usage itself is continuously jumping from 1% to 10%. Maybe even a little more. That's even when I am not touching anything.
See less See more
Not open for further replies.
1 - 2 of 3 Posts
Thanks for the reply.

Yes, I have tried different dial-up numbers. Actualy, there are about 9 different numbers. Some are better than others. I have had this ISP for a LOT of years and they have actually been pretty good. The dial-up number I use most often I have been using for the past couple years. LIke I said, I used to be able to go to ShoutCast Radio and steam low bitrate stations to WinAmp with no problem. Now, all it does is want to buffer every ten seconds. My modem has the latest/greatest drivers. I haven't changed anything. I have even dialed-up to another ISP (cousin's) and experienced the same thing. For web surfing, I have tried about every browser under the sun. I have always used Firefox with no problems. But now, even when pages start to load, the modem just stops receiving any data for a time (like a timeout) and then starts again for a bit, over and over again, until the page has loaded. This all just started about 5 or 6 months ago. The modem connects fine and at a good rate. I've upgraded the Java as required when new versions are released. Just not sure what's going on here, but something has certainly changed.

For the record, I don't ever recall seeing the "CPU Usage History" under "Task Manager" shaped like a "Saw Tooth" when I am connected. It's a night and day difference between when I am not connected and when I am connected. When I'm not connected, the "CPU Usage History" is a straight line and about 3% usage. As soon as I dial-up and connect, the usage starts jumping to 10% to 30%, up and down, like a saw tooth. That's just connected, not doing anything. When I start surfing or downloading something, the usage spikes up to 80% or 90% and then down to 10% and then back up to 80%. As soon as a page loads or a download finishes, the usage drops back to the smaller saw tooth pattern from 10% to 30%. When I disconnect, the usage goes back to a straight line around 3%. Device Manager shows no conflicts and everything running with no problems.
See less See more
1 - 2 of 3 Posts
Not open for further replies.