Tech Support Forum banner

DVD/CD drive doesn't recognize discs

14529 Views 14 Replies 3 Participants Last post by  dai
I am trying to fix problems on Windows XP Home edition accessing CD or DVD discs. The system doesn't seem to recognize discs inserted into the drive. I installed a new drive, a LITEON DVD/CD re-writer, to replace an older drive that seemed to stop working. Yet, the new drive fails in a similar way to the old drive that I just replaced. The drive appears in the BIOS, in the Device Manager, and in Windows Explorer. But it doesn't recognize a new disc inserted into the drive. If I reboot the system with a disc in the drive, then I can access the disc's contents in the usual manner, but once I eject the disc and insert another disc, then it fails again the same way. I've installed all the latest service packs and updates, and have tried to update the driver, but to no avail. Furthermore, burning a disc seems to work, and I can read the newly created disc on another computer, but not on the computer that is failing.
Not open for further replies.
1 - 15 of 15 Posts
Do you have any third party software installed which is able to lock the drive...such as InCD??? If yes, try uninstalling those type of programs as that may be the cause.
I tried both suggestions, but saw no change in the mode of failure .

First, I uninstalled InCD. After rebooting, I observed no change in the mode of failure. Then, I selectively killed various processes in Task Manager to see if I could effect any change in behavior. I was not able to identify any programs/tasks that affected the mode of failure.

After rebooting, I followed the suggestion about removing the upper and lower filters by modifying registry entries.
Although filters were present, their removal did not cause any apparent change in system behavior, and no change in the mode of failure.

Got any other suggestions?
Perhaps there is some way to determine what software gets executed when a disc is inserted, and hence what might be causing a conflict.

To elaborate further on the mode of failure, when I insert a disc, I see the DVD/CD drive light go on solid for a few seconds while the hard drive light flashes a bit, suggesting something is getting loaded and executed by the OS. I also observe a subtle change of behavior in Windows Explorer, as it seems to be able to sense the presence or absence of a disc, and the type of disc (it displays either CD-Drive D: or DVD-Drive D:) but it never displays the content of the disc, as if something is preventing it from reaching the point where it recognizes the file system on the disc. Furthermore, Windows is configured to prompt for the action to take when a disc is inserted, yet I never observe the pop-up window prompting for a program selection.
See less See more
in the device manager uninstall the drive then right click and scan for hardware changes
I have tried uninstalling the drive and scanning for new hardware. I have also searched for an newer version of the driver. It doesn't fix the problem.

The Microsoft Knowledgebase article you mentioned refers to the OS not recognizing the drive, but the problem I am having is that the OS doesn't recognize a removable disc when inserted into the drive. Yet, everything works fine if the disc happens to be in the drive when the machine is re-booted.

My hunch is that something has broken the chain of events that occurs when a disc is inserted. That chain of events must include: notification of insertion of a new disc, determination of the physical disc format (CD or DVD), recognition of the content of the disc, and invocation of an application.
uninstall and reinstall your burning software
That still didn't do the trick. I booted the system with the NERO OEM disk in the new drive, and installed the burning software, and rebooted again. The problem still persists.
did you uninstall if first before running the install
recheck the jumpers on the drive and that you are usuing an 80 wire ide cable
master goes on the end and slave in the middle
Yes, I uninstalled everything before reinstalling.
Here is the hardware configuration:

Primary IDE Controller:
80-wire IDE cable
Master: ATA-100 hard drive, jumpered,
connected at end of cable.
Slave: None
Transfer Mode: Ultra DMA 5

Secondary IDE Controller:
40-wire IDE cable
Master: LITEON DVDRW SHM-165H6S, jumpered,
connected at end of cable
Device Driver Version: 5.1.2530.0, Microsoft
Slave: None
Transfer Mode: Ultra DMA Mode 2

I find it hard to believe it could be the 40-wire IDE cable, as opposed to an 80-wire cable, considering that everything works perfectly if a disc is present during boot.

I searched LITEON's website for technical support, at, and saw an identical problem description, that they suggested could be fixed by removing the UpperFilters and LowerFilters in the registry. Unlike the MS knowledgebase article you referenced, it included two additional registry ControlSet entries, and I tried their suggestion also, still to no avail. I sent their tech support an email, with a URL to this thread, and hopefully they will join this discussion too.
See less See more
dvdrw drives for the last couple of years require the 80 wire ide cable to function correctly
i use liteons normally had to buy a pioneer last time as it was all my supplier had in stock
I tried using an 80 wire IDE cable, the failure persisted.
I tried disabling all system startup programs via msconfig, still no luck.
I replaced the drive with one from different manufacturer, a drive that works correctly in another system, and reproduced the failure mode exactly.

What other configuration issues, like upper and lower filters, can I check? Everything seems to be indicating it is independent of hardware, and related to a software or configuration problem.
try it in the slave position on your h/d cable,if the h/d is a wd drive you will have to reconfigure the jumper on that as well
In the interim, I found an extra hard disk, substituted hard drives, and installed a fresh copy of Windows XP SP2 OEM on the new hard drive. With a *fresh* version of the OS, on a clean hard drive, everything worked fine, and the problem vanished. Hence, this is clearly software, not hardware, and reconfiguring IDE controllers, going from master to slave using just the primary IDE controller, will make no difference.
Got any software suggestions?
the software that causes the problem is the burning software that installs upper and lower filters
nero incd
image drives ect
uninstalling and reinstalling the software usually does the fix
1 - 15 of 15 Posts
Not open for further replies.