Tech Support Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
462 Posts
Discussion Starter · #1 ·
When i click on the doom 3 shortcut on my desktop the screen goes black as it is changing resolution then i see a quick flash of the doom 3 loading screen then my monitor changes resolution again and i go back to the desktop. The console comes up and here is what it reports:

2008 MHz AMD CPU with MMX & 3DNow! & SSE & SSE2
1024 MB System Memory
128 MB Video Memory
Winsock Initialized
Hostname: shiela
IP: 172.216.189.222
doom using MMX & SSE & SSE2 for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Current search path:
C:\Program Files\Doom 3/base
C:\Program Files\Doom 3\base\u-e-q-mod.pk4 (5 files)
C:\Program Files\Doom 3\base\pak005.pk4 (63 files)
C:\Program Files\Doom 3\base\pak004.pk4 (5137 files)
C:\Program Files\Doom 3\base\pak003.pk4 (4676 files)
C:\Program Files\Doom 3\base\pak002.pk4 (6120 files)
C:\Program Files\Doom 3\base\pak001.pk4 (8972 files)
C:\Program Files\Doom 3\base\pak000.pk4 (2698 files)
C:\Program Files\Doom 3\base\game00.pk4 (2 files)
game DLL: 0x0 in pak: 0x0
file system initialized.
--------------------------------------
----- Initializing Decls -----
------------------------------
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
5151 strings read from strings/english.lang
Couldn't open journal files
execing editor.cfg
execing default.cfg
execing DoomConfig.cfg
couldn't exec autoexec.cfg
5151 strings read from strings/english.lang
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
Initializing OpenGL subsystem
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
...calling CDS: ok
...created window @ 0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...attempting to use stereo
...PIXELFORMAT 10 selected
...creating GL context: succeeded
...making context current: succeeded

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
------------------------------------
sound: STEREO
...using GL_ARB_multitexture
...using GL_ARB_texture_env_combine
...using GL_ARB_texture_cube_map
...using GL_ARB_texture_env_dot3
...using GL_ARB_texture_env_add
...using GL_ARB_texture_non_power_of_two
...using GL_ARB_texture_compression
...using GL_EXT_texture_filter_anisotropic
maxTextureAnisotropy: 16.000000
...using GL_1.4_texture_lod_bias
X..GL_EXT_shared_texture_palette not found
...using GL_EXT_texture3D
...using GL_EXT_stencil_wrap
...using GL_NV_register_combiners
...using GL_EXT_stencil_two_side
X..GL_ATI_fragment_shader not found
...using GL_ARB_vertex_buffer_object
...using GL_ARB_vertex_program
...using GL_ARB_fragment_program
...using EXT_depth_bounds_test
---------- R_NV20_Init ----------
--------------------------------------------
----- R200_Init -----
Not available.
---------- R_ARB2_Init ----------
Available.
Cg not available.
--------------------------------------------
---------- R_Exp_Init ----------
PARAM bloom0 = { 0.199501 };
PARAM bloom1 = { 0.176059 };
PARAM bloom2 = { 0.121004 };
PARAM bloom3 = { 0.064769 };
PARAM bloom4 = { 0.027000 };
PARAM bloom5 = { 0.008765 };
PARAM bloom6 = { 0.002216 };
PARAM bloom7 = { 0.000436 };
Available.
--------------------------------------------
----- R_ReloadARBPrograms -----
glprogs/test.vfp
glprogs/test.vfp
glprogs/interaction.vfp
glprogs/interaction.vfp
glprogs/bumpyEnvironment.vfp
glprogs/bumpyEnvironment.vfp
glprogs/ambientLight.vfp
glprogs/ambientLight.vfp
glprogs/shadow.vp
glprogs/R200_interaction.vp
glprogs/nv20_bumpAndLight.vp
glprogs/nv20_diffuseColor.vp
glprogs/nv20_specularColor.vp
glprogs/nv20_diffuseAndSpecularColor.vp
glprogs/environment.vfp
glprogs/environment.vfp
-------------------------------
using ARB_vertex_buffer_object memory
using ARB2 renderSystem
found DLL in pak file: C:\Program Files\Doom 3\base\game00.pk4/gamex86.dll
copy gamex86.dll to C:\Program Files\Doom 3\base\gamex86.dll
********************
ERROR: wrong game DLL API version
********************
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL



Ive heard that this is caused by an incorrect gamex86 or doom3.exe and them being 'mismatched/inconsistent', i cant reinstall is there anyway i can find out what version i have, i cant remember whether i updated it. if anyone has the version 1.3 nocd patch could you send it to me or sumthin as i think this cud fix the problem.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top