Tech Support banner

Status
Not open for further replies.
1 - 20 of 20 Posts

·
Registered
Joined
·
278 Posts
Discussion Starter #1 (Edited)
I dont know what is wrong with my pc there is no viruses for shure i ran AVG Ad aware and mcafee. I want to do a disk check. I try and then i restart and the ibm tinkpad screen comes up and then the xp screen and after that it goes blank like the monitor is off. Like if you had no ram in. You know but it sounds like it is doing something so i wait and wait and nothing happend. Then i restart and ms dos comes up and and does a ram check and it says ram passed and some other checks of other things. This must mean that i interupted the disk check but what is going on? I am sorry my pc is such a peice of crap!!!! Help? Thank you oh and i was wondering how to do a cover up like by typing it into my run utility with the windows cd in so that it will replace files that are missing maybie that would work?
 

·
Registered
Joined
·
33 Posts
CHKDSK in run will run a disk check, i had simlar come up on my laptop it was doing a diskcheck and i just canceled it and did it when i was on my desktop by doing what i said above. That should make it stop
 

·
Registered
Joined
·
6,641 Posts
Type chkdsk c: /F in start => run (provided c: is the volume letter of your system drive). This way it'll search for bad sectors as well. If it asks to unmount the volume answer no then yes to schedule the test at next restart and reboot the computer. Don't interrupt chkdsk when it's running. Leave it running overnight if needed.

You can check your system files if you own an XP CD provided your CD is the same version as what you have installed. If you have updated your computer to service pack 2 then your CD needs to have SP2 on it as well. If it's XP Pro you'll need an XP Pro CD. If the XP CD hasn't got the service pack 2 on it then you can create a slipstreamed XP CD with SP2 following one of these guides :
http://www.winsupersite.com/showcase/windowsxp_sp2_slipstream.asp
http://www.helpwithwindows.com/WindowsXP/winxp-sp2-bootcd.html

Once you've got the right CD go to start => run and type sfc /scannow (mind the space after sfc). This will run the system file checker which will search for possible corrupt system files and replace them with a good version. It'll ask for the CD if it can't find a good backup on the hard drive.

Repeatedly press F8 when the computer starts and choose safe mode in the menu that will appear. See if it starts faster. If it hangs for a long time on a driver (look for the lines at the bottom of the screen) then tell us about it.

Start the computer normally then go to start => run and type eventvwr.msc. Tell us if there are any errors corresponding to the time the computer took to start in any of the sections there.

Right-click "my computer" => properties => hardware => device management. In the view menu tick "show hidden devices". See if there are any warning signs next to one of your devices there.

Have a look at this thread for more things to try :
http://www.techsupportforum.com/611201-post13.html
 

·
Registered
Joined
·
278 Posts
Discussion Starter #4
I can go to C: -> Properties-->Tools-->Disk Check and schedual it but when i go to restart my pc after the windows xp loading screen(the one with the progress bar the scrolls across reapededly) the screen goes black. Not just black but like its off no light at all. It looks like my pc is off but i hear it running. Then i turn it on and back off and it says some stuff on a dos screen like ram check passed system and vidio bios shadowed and all that and then it starts. But no matter what when i restart my pc (whether or not i tried a disk check) right before the welcome screen it goes black for like 40- 60 sec like the screen is off and then back to normal.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #5
I let it go on the blank screen for about a hour and it started up so it nust be doing the disk check but why would it not show on the screen. I have been having trouble with my display driver in another forum but i though i got the right one now I dont know? Could it have to do with that?
 

·
Banned
Joined
·
468 Posts
That is not normal.

Try booting to safe mode by tapping the "F8" key about once per second immediately after turning it on.

Report results here.
 

·
Registered
Joined
·
6,641 Posts
@ RobbyJK : please follow the remaining of my instructions in post #3.

- Run the system file checker (sfc /scannow with the proper XP CD).
- See on which line the computer hangs the longer when you start in safe mode.
- Go into the event viewer and tell us about the errors you'll see there.
- Check the device manager for non-working devices.

You'll find other clues in this thread :
http://www.techsupportforum.com/611201-post13.html

Please tell us more about your computer specs so that we can help you better : is this the same IBM Thinkpad R31 you're having battery issues with ?
 

·
Registered
Joined
·
6,641 Posts
Were you asked for the XP CD when you ran the check ? If no then your system files are ok, no need to run it in safe mode. Please proceed with the other steps :
- See on which line the computer hangs the longer when you start in safe mode.
- Go into the event viewer and tell us about the errors you'll see there.
- Check the device manager for non-working devices.
Refer to post #3 for further instructions.

And you haven't answered my question : is this a thinkpad R31 or are we talking about another computer ?

Also, make sure that your computer is fully upgraded with the latest critical updates from Windows update. There's no point trying to troubleshoot your computer if XP is not up-to-date.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #12 (Edited)
Yes it is the thinkpad r31 model 2656
yes it asked for the cd and i tryed it now and it still asks for the cd no matter what? But i will do the other steps and post back. But how do i know if the error has to do with start up? There are tons of errors and warnings in applications and system categorys?:4-dontkno
 

·
Registered
Joined
·
278 Posts
Discussion Starter #13
When i start in safe mode it doesnt delay at any exept the last one and that is probly because it is loading windows after that so there is a delay? The driver was mup.sys
 

·
Registered
Joined
·
6,641 Posts
1) When you ran the disk check utility did you check the two boxes to fix file system errors and scan for bad sectors ? If not then please do that now and restart the computer when prompted to do so. Running chkdsk c: /R (not /F like I said before, my mistake) from the run command will do exactly the same. This will test your hard drive cluster by cluster for errors which will take a long time, possibly more than one hour. Don't touch the computer until you're back in Windows.

Once in Windows go to the event viewer (start => run => eventvwr.msc), go in the application section and search for the entry called "winlogon". This is the log report of the disk check utility. Double-click that entry and use the third button on the right to copy the information in the clipboard then paste it (right-click => paste) here.

2) Please answer my other questions, they're part of the troubleshooting process and we can only move further until you've answered them all :

- Are there any non-working devices in the device manager ? Go to start => run and type devmgmt.msc. Click view => show hidden devices. Do you see any device there with a yellow warning sign or a red cross next to its name ?

- Have you done all the latest critical updates from windows update ? Go to start => windows update and follow the instructions from there.


3) If sfc asks for the CD it means it found errors in your system files and need to replace some of them. Do you own an XP CD or was XP already installed on the computer when you bought it ?

If you installed XP yourself with a retail XP CD then follow the instructions from post #3 to create an XP SP2 install CD and insert that CD when sfc asks for it.

If XP was preinstalled and all you got with the computer is a recovery CD then look on your hard drive for a folder called I386. It may be under the Windows folder (in Windows Explorer go to tools => folder options => view and untick "hide operating system protected files" so that you'll able to navigate in the system folders) or somewhere else on the drive. Once you've located that folder, copy it to the root of your system drive so that it becomes C:\I386 (if it's already there then all the better). You'll need to change a value in the registry so that sfc will look for that folder instead of the CD : go to start => run and type regedit to run the registry editor. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup
Double-click on "SourcePath" on the right and type C:\ in the box that comes up. Then close regedit, restart the computer and rerun sfc /scannow.

If you can't find any I386 folder on your hard drive then look for one on the recovery CD. If it's in the root of the CD then simply insert that CD when sfc asks for it. If it's elsewere then do as above : copy the folder to C:\I386, edit the registry and rerun sfc.

If you have no recovery CD then contact IBM/Lenovo to get them shipped to you, they may come in handy and will be your only way to reinstall XP should the hard drive physically fail one day.

Tell us if you were able to replace the corrupted system files with sfc.


4) In the event viewer, double-click the errors and use the third button to copy the information to the clipboard then paste it (right-click => paste) here. If there are several identical errors (identical means same source and same event number) then paste it only once but tell us roughly how often that given error occurs.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #15
Ok fist off i patched one of my files to allow third party xp themes to be used so i will run the sdf scannow and re patch it. one quesiton i have is i also have a vista emualtion file in system 32 to allow vista games to run on my xp system. And third i i have alkey for applications installed now so that i can have the vista sidebar on my xp system. If i go through with this process will it mess up my system?
 

·
Registered
Joined
·
6,641 Posts
I said it already but I'll say it one more time : we can only help you efficiently if you answer all of our questions. It's the only way for us to identify what the problem is. Please answer the following questions :
- Is this computer updated to the latest updates in Windows update ?
- Are there any problems in the device manager ?
- Tell us about your errors in the event viewer.
- Tell us how the chkdsk scan went. Please send us the report which you'll find in the winlogon entry in event viewer => applications.

It's safer to uninstall the vista sidebar and any desktop replacement utility you have installed. Those things can be a pain in the a** and are known to create stability issues. It's possible that it creates problems with the system file checker if some files and settings are replaced and others not.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #17
Yes it is updated. The cd i installed had up to sp2 and since then i have updated a few times auto updades.

No problems in the device manager at all.

IN event viewer all the ones that are under the source of winlogin just have information no errors and the info is that the shell stopped unexpectadley and explorer.exe restarted

That is all that is in there? So
 

·
Banned
Joined
·
468 Posts
- Tell us how the chkdsk scan went. Please send us the report which you'll find in the winlogon entry in event viewer => applications.

It's safer to uninstall the vista sidebar and any desktop replacement utility you have installed. Those things can be a pain in the a** and are known to create stability issues. It's possible that it creates problems with the system file checker if some files and settings are replaced and others not.
The less responsive/more difficult the User, the less likely to get help.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #19 (Edited)
Ok well i dont know how to uninstall the side bar it was one of those zip files that came with an install .ini file that you right click on and the option to install is in the menu. Can you help me to uninstall that?


Anyways i did the disk check and nothing new in event viewer. OH and just to let you know i dont think it does the disk check because i left click on c: and choose properties=>tools and disk check and i check the two boxes and push yes then it tells that it can do the disk check do you want to schedual it for the next time you restart and i push yes. Thats normal but when i restart, as i said before, after the bootscreen it goes completely bllack for like 1 hour then it completely restarts. It goes back to my ibm thinkpad screen then to the xp bootscreen and blank for about 10 sec and then to welcome. (I dont have a password) Usually when i do disk checks it dont restart after it just finished starting up. I dont know? I geuss i could take it in and get help. This pc is old so. Maybie my ram is bad or something. Im getting more sooon! But yeah i have windows blinds which i paid for so not uninstalling that and i patched one of my windows files so i could apply third party themes and i can either run the program agian to unpatch the file or run the sdf/scannow thing. As for the side bar i would like to uninstall it so if you could help me. That way i can uninstall alkey for aplications. But just to let you know all of this started a long time ago before i had any of this stuff exept windows blinds i had that. It was like right when i got a new hard disk and installed windows. I started to download all the stuff i had before like avg and adaware all the security stuff and then after like that first week one day i tryed to start the pc and i turned it on and the screen was black and stayed black as if i hab bad ram or my ram needed to be reseated. so i reseated the ram and it was fine but it scared me and i wanted to do a disk check and this is when i discovered the problem. It worked fine before that happend because i checked everything when i installed avg and adaware and my firewall and all that. Sorry such a long message?:wave:
 

·
Registered
Joined
·
278 Posts
Discussion Starter #20
I reinstalled windows was sick of all the problems started fresh and new clean up to sp2 on the intall cd and updated three times. Explorer updated and all. I do think that my display driver is the blame for the Disk check not working. Because when I installed windows there was no blank screen after windows xp bootscreen and as soon as i installed the display driver that was recommended in another thread it started that again. I havnt tryed to do a disk check yet because i just got my pc back to normall and im scared to do it? But anyways thanks!
 
1 - 20 of 20 Posts
Status
Not open for further replies.
Top