Tech Support banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi,
Im using a riva TNT 2 32 MB display card on a ME O.S .
My RAM is 64 MB and whn i had fixed my card , i had abs no probs with Dx 8.0 loaded... But thn whn i loaded 8.1, i started exp. probs tht my videos wuld freeze so i upgraded my drivers and videos work perfectly fine but my games dont wrk whn i looked into the prob inside Dx, i found tht direct draw tested fine but my direct 3d caused the system to hang... when i test Direct 3D i get the followig error:
Direct3D 7 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x80004005 (Generic failure)
Direct3D 8 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)
Direct3D 9 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)
I have now loaded Dx 9.0 and 44.03 drivers but as bizzare as it may sound, my Direct 3D begins working at 9:00 pm every night and at morning the DIrect 3D is back to the error! ive seen this trend for 3 nights now! Is this some kind of a virus im sure windows doesnt need reinstallation if it does work every night...
Plz plz help me ive tried everything under the sun!
Thnx.
PS:this is my Dxdiag log:
------------------
System Information
------------------
Time of this report: 8/13/2003, 12:31:40
Machine name: ANMOL
Operating System: Windows Me (4.90, Build 3000)
Language: English (Regional Setting: English)
System Manufacturer: VIA Technologies, Inc.
System Model: VT82C692BX
BIOS: Award
Processor: Intel Pentium III, ~730MHz
Memory: 64MB RAM
Page File: 65MB used, 1918MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0 (4.09.0000.0900)
DX Setup Parameters: Not found
DxDiag Version: 4.09.0000.0900 32bit


---------------
Display Devices
---------------
Card name: NVIDIA RIVA TNT2 Model 64/Model 64 Pro
Manufacturer: NVIDIA
Chip type:
DAC type:
Device Key: Enum\PCI\VEN_10DE&DEV_002D&SUBSYS_00000000&REV_15\000800
Display Memory: 16.0 MB
Current Mode: 800 x 600 (16 bit)(optimal refresh rate)
Monitor: AcerView 34T
Monitor Max Res: 1024,768
Driver Name: nvdisp.drv
Driver Version: 4.14.0010.4403 (English)
DDI Version: 7
Driver Attributes: Final Retail
Driver Date/Size: 5/2/2003 15:19:00, 107296 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
VDD: *vdd
Mini VDD: nvmini.vxd
Mini VDD Date: , 0 bytes
Device Identifier: {D7B71E3E-436D-11CF-8372-0A20B4C2C935}
Vendor ID: 0x10DE
Device ID: 0x002D
SubSys ID: 0x00000000
Revision ID: 0x0015
Revision ID: 0x0015
Video Accel: ModeMPEG2_A ModeMPEG2_B ModeMPEG2_C ModeMPEG2_D
Deinterlace Caps: n/a
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: Not run
D3D7 Test Result: Failure at step 8 (Creating 3D Device): HRESULT = 0x80004005 (Generic failure)
D3D8 Test Result: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)
D3D9 Test Result: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)
 

·
Registered
Joined
·
6 Posts
Here is what fixed my directX incompatibilities - I dont' really have enough info to guarantee if your situation will benefit from this but here goes:

1. terminating the Terminal Services process (you prolly don't need it, unless you run remote desktop or something, just disable it)

2. making sure that Netmeeting is uninstalled
(here's an article that shows you how for win2k and winxp)

click here

3. making sure your AGP port drivers are re-installed (if you have a via-based board these would be the 4-in-1 drivers, most recent version, prolly, check with your manuf.

(maybe 4) don't install the latest signed nvidia ref. driver if your card is not an FX model. at the time of writing it was 4.5.2.3
I rolled back to 4.5.2.0 and it works great.

I'm sure other people with similar errors but different configs will have luck with other methods (ie. running netmeeting and then windows desktop sharing, then disabling desktop sharing, then disabling direct3d accel. then enabling direct3d accel.) but the 3 checkpoints above worked for me, so i think they're not a bad starting point, and they don't involve having to re-install 8.1 or 9.0 or 9.0a or 9.0b. Crikey, if MS would just get it right the first time

my system: for reference is in my profile.

I hope this helps someone avoid a sleepless night like the one I had. if it did - send me a mail cheers.
 

·
Registered
Joined
·
1 Posts
I've got pretty much the same problem as Alcazar: my Direct3D tests give me the same error messages. I recently upgraded my processor from a P-3 550MhZ to a Celeron 2.4Ghz, but that and the motherboard are the only things I've changed. I simply can't understand why this error is occurring, because everything worked perfectly on my 550MhZ. I've got DirectX 9 and the latest NVidia drivers (45.23) for my GeForce 2 MX 400 on my system. This just doesn't make any sense, and I'm at my wit's end!
 

·
Registered
Joined
·
6 Posts
something else that might help is to
completely uninstall your display drivers using add-remove programs, then diligently elminate any leftover files associated with prior drivers. then download the directX re-distribution package, extract to a folder, then extract the cab files and 'install' the inf's one at a time for every folder. if you get an error message, just move on to the next folder because that means it's not intended for your OS.

then re-install directX using Setup, and then re-install your display adapter.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top