Tech Support Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello Friends,

I am a completely non-technical person when it comes to laptop hardware or software. So, I am in the most helpless situation at the moment.

My laptop - Dell Inspiron 1525 just completed 1 year (April 2009), and just 5 days later the Battery started working mysteriously. Sometimes I would find 'Battery not detected' and sometimes the message was ' zero percent battery, not charging'. I called up Dell and was informed that I would need a new battery. As my work doesn't require much travelling my laptop ran less than 10 hours on battery in the last year. So I thought of using it anyways without a new battery on power. But last week I am finding great problems, as every 15-20 minutes the system hangs and gets power off (even when its running on power).

Can please someone suggest what the problem is. And what might have happened. what should I do now?

Please help.

Thanks in regards,
 

·
Registered
Joined
·
1,551 Posts
Modern batteries need to be used. If not they tend to die. You shouldn't have any probs running without the battery. I ran a Compaq for three yrs without one. Try looking in the power settings. Should be in the Control panel.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
@TriggerFinger - I checked the BIOS, and it says "battery not recognized"

@belfasteddie - You mention 'modern battery'. can you please explain the term. The battery that was in my laptop, was already there when I bought it last year. I was not asked for any option. But, yes, I believe I also can run the system without buying a new one unless I want to use it while travelling. (which I don't do) My problem was the instant shutting down of the system every 15-20 minutes even while running on power... :sigh:

@Captainmark, I tried taking out th faulty battery as you had suggested and now its working fine for 4 hours on power without any problem! I will see if this works...

Thanks to all for your suggestion. Just an afterthought, do you guys think there might be a problem with the motherboard?
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top