Tech Support banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
327 Posts
Discussion Starter #1
Hi there.

I am using a Creative Extigy as my sound card. I installed it today, for some reason I have to have the wave levels set to about a quarter so it doesnt distort. Is this correct??

The sound doesnt sound as good as it did before on my Realtek AC97. Although I dont know why that is.

Also, is there anyway to plug my Xbox into it? so the sound goes through the Extigy?

Thanks
Amnesia
 

·
Registered
Joined
·
1 Posts
hello!
I'm also a Creative Extigy user and I accidentaly scratched my driver cd.I tried to find the driver on the internet but I couldn't find it anywhere.can you send me the driver please?my yahoo messenger ID is Email link removed if I make my sound card work I can help you with your problem.thank you!
 

·
Premium Member
Joined
·
2,430 Posts
Amnesia 180, did you disable the onboard audio in the bios?

Paolo12, we do not barter for help here on the forum, if you need a new driver cd for your Extigy you can usually purchase a new one from Creative (call their customer service) for about $5-$14 incl shipping. Nor is it wise to link to your email address on the forum as someone trolling the website could send you spam or worse, as such I will remove the link to your email, in the future you can send someone a private PM if you wish to exchange email addys.

twajetmech, moderator
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top