Tech Support Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have been having this problem for a while now. I have re-installed Mozilla severl times and have kept my computer free of infections,spyware etc.(as much as possible). What happens is; i would install Mozilla, the installation would be a success but when i would try to open Mozilla to browse the internet, Mozilla just won't load. If i were to press Alt+Ctrl+Del and check the processes, Firefox would be running but it hasnt loaded on my screen:4-dontkno. I've read on otehr forums to clean up my CPU, i have done so but i still have the same problem.
I would really like somebody to help me on this because i really don't like using explorer and mozilla owns. :D
Thank You.
 

· Registered
Joined
·
560 Posts
Hi Foxxy,

This can usually be caused by incompatible extensions, assuming you have some installed of course!

Open Firefox in Safe Mode - Start > Programs > Firefox (or Bon Echo, Minefield, Gran Paradiso (whatever version you're using)) and use the safe mode option.

Open the Add-On's manager (Tools > Add-On's) and disable your extensions. Close from safe mode and reopen normally. Now enable your extensions one or two at a time and restart Firefox. That way you'll weed out any dodgy extensions.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hi Foxxy,

This can usually be caused by incompatible extensions, assuming you have some installed of course!

Open Firefox in Safe Mode - Start > Programs > Firefox (or Bon Echo, Minefield, Gran Paradiso (whatever version you're using)) and use the safe mode option.

Open the Add-On's manager (Tools > Add-On's) and disable your extensions. Close from safe mode and reopen normally. Now enable your extensions one or two at a time and restart Firefox. That way you'll weed out any dodgy extensions.
Oh Keith you legend :D

Thanx so much man!
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top