Tech Support banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
For a while I was using a switch for the network at home, but then the fileserver I was using with the switch died. So I instead bought a router this time and everything is working pretty well but there's a small inconvience now. Every so often windows will pop up a window saying that "a network cable has been disconnected" and I'll lose my connection for a few seconds. This isn't really too big a problem but it's annoying as I sit on IRC and sometimes it'll sit there for hours before it finally disconnects. I've never had this problem before with my switch so I know it came about when I got the router.

So my question is, how can I get my router to stop losing the connection randomly?

My router is a linksys wired router BEFSR41v4. I have already downloaded the most recent firmware for it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I went to control panel -> network connections -> right click properties on my connection -> set it to force 100 full duplex. But it seems the problem is still there. Anything else to try or did I do the wrong thing? I wasn't sure how I was supposed to set my nic to that setting so I just kinda wandered around.
 

·
Registered
Joined
·
5 Posts
Check your event viewer to see if there is some kind o IP address conflict. You said you went from a switch to a router. Are all of your computers on the network assigned a static IP address, or is the file server also a DHCP server. If that is the case, you would have make sure DHCP is turned off in the router.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
The fileserver is what died so that's no longer part of the network. Yes there is a log of an event in event viewer from the source Tcpip that corresponds to when IRC stopped responding.

I followed a guide on setting up a static ip address on this computer, but I haven't done the process on every other computer on the network.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Ok so I've assigned a different ip to each computer on the network, but I'm still having random disconnects. I don't think I can disable DHCP on the router as that's what gives the other computers on the network their IPs.

I guess I should clarify how this network is set up. Before it was cable modem -> fileserver -> switch -> this computer + wireless access point -> rest of the computers. Now it's cable modem -> router -> this computer + wireless access point -> rest of the computers.

As it current stands, I have this computer's nic set as JamesO suggested, each computer has its own static ip set, and the router's DHCP is enabled. Anything else I can do?
 

·
Citizen of the world
Joined
·
51,047 Posts
Well, I see an obvious thing that would make this network work loads better! Get rid of the link between the computers and allow all the systems to connect directly to the router. Depending on the WAP, you may be able to simply connect it directly to the router, or failing that, find a rebate deal on a wireless router. Routing all the systems through yours is a recipe for problems.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Heh, I knew I'd say it wrong. The cable modem goes into the router and I plug this computer into the router and I plug the WAP directly into the router as well. So nothing goes through my computer, yeah doing that would really be pointless.
 

·
Citizen of the world
Joined
·
51,047 Posts
OK, that makes more sense. :smile:

Have you looked for sources if interference with the 2.4ghz WiFi signal? Microwave ovens and cordless phones are two possibilities.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top