Tech Support Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I desparately need some VERY SPECIFIC help. This may be a NEW problem for most BUT as MORE computer are being sold with HD screens and added-on or built-in TV Tuners, you will see this, and similar, more and more often.

FIRST OFF, I KNOW ALREADY how WMC works (or is supposed to!) and have set it up for use with a cable box before many times, so PLEASE do not send me all the links for "How to ......" articles - they do NOT apply!

This is a very isolated and specific problem. THe details are as follows:

I am trying to set up my WMC on my HP Envy 17 laptop to enable me to watch cable TV on my laptop and control the channels (OS is Win7x64SP1). This is done by the use of my add-on, USB TV Tuner, made by Hauppauge, model HVR-950Q. Normally this isn't a problem (I used it with Comcast cable for quite some time); been there, done that.

HOWEVER, I just recently changed ISPs and Cable provider to ATT & Uverse. BE WARNED!! Uverse & ATT Tech Support makes HP Tech Support look good! Nuff said?

The WMC can set up the TV signal either automatically if it knows or recognizes the make/model of the set top box. Most often this is done manually. In order to control the set top cable box, your computer has to be able to "see" and read IR codes sent out my almost all remotes (there are a VERY few RF and sonic ones left out there, but this ATT one is regular IR). It also has to be able to SEND IR commands to the set top box just like the hand held remote. This is done by using the MCE Kit which consist of an IR Sensor and a IR Transmitter (called a IR blaster). This device is plugged into the USB port; Windows already has the drivers for it, so it's basically plug & play.

Well, my Uverse comes with a set top box made by Cisco. Brand new, but has a remote and works just like any other and looks like most look with the same buttons, etc. The Cisco box is also a wireless receiver and a DVR, but I don't think that really impacks this problem.

When you manually set up WMC for the TV and control of the set top, it has to "learn" the IR codes from the ATT remote. Normally, these remotes use one standard set of codes or another so if WMC can figure out which set it uses, you are done, home free.

IF NOT, as is the case here, then it has to LEARN the needed codes one by one by pressing specific buttons on the ATT mode so that the MCE Kit sensor can "see" and learn them. It's exactly like any universal "learning" remote. The process is the software ask you to press a button and then to hold it and then to release. Once a button is learned it asks for the next and so on.

Only problem is that, for reasons unknown and totally non-sequitor, WMC can NOT learn the IR codes from the ATT remote!! I tried everything. Holding it close,far away, at an angle, in contact, etc., but I never get past "press 0, hold, release". Clearly it sees a code and reacts to it, but WMC never "learns" or records or saves it or whatever. Stuck on ZERO, literally! LOL (oh, that hurt!)

The Cisco/ATT set top box is a model IPN4320, if that mneans anything to anybody.

HAS ANYONE OUT THERE GOT THIS COMBINATION OF HARDWARE TO WORK? Anyone ever hear of this problem before? Has anyone worked, succesfully or not, with this Cisco/ATT set top box? Please let me know.

I have checked and verified that all parts of the MCE Kit are working. I have reset/reloaded the software/OS and my computer checks out 100%. ATT says their hardware is also showing green across the board.


I have talked, until my voice gave out, to ATT Tech Support, Uverse TS, Cisco and Hauppauge and NONE of them want to claim responsibility or even address the problem. They a;; shout "third party" and run away. Frustrating.

did find one fee based TS that wanted $200 to just consider the problem, but they offered no guaranty or warranty for their work, but they would be happy to collect $200 to play around with my system. None of them that I talked to had any idea how the WMC works or what a MCE kit was - like talking to a 4 year old - but hand over the money! No thanks.

Your help and advice would be appreciated. The usual how to links and articles are ueless here but someone, somewhere, must have tried to marry up WMC and Cisco before! I can't be the first! Can I?

Thanks in advance (hopefully)! Happy 70th birthday to Dr., Stephen Hawkin! Many more!

Bob, the OldeGreyWoolf

 

·
Registered
Joined
·
2 Posts
@OldeGreyWoolf

I HAVE THIS EXACT PROBLEM. Im running windows 7, service pa ck 1, i have a media gate remote, with reciever and problem, and like you just recieved a Cisco CIS330 STB, also known as Scientific Atlanta CIS 330.

Either way i have not found a viable solution other than replacing some ir driver dll files and then writing the CCF files myself for Media Centers modified drivers to send to the IR blaster, but this is all way beyond my ability and knowledge with PCs. As well, i believe their remotes use toggle codes ( meaning it sends different frequency signal everytime u press the same button), therefore media center cannot learn the code. The only way to get around that is to do what i mentioned above, detailed on this helpful, but overly technical page here MCE Remote Replacement Driver FAQ


I have settled for just using two remotes, my STB one, and my PC one for media center.

If anyone else has any useful or easy suggestions around this problem, please let me know as well.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks. That solution of rewriting the IR drivers is a bit beyond me also. Your response is the closest thing I've seen so far, anywhere. If you find someone who HAS done the rewrite, I'd appreciate a copy of those drivers.

Not sure I agree with the toggle idea though. What would be the advantage or reason for such a rotation toggle function? It's my understanding from talking to the Logitech Harmony Remote support techs, that the signals sent when the button is pressed is a digital sequence It should send the same code set each time for any particular device. My guess, and it's ONLY a guess, is that the common code sets are of a fixed number of digits long by industry agreed upon convention. Say each code send is 20 digits long. I suspect that the ATT remote sends a greater number of digits than is the standard convention, say 30 digits. I think that's the reason WME can't "learn" the ATT remote is that it only has "room" to learn just 20 out of those 30, hence the failure. I suspect that this was done in anticipation of coming additional functions that would require the larger code sets. Planning for the future so to speak.

I tried calling Cisco but got stonewalled. They are unwilling to discuss information on their proprietary devices. Does that sound about right to you? I can't really think of any advantage to toggling the codes and matching to the receiver would be near impossible, since you could press a command button when the remote was NOT directed toward the receiver which would toggle the remote, but how would the next button press be understood by the receiver. How would you keep the receiver in sync with the remote?

Food for thought, eh?

Bob Woolf
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
BTW, my work around solution was to not use the WMC or MCE at all. I only used WMC to watch and record TV, so I just got the ATT DVR and since I have an Hauppauge HVR-950Q tuner, I just used their WinTV 7.2 app to watch the channel 3 output of the ATT box and now use the ATT remote only.

It actually works even better than WMC and has a better picture plus record and snap shot functions as well as the usual pause and replay. If you don't have a Hauppauge, there are several other apps for just about any tuner. Blaze is a good alternative. What type tunner do you have?

Olde Greywoolf
 

·
Registered
Joined
·
2 Posts
I have a Hauppagge HVR 1250 PCI-E, it has its own remote, but i prefer my MediaGate one, because it has an IR blaster as well. I've tried Win TV, but still prefer Media Center because it allows me to browse files and movies too, as well as shut down my PC in the prgram.

I might try some other programs out and what you suggested.

As for the toggle codes, i undertand it it has a few sets of codes for each command, which seems really redundant, and pointless ( why are they basically encrypting the signal?) maybe cause Cisco makes routers primarily. who knows, but your other suggestion might be whats being done, It would make alot more sense than using toggle codes.


Anyhow, if i find any pre-written drivers or info, i will send a link your way. I'm sure as they sell more STB's to service providers more and more people will end up in our situation, so someone is bound to make a solution.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top