Tech Support Forum banner

Computer power up problem

1342 Views 6 Replies 4 Participants Last post by  oscer1
Hi

Recently I've been having very frustrating problems with my computer. About a month ago, the computer started not powering up at times. Basically all it showed was a blank screen when I powered up, no beeps no nothing. This only happened if I turned on/off the computer within a minute, otherwise, it would turn on fine. (If I turned the computer off, I wasn't able to turn it back on until 2 minutes or so or the blank screen problem would persist)

Now it's gone from irritating to straight up bad, I can't use my computer at all. I power it up, blank screen no matter what. Everything is plugged in properly, so I don't understand why this is happening. Can someone help?
Status
Not open for further replies.
1 - 7 of 7 Posts
Try unplugging all of the wires and holding the power up button for a minute or so. This removes static electricity inside of the computer which might be the cause of the problem
PC Specs?
Pre-Built Brand & Model Number
Custom Built-Brand & Model of Mobo-CPU-RAM-Graphics-PSU.
PC Specs?
Pre-Built Brand & Model Number
Custom Built-Brand & Model of Mobo-CPU-RAM-Graphics-PSU.
Pre built Canada Computers:


Windows 7
4GB Ram DDR2
Asrock G41M-VS2 Motherboard
500GB Hardrive
Standard 500watt supply
HD 4650 Card
Dual Core e5400



Some people on another forum said it was probably the power supply, but truly, I don't have the money to go around buying parts until it works. I need to know THE culprit.
See less See more
Your problem relates to a power issue and I suspect your included 500W PSU is low quality.
We recommend a minimum 550W good quality PSU for any PCI-E GPU.
I went out and bought a new psu and I'm still having the same problem. I boot up, every fan is spinning and the screen is blank, with no bios or anything.
1 - 7 of 7 Posts
Status
Not open for further replies.
Top