Tech Support Forum banner
Not open for further replies.
1 - 2 of 2 Posts

· Registered
244 Posts
Discussion Starter · #1 · (Edited)
Hi There,

I help people fix up their computers in my spare time. In the last few days, I have run across this same problem not once, but twice! And I'm somewhat baffled as to what might be causing it. I thought I'd throw it out there and see what you guys thought.

Simple standard desktop computer. Standard printer. All of a sudden when the user tries to print, they get the following message:


Here is what I have already tried:

- I checked the "Printers and Faxes" window and the printer is definitely installed and set as the default printer.

- I checked the Device Manager for any problems with the printer driver. I uninstalled the printer and then "scanned for hardware changes" and it re-appeared back in the Device Manager. I assume that means it re-installed itself. NOTE: There is a problem with a network driver, but I'm not sure that it's related to the printing problem.

- I tried to print a test page via "properties", but nothing comes out. The error message appears again.

- The printer is turned on and has sufficient ink.

- The USB cable between the pc and the printer has been unplugged, plugged back in, even replaced in one case.

- I checked the print spooler. In one case it is running, and in 1 case it is not running. In the case where it is not running, the only dependency is the RPC, which is running. I can not get the print spooler service started however. I tried starting changing the startup type to Manual and clicking [Apply], but at no time does the [Start] button become "pressable" (stays dim). I'm not sure this is a print spooler issue anyway, since in one of the cases the print spooler is running just fine.

I'm really not sure what else to try. This seems to be coming up more and more, and I would really like to offer these folks a solution.

So any help you guys could give me would be GREATLY APPRECIATED! Thank you in advance.

· Registered
14 Posts

Is it possible to test the printer in another computer to rule out the possibility that the printer is faulty ? I would also like to know what is the model of the printer /printers.

There are few things I would try to fix this problem,
on the computer where the print spooler won't start in command prompt
sfc /scannow to check that one of these files might be corrupted
also it spooler issue could be problem with registry, unfortunately I don't
know that area too well.

The problem could also be usb drivers related, (before using this I suggest making restore point just in case)

Unplug all usb devices and boot computer to safe mode.

Go to Device manager, in the view Tab Select the Show Hidden Devices Option

Uninstall Human Interface Devices\USB Human Interface Devices and\or Composite USB
Uninstall Universal Host Controllers\USB Root Hubs
Uninstall Universal Serial Bus Controllers\USB Host Controllers
Uninstall All USB devices Printers. Scanners, Etc

Reboot computer to normal windows, it will automatically reinstall the usb controllers.
Windows might ask you to restart your computer, do that if prompted.

Go to Printers and Faxes and click File
Select Server Properties
Open Drivers Tab and remove all drivers
Install your printer software and now plug your printer.
Test Printing, if the printer still doesn't work on the printer
Select Properties and go to Advanced Tab,
Click New Driver
Choose Generic Manufacturer and on the right select Generic / Text Only
and click next, you might be prompted for xp cd to install the drivers.
Try printing again. If this won't work then im out of solutions :4-dontkno
1 - 2 of 2 Posts
Not open for further replies.