Tech Support banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I Really Need Help With This One... Any help would be appreciated

I made a very stupid mistake when configuring my Cisco 1700 router for broadband use at home. I made the following configuration based on the guidence of some jerk who posted on a website. Obviously I did not know what I was doing.

ip nat inside source list 1 interface Ethernet0 overload

As you may have guessed, this overloaded NVRAM on my Cisco 1700 router and now I receive the following message when starting up:

INSUFFICIENT MEMORY TO LOAD IMAGE

I can not boot into EXEC mode. I can only get into ROMMON.

The NVRAM is overloaded with garbage and I need to clear it out and get this router functional. Any help would be appreciated. Any additional details you need please ask. I will be monitoring post frequently.

Thank you in advance.
 

·
Registered
Joined
·
86 Posts
Hi. Very strange. Did you upgrade the IOS (boot image) at all? The command listed should not have done what you are describing and is a valid NAT command. The 'overload' refers to the interface being able to use its IP address for multiple clients - a must if you have more than one PC that needs access to the Internet. That being said, the following will restore a default configuration for you and get you router up and running again - ASSUMING THERE ARE NO HARDWARE ERRORS such as a faulty memory chip (I suspect this).

WARNING -- THIS WILL ERASE ALL OF YOUR SAVE CONFIGURATION!!!!

This means you will have to reconfigure you interfaces again and any other settings you had configured on your router after rescuing it. This shouldn't be a problem if you had a backup of your config on a TFTP server.


------------------------------------------------

Type "confreg 0x2142" at the "rommon 1>" prompt and hit 'enter'

This step bypasses the startup configuration on boot up

Type "reset" at the "rommon 2>" prompt and hit 'enter'

The router will reboot, but ignore the NVRAM configuration.

Type "no" after each setup question, or press "Ctrl+C" in order to skip the initial setup procedure.

Type "enable" at the "Router>" prompt and hit 'enter'

This will put you into the power user mode "router#"

Type "conf terminal" at the "Router#" prompt and hit 'enter'

This will put you into the configuration mode "router(config)#"

Type "config-register 0x2102" and hit 'enter'

Press "Ctrl+z" or type "end" in order to leave the configuration mode.

The "router#" prompt appears.

Type "write memory" or "copy running-config startup-config" in order to save the default startup configuration file to NVRAM.

Type "reload" and hit 'enter'

The router will reboot, and should start with basic configuration.

-----------------------------------------------------------

If you still have an issue I am sure I can help you as I have had 10+ years experience working with Cisco routers and switches.

Cheers

Wiz
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thank you for your help!!!

I have tried to do what you have instructed prior to posting this thread. I can not get to "router>". The router gives me:
-----------
INSUFFICIENT MEMORY TO LOAD IMAGE!
The difference between Memory required and Memory available is the additional
memory you need to run the router. Alternately, use a smaller image; this
may cause the memory requirement to decrease, and may allow you to at least
use the router with reduced functionality until you get more memory.


*** System received a Software forced crash ***
signal= 0x17, code= 0x200, context= 0x8000630c
PC = 0xffffffff, Vector = 0x200, SP = 0xffffffff
----------

Once this happens the router continues to try and reboot itself and then eventually dumps me back at rommon. I had the router working with the following config for 1 day and then I brought it to work to work on and then I started having this problem.

------------
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname RouterA
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$qIKM$Pl4NfLu6/UVVoKgPV.oxg/
!
username Jeff password 7 11231554454B535C5C
memory-size iomem 25
no aaa new-model
ip subnet-zero
no ip source-route
!
!
ip cef
!
!
!
!
interface Ethernet0
description WAN
ip address dhcp client-id Ethernet0
ip nat outside
ip virtual-reassembly
half-duplex
!
interface FastEthernet0
description LAN
ip address 10.254.1.2 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
!
interface Serial0
no ip address
shutdown
!
ip classless
no ip http server
!
ip nat inside source list 1 interface Ethernet0 overload
!
access-list 1 permit 10.254.1.0 0.0.0.255
snmp-server community JMC RW
!
control-plane
!
!
line con 0
password 7 01390A5509525E5F79
login
line aux 0
line vty 0 4
password 7 11231554454B535C5C
login
!
end
-------------

Any other ideas?? Thank you so much in advance. I hope to find a solution as most people that I know whom are familiar with cisco ios tell me they have never seen this before.
 

·
Registered
Joined
·
1 Posts
Hi all,
At first, you must find "cisco 1700 ios", (each router Cisco has each IOS version and name) for instance, cisco router 1700 ios is: c1700-y-mz.122-11.T.bin (about 4.08 MB). Copy c1700-y-mz.122-11.T.bin to C:\TFTP_Root\ .Then you prepair a cable console, and fastethernet cable (cross-over ok). Connect pc with router through console port and ethernet port. You also download TFTP Server and install on your pc,remember run its first of all. Then:
You must config IP for your computer. Let's do the following example:
pc: ip address : 192.168.1.5
subnet mask: 255.255.255.0
default gateway: 192.168.1.1
And then Power on the router:
hit Ctrl + Break key together. And the router will appear:
rommon 1>
Then type the following commands:
rommon 1> set
rommon 1> IP_ADDRESS= 192.168.1.4
rommon 1> SUBNET_MASK=255.255.255.0
rommon 1> DEFAULT_GATEWAY=192.168.1.1
rommon 1> TFTP_SERVER=192.168.1.5
rommon 1> TFTP_FILE=c1700-y-mz.122-11.T.bin
rommon1 >tftpdnld
When you see "!!!!!!!!!!!!!!!!!!!" running, you're successful and wait some minutes until progress finish.

Regards.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I tried this also. I apreciate your ideas, but still after tftp(ing) an image I know is good I receive the same:

INSUFFICIENT MEMORY TO LOAD IMAGE!
The difference between Memory required and Memory available is the additional
memory you need to run the router. Alternately, use a smaller image; this
may cause the memory requirement to decrease, and may allow you to at least
use the router with reduced functionality until you get more memory.


I know the image is good because I have about 3 1700 series routers with exactly the same configuration. On this one I just managed to cause problems. My boss was telling me something about manually emptying the eprom (i think) because in my original router configuration I did not program a limit on the routing being performed which ended up overloading the buffer memory causing this problem? Does this hold any water?
 

·
Registered
Joined
·
86 Posts
Do you have some additional memory chips for this router? I would try replacing them and reloading the image to the new NVRAM. I suspect one of the chips has an issue that is causing the router to assume less memory than it has. Alternatively, try re-seating the memory chips and rebooting. Lastly, at the risk of compounding your problem, you could "borrow" RAM chips from one of your good routers to verify if this fixes your problem in a test.

See the following http://www.cisco.com/en/US/docs/routers/access/1700/1720/hardware/installation/guide/upgrds.html for a 'how to' on doing this.

I assume that the config you listed above is from a backup as you can currently only get to ROMMON. Your config has the command "memory-size iomem 25" which I also assume is for a purpose - and is not used when loading the image anyway - b ut if memory issues persist later on, this could be verified as necessary.

By the way, sorry about the limited replies as it's been the weekend here in Aus.

Wiz
 

·
Registered
Joined
·
86 Posts
Sorry. Just re-reading my post and see I didn't make it clear that the IOS image is stored in "flash" memory (NVRAM). The DIMM's are used for running the image when it is unpacked from flash memory on boot up.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top