Tech Support banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1 (Edited)
I recently upgraded my version of Power DVD from 4 to 6 and it seems all of a sudden I've noticed DVD movies tend to be choppier (although they do look a bit nicer) in full screen mode. I'm kind of wondering if this is because of my PC specs (Pentium III 1 GhZ;512 MB of RAM) not being powerful enough.

Should I downgrade, or is there something I can do to fix this?

EDIT: I've tried playing the DVD in other Media players like Jet Audio and WMP, and I still get the same result (it got even more choppy). I know it's NOT the DVD itself, because it played fine previously. Is it a drive problem, perhaps?
 

·
Registered
Joined
·
1,188 Posts
@ Cain Highwind
Your CPU and memory are fine. It may be your Video Card is a bit weak. You may benefit from updating the drivers if possible. You might also check under'control panel>display properties>settings>advanced' and see if there are any tweaks to improve performance. Sometimes a video card will have a slider for video performance with 'performance' and one end and 'quality' at the other end. You may benefit from nudging it a bit to the 'performance' side.

You could also check to make sure your DMA is enabled. In 'control panel>system>hardware>device manager' under "IDE ATA/ATAPI controllers, double click on 'Primary IDE..>settings' and 'Secondary IDE...>settings'(whichever is the channel your DVD-ROM resides on) and see if the 'current transfer rate' is 'Ultra DMA Mode 2' or 'UDMA4'. If it is not, then right click on 'Primary IDE channel' or whatever channel the drive is on, and choose 'uninstall', then reboot your computer. Windows will redetect your drive and reinstall your drivers. Hopefully it will restore the DMA level that is appropriate. Go back and check.

Or you could go back to PowerDVD4 if that worked without a problem.

Keep us posted of your progress.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #3
I discovered what it was, it was the hardware acceleration option. Reading about it carefully in System Requirements and such, I found that those video enhancing options was what was slowing it down (my PC being a bit too slow to handle it)

It's fine now though, being that I don't see a HUGE difference in picture quality anyway.

Thanks though.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top