Tech Support Forum banner
Not open for further replies.
1 - 14 of 14 Posts

· Registered
10 Posts
Discussion Starter · #1 ·
I have three computers in a Workgroup and I can transfer files through all the computers properly. However I cant set up permissions to who can access these files.

The three computers are Windows 7 64bit desktop, Windows 7 64bit laptop, Windows XP Professional 32bit desktop.

What I tried so far...
Right-click on folder I wanted to share
Click on Sharing Tab
Click on Advanced Sharing>Permissions>Add...>Locations

I only see the name of the local computer, I don't see the two other computers on the network.

The window looks similar to this

If anyone knows how I can find the other computers in my network, in the locations window i would be very grateful :flowers:

· Registered
10 Posts
Discussion Starter · #3 ·
Not sure if this is what you need but, you could try this:

Set Permissions for Shared Folders
Thanks for your reply. I tried it out but it doesn't work. I think the problem is that i cannot find my other computers in the location window :sad:.

What i tried was typing this in the cmd:

cacls "My Documents" /G Computer2:F

but what it says is No mapping between account names and security IDs was done.

Thanks for your help, im gonna try other ways to find my other computers in the network.

· Registered
1,784 Posts
Another way would be to make the user accounts on the computers locally, then add them to the hidden userlist and assign the creds you want them to have locally.

The problem. You have to go to each computer to do it.

· Registered
10 Posts
Discussion Starter · #6 ·
Another way would be to make the user accounts on the computers locally, then add them to the hidden userlist and assign the creds you want them to have locally.

The problem. You have to go to each computer to do it.
So you mean, create a user account in each computer with the same username and password. Then add the username into the permission list under the sharing tab?

You only get "locations" in a domain not when doing peer to peer networking. This is why you only see the local workstation.
Oh, that kinda sucks. So can i make a domain on windows xp or windows 7?

Thanks guys for your help! :smile:

· Registered
1,784 Posts
You can share files securely in a peer to peer network environment. I have done this in customers locations before. Although it is a bit of a crude and long way to do it. It works, and works very well.

Here is how i have done it. You need to have windows xp, vista, or 7 PRO or better.

First setup all the users you need to use for the permission leveled share(s)
Set them up as STANDARD or LIMITED users! – These users MUST have a password entered.
Now if you don’t want to see all of the user names that you have made at the windows logon you need to do the following.
To hide user accounts on Windows & Logon Use Regedit
Start - Run type regedit
Once in regedit go to HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon
In the left panel, right click on Winlogon and click New and click Key. (Only if SpecialAccounts is not there already)
Type SpecialAccounts and press Enter
In the left panel, right click on SpecialAccounts and click New and click Key.
Type UserList and press Enter. (Only If UserList is not there already)
In right panel of UserList, right click in a empty area and click New then click DWORD (32bit) Value.
Type in the name of the user account that you want to hide and press TestUser
In the right panel, right click on the user account name and click Modify.
To hide the user account – Type 0 and click OK. (number zero not the letter)
** Whenever you want to use the account just unhide the it by typing 1 instead of zero.**

Now to share files securely with windows 7 pro.

Create share folder eg. C:\testshare
Share folder out to all users
Right click on folder (testshare) and click properties
Click on share tab
Type everyone then click add
Set permission level as read/write
Click share then click done
Click on the security tab
Click advanced
Click auditing then click continue
Remove the check mark for “include inheritable auditing entries from objects parents” This is VERY important! Do not skip this step!
Click ok
Click the permissions tab
Click change permissions
Remove all users or groups EXCEPT everyone, administrators, and system
Now we are going to add the users that you want to HAVE access to this folder
click add - type in the username that you want to have access to this shared folder (eg. TestUser)
for each user do the following:
click check names then click ok
click full control twice under the ALLOW column (clicking it twice removes the full control check box only) Do this for all users you want to HAVE access to the share
click ok
click add now type in the name of the users you DO NOT want to have access to the share
click check name and ok
now click full control check box once under the DENY column
click ok
do this for all users that you do not want to have access to the shared folder
click ok
When you are done entering all the users and finished setting the permissions click ok to close the advanced security settings for testshare. A windows security window will pop up saying that you have deny permission settings entered – click YES
click ok and click ok again.
Now when you go to access that shared folder from a computer you will either be allowed to open it or denied depending on the user permissions for the log on you are using.
If you cannot see the shared folder for whatever reason then you can add the share using the command prompt.
Start – run – cmd
Type: net use z: \\computername\testshare /p:yes /user:username password
Hit - enter (the “z” can be any letter you want that is not in use by windows).
If the computer name does not work replace it with the computers IP address.

Sorry for the delay in getting it here took a while to type it out, and verify all the steps.
If you follow these instructions EXACTLY it will work 100%.
You can do the same for share folders with in share folders as well if you like. The inheritable permissions check mark is the key to this. Make sure it is REMOVED.
Let me know if you have any issues.

· Registered
10 Posts
Discussion Starter · #10 ·

Thank you, i was about to go research on how i could create a domain on win xp but if its only for server OS than there's no point in me looking into it.


Thanks for the detailed instructions! I'm going to try it out on my computers this weekend and ill post back if it works or if there is any issues.

Thanks again guys! =D

· Registered
1 Posts
Hey Shekka,
Hey there!

I saw your post on and I am trying to follow what you said but I am unable to achieve the desired results you said were achievable.

Here is my ordeal:

I have a small business that has 8 users wanting to use the external hard drive we went out and purchased. We want to be able to have one folder that allows users to share documents and other business related documents with one another in a central location. I know we could have used Google Drive or even SharePoint, but my boss is cheap and I told him that we could achieve what he wanted for less than $60. Each person has their own folder on the drive and with that they each have their own permissions, so only that person (and he also wants to be able to have two Admin users be able to have access to see everyone's folder so we know they aren't putting personal files on the drive).

I have made all the users on the computer we are using that has the external hooked up to it and have hidden them from the login screen so they all aren't showing up. My problem is that if I am on my laptop upstairs as user NSmith and I have set the permissions on the computer that has the hooked external hdd up to it to allow just NSmith to have access to my folder, I get the error "You do not have permission to access \\JDoe-pc\shared\NSmith." So if there is anyway you could help me out, I'd be greatly appreciative!


· TSF Emeritus
16,407 Posts
You should have gotten a NAS but it would have been more than $60.

All user accounts with same password [if you want them to autologon otherwise they will be presented with a logon screen] they logon to have to exist on jdoe-pc or no access. It appears nsmith does not exist on jdoe-pc which is why you get the error.

Everyone has to have list permissions to the shared folder so they can transverse it to their folders. Admins should be assigned with modify permissions to the shared folder but then we are getting into what Shekka has already posted.
1 - 14 of 14 Posts
Not open for further replies.