Tech Support banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I'm trying to fix a friends computer. The OS is W98 There are some problems with the CD-ROM drive. When you put in a CD, it never autoplays (autoplay is enabled). I can "Explore" the CD and some CDs open fine that way. But other CDs (they're not corrupt, because they work on another computer), when I try and open the Setup or Autoplay file, I get a "This program has performed an illegal operation message" and the CD won't play. I can't figure out why.
 

·
ID10T Circuit replacement
Joined
·
1,038 Posts
Couple of things you can try.

Make sure the autoexec.bat and config.sys files are not loading dos drivers.
example(config.sys)
device=c:\windows\oakcdrom.sys /d:mscd001

(autoexec.bat)
mscdex /d:mscd001

You can access these files by typing "sysedit" in a run box (no quotes) Type the word REM in front of the lines followed by a space. Save the files and reboot the computer.

If you have no cdrom after this, then you may have a driver problem for the ide. Let me know if this happens.

If the above does not apply, go to device manage and click on the properties of the cd-rom drive and enable/disable dma mode.

(Disable if enabled, or enable if disabled) Reboot after you do this.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
I tried the first things, and it didn't seem to do anything. I couldn't find a dma mode setting. I printed off the error that one CD causes here it is (if you need me to type out all the hex stuff i can, but it's really long)
STARTHERE caused an invalid page fault in module DIRAPI.DLL at 017f:6802d44f.
Registers......
It just goes on from there listing the resgisters and stack dump.
 

·
ID10T Circuit replacement
Joined
·
1,038 Posts
You could also right click on my computer icon, select properties, go to device manager. Doulbe click the cdrom drive and enable/disable dma mode. Do the opposite of what it is and reboot.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
idtent said:
You could also right click on my computer icon, select properties, go to device manager. Doulbe click the cdrom drive and enable/disable dma mode. Do the opposite of what it is and reboot.
An earlier post said to do that, but that wasn't even an option in the properties of the cdrom drive.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top