Tech Support banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I'm trying to install Win98 on a newly formatted FAT32 4Gb HD, with a 36x Momitsu CDM-T631 cdrom (most likely the root cause
of all this hassle).

Each time I boot with the win98 startup disk (i made several, so its not the floppy), i choose 'start w/ cdrom support'. I

then try to select the D: drive which MSCDEX maps it to, it does that without a problem. Problem begins when i try to read
something from the cdrom, like copying, it says 'CDR101 drive d: ready not reading' or something like that.

Strange thing is, I had the exact same drive working fine an hour before in win95b, just before I formatted the HD. Also the Win98 cd is an original, not a copy, works OK with my other PC.

I've already tried the CDM-T631 DOS drivers from the net to no avail, i still get the CDR101 message.

I even tried changing the cdrom from its original position in the motherboard to where the hard disk normally is, still nothing (so i put it back). also tried changing jumpers around, nothing.

Then I read somewhere that Win98 can boot from CDROM, so i tried that (the computer/BIOS purportedly supports booting from
CDROM) . No good. Now I'm starting to wonder just what in the world can i be doing wrong?

BTW the CDROM is on the secondary 'slave' setting, the hard disk is on primary master. It shows up in the system setup menu
when I boot up the PC, and when the drivers in the config.sys load up it gets recognised then also.

please help!
 

·
ID10T Circuit replacement
Joined
·
1,038 Posts
It sounds like a dirty cd rom lens. You might try a laser lens cleaner. Also clean the cd itself. Your drive is loading if mscdex is giving it a drive letter.

Also, You can also check the cables. Are you using a 80 wire ide cable instead of the old 40 wire? Put the cdrom on the secondary ide controller with a 40 wire ide cable and see if that clears it up.
 

·
Citizen of the world
Joined
·
51,042 Posts
Something could have simply gone "south" in the CD drive. FWIW, with the barrage of cheap CD-RW rebate deals, a lot of people have closet's full of CD drives, maybe you can find one to test. Too bad you're not local, I think I have six or seven CD-ROM drives sitting in the closet, I've replaced everything with CD-RW drives. :D
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
but it was working just hours b4

Thanks for your reply, idtent

I dont think its a dirty lens because the drive was working fine just before i formatted the HD getting ready to install Win98. I have a strong feeling that it may be the drivers, but I'm not an expert unfortunately. i'll try to get a cd cleaner though. the Win98 CD itself is definitely okay because i can get it to work on my other PC.


idtent said:
It sounds like a dirty cd rom lens. You might try a laser lens cleaner. Also clean the cd itself. Your drive is loading if mscdex is giving it a drive letter.

Also, You can also check the cables. Are you using a 80 wire ide cable instead of the old 40 wire? Put the cdrom on the secondary ide controller with a 40 wire ide cable and see if that clears it up.
I already tried changing the ide controller but it refused to work. i think its the 80 pin type. its an old ATX Pentium 2 mobo.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
temperamental CD drive

Thanks John

but i fail to understand or believe the fact that the CD drive was working fine in Win95b, then just decided to give up when I offered it Win98. i would really like to get it working, rather than just throw another drive in there, because it was a really fast drive, worked very well, but in DOS, thats another story.... :confused:

johnwill said:
Something could have simply gone "south" in the CD drive. FWIW, with the barrage of cheap CD-RW rebate deals, a lot of people have closet's full of CD drives, maybe you can find one to test. Too bad you're not local, I think I have six or seven CD-ROM drives sitting in the closet, I've replaced everything with CD-RW drives. :D
 

·
ID10T Circuit replacement
Joined
·
1,038 Posts
Do you have a 40 pin ide cable?? You shouldn't use the 80 pin with the cdrom. Try a 40 pin on the secondary. Make sure the controller is enabled in the bios of the motherboard.
 

·
ID10T Circuit replacement
Joined
·
1,038 Posts
For your drivers:

Config.sys
device=a:\oakcdrom.sys /d:mscd001
lastdrive=z


Autoexec.bat
a:\mscdex /d:mscd001

Find the oakcdrom.sys and mscdex.exe files on the windows 98 boot disk. Copy the files to bootable floppy. If you get a drive letter, then the drivers are properly loaded. If you are having the error, it could be like johnwill said, a bad drive, or dirty lens, or the ide cable is the wrong kind.

BTW:
Do you have the red wire on the ide cable on the same side as the power connector? Is the red wire on pin1 on the motherboard?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
whoops

oops i think it was actually a 40-pin cable,i'll check tommorrow because otherwise i might fall asleep at the kb ;)

idtent said:
Do you have a 40 pin ide cable?? You shouldn't use the 80 pin with the cdrom. Try a 40 pin on the secondary. Make sure the controller is enabled in the bios of the motherboard.
 
S

·
Guest
Joined
·
0 Posts
If you boot to a Win98 boot floppy which you can get here. Just download the boot disk for Win98 and insert a new floppy disk in the drive then double click the file you downloaded to create a boot floppy.

I was under the impression that when you boot to a boot floppy and select start computer with CD-Rom support that it will create a ramdrive in D and your CD-Rom will become E.

Try booting to the floppy selecting start with cd-rom support and when it gets to the A:> prompt type E: enter and see if it goes to the E drive.
If it does just type setup and hit the enter key.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
Thanks Speedo

Unfortunately what you described doesnt happen with my system, when i boot w/ floppy , then try changing to e: or any other letter for that matter it just gives the usual 'invalid drive specification'. i'll try those bootdisks though, post sometime tommorrow hopefully with an update. now i need to :sleep:

SPEEDO said:
If you boot to a Win98 boot floppy which you can get here. Just download the boot disk for Win98 and insert a new floppy disk in the drive then double click the file you downloaded to create a boot floppy.

I was under the impression that when you boot to a boot floppy and select start computer with CD-Rom support that it will create a ramdrive in D and your CD-Rom will become E.

Try booting to the floppy selecting start with cd-rom support and when it gets to the A:> prompt type E: enter and see if it goes to the E drive.
If it does just type setup and hit the enter key.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #12
Thanks for all the help, guys

but im giving up on this one, its not worth the hassle. its going back to the guy i got it from.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top