Tech Support Forum banner
Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
567 Posts
Discussion Starter · #1 ·
Preface, needed to upgrade drivers for to play Rift. Was using 9.1 (I think, was 12/10 release, anyhow). Game just didn't like it and kept complaining, and I was getting black screen driver loops. Couldn't play for more than about an hour. (yes, GPU is clean, fresh paste on the heatsink)

Installed-
11.2
11.1
10.10e
(not all at once, mind..)

My process is:
uninstall from add/remove programs
uninstall basic driver from hardware manager
restart to safe mode
run Driver Sweeper
restart to safe mode
run CCleaner (I know, but it cleans out all the residue..)
restart to normal
install new driver

Now, the issue:

When I finish the install, I keep getting the yellow question mark that says some warnings were detected, check the log file. So I do. Guess what? Says nothing about any warnings. Errors = 0

Ok, hit the final restart. When I get back to desktop, CCC doesn't start up automatically (it should), no biggie, I'll just click the icon right? I do so and the "thinking" circle at the cursor will blink on and off a few times, CPU usage will spike, then....nothing. CCC just will NOT start up.

Tried Google first to no avail. Most people just said to use a sweeper and install, all is well. Not for me!

Any help greatly appreciated, the sooner the better. :grin:
 

·
Registered
Joined
·
1,669 Posts
Have you tried uninstalling CCC and just running the drivers? My experience with CCC is to just leave it uninstalled as its more trouble than its worth. What are your temps while playing? If its black screening the overclock on the card would be my first suspicion.
 

·
Registered
Joined
·
567 Posts
Discussion Starter · #3 ·
I temp logged it...as well and burned it with FurMark. My MAX temps are about 71c, well that register in the log, anyway.

I dropped the OC just to try. Stability WAS a bit better, but still have issues. The game is the biggest problem, just waiting for them to fix it. Some people are underclocking and running low-res engine with some success.

I want CCC for OC ability, manual fan control, and most important? Right now the biggest fix seems to be to turn off Catalyst AI. I can't without CCC.

I have a new Sapphire HD6950 reference card coming on Thursday, would like to get this mess sorted for the new hardware.
 

·
Registered
Joined
·
567 Posts
Discussion Starter · #6 ·
Ok, will go that route. Have used Rivatuner before, but I thought that was more of an NVidia thing?

Did some digging at it..it says there's an incompatibility issue, but I can't get details. It flags, then if I ask for more info, I get nothing of any value.

iirc, the driver itself seems to function flawlessly, I just can't control my card (or turn off ATI-specific functions like I need to...)
 

·
Registered
Joined
·
567 Posts
Discussion Starter · #7 ·
Wrench:

Did the package install, then tried the CCC-only just in case.
 

·
Administrator, Team Manager, Gaming, Team Manager,
Joined
·
54,106 Posts
CCC is tied to the driver version, if you have the wrong CCC package for the driver it won't work. I've also seen where uninstalling using CCleaner or Driver Sweeper also remove some .net components needed to run CCC, try reinstalling .net from 3.5 through 4.0> Download details: Microsoft .NET Framework 3.5
 

·
Registered
Joined
·
567 Posts
Discussion Starter · #9 ·
Installed the CCC version appropriate to the driver.

.NET 4.0 installed
.NET 3.5 says it can only be modified by "Turn Windows Features On and Off" in the user CP...I went there, turned on all the functions. Still nothing.
 

·
Registered
Joined
·
567 Posts
Discussion Starter · #10 ·
Reading the AMD site for fixes to MOM.exe (CCC). It says to uninstall all .NET Framework, then reinstall.

Ok, fine.

However, I have 3 entries for 4.0, one for 1.1, and NONE for 3.5 in my "uninstall a program".

There's a link to an outside uninstaller specifically for .NET, it includes 3.5. What should I know before I proceed?
 

·
Registered
Joined
·
567 Posts
Discussion Starter · #12 ·
Well, after many Window updates, reinstalling, and a fair amount of cursing...I gave up.

Found MSI Afterburner for fan controls, and to re-bump the clocks. Doesn't have any of the advanced features specific to the card, but that's ok for now. Going to just backup my files and do a clean install of W7 along with the new 6950. Was able to play Rift for a couple hours (needed to do something non-frustrating for a bit) without crashes, but my FPS went in the toilet. Can deal with that in an MMO, though.

If that don't fix it?

Well, I'll be back, I guess...:sigh:

Thanks for the help!
 

·
Registered
Joined
·
1,669 Posts
Well, after many Window updates, reinstalling, and a fair amount of cursing...I gave up.

Found MSI Afterburner for fan controls, and to re-bump the clocks. Doesn't have any of the advanced features specific to the card, but that's ok for now. Going to just backup my files and do a clean install of W7 along with the new 6950. Was able to play Rift for a couple hours (needed to do something non-frustrating for a bit) without crashes, but my FPS went in the toilet. Can deal with that in an MMO, though.

If that don't fix it?

Well, I'll be back, I guess...:sigh:

Thanks for the help!
Good luck!
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top