Tech Support banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Someone suggested changing the "EnablePrefetcher" value in the registry from 3 to 1 to increase gaming performance. I looked it up and it seemed safe, so I tried it, restarted, and it worked fine. I did notice less stuttering and overall smoother gameplay in Battlefield 2, so I thought maybe if I disabled it completely I would get an even greater performance increase. I changed it to 0 and restarted, but when my desktop wallpaper appeared, my computer rebooted. I thought maybe it was just a one time thing and let it restart, but it did it again the second time. I pressed F8 and started my computer with the "Last known good configuration", it worked but the EnablePrefetcher value had been reset to 3. I figured 0 just wouldn't work for some reason, so I set it back to 1, restarted, and had the same problem I had when I disabled it. It kept rebooting till I started it with the Last known good configuration, and once again it reset back to 3. I found out TuneXP's "Optimize prefetch" setting basically just changes the EnablePrefetcher value to 3 when enabled, and 0 when disabled. I thought maybe TuneXP was interfering in some way, I disabled optimize prefetch in TuneXP and restarted, same thing happened, computer rebooted at desktop. I tried uninstalling TuneXP completely and then setting it to 1, still didn't work.

I'm not sure why it would work fine before, then I try to disable it once and all of a sudden I can't change it at all. Could someone list some possible reasons why I wouldn't be able to disable prefetching? Or what might have been changed that would prevent it from being disabled? Maybe another registry setting was changed when I disabled it, and now it has to be set to 3 or else it won't work?
 

·
Superhuman Computer
Joined
·
1,632 Posts
This sounds as though you've got a corrupt startup file somewhere, but the prefetched file is being used instead of the proper one. If you have the XP cd with the correct service pack on it, put it in the drive and click Start -> Run... then type "sfc /scannow" (note the location of the space and type it without the quotes of course) and hit enter. This should initiate the system file checker which will scan through your system and restore any corrupted files.

After doing this, try turning the prefetcher off again and see if this works. If it does, clear out the contents of your %systemroot%/prefetch folder - this will make things start slowly the first time they run while the prefetch is rebuilt, but will return to a nice working speed in subsequent runs (assuming you retain the 1 setting and keep application prefetching on). If it doesn't work, post back and we'll see what we can do for you.

For more information on the prefetcher, read this.

What I do is turn off the prefetcher for applications but leave it on for boot (setting 2), but it's entirely up to you - play around with it a little and find out what seems to be fastest
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
The system file checker isn't working. It says:

"Files that are required for Windows to run properly must be copied to the DLL Cache.

Insert your Windows XP Home Edition CD-ROM now."

When I click More Information it says either I have inserted the wrong CD or the CD-ROM drive isn't working. I have the CD in, it just doesn't seem to be recognizing it. This is a new copy of Windows XP, I bought and installed it no more than a month or two ago, and I've taken it out of the box maybe 3 times since I got it, it has no scratches, the surface is very clean, spotless even. It's a full install (not upgrade) Windows XP Home SP2 CD-ROM, it's the exact same one I used to install windows. I don't think it's the CD-ROM drive, I also tried putting it in my DVD-ROM drive, both drives are recognizing it, I can explore the disc, but the system checker doesn't realize it's in the drive. I'm not sure what's wrong.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top