Tech Support banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
Ok, So I just installed Fedora Core 4 this morning and so far so good, except for the fact that I can't access the internet. I have a Cable Internet connection thats always on and I have several computers connecting to a Broadband Switch Router. I'm new to Linux (w00h00!) and I wanted to give it a try. I have tried searching for an answer to my problem on the forums here at TSF, but no luck.

Thanks in advance for any help.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #3
The router is set to DHCP and I don't exactly know what you mean by "ifconfig", where exactly do I do this? Please go easy on me, remember, I'm new to linux.
 

·
Registered
Joined
·
58 Posts
Ohh, my bad.

Open up a shell, or terminal and type in the command:

su

You should then be prompted for your root (Admin) password.

Then type simply type in the command ifconfig (If you aren't using X [The GUI] type in ifconfig >> ifconfig.txt. Then you can upload it and link it here.)

Then copy the output to here.


That's odd FC3 didn't automatically see the DHCP server. Are you sure you configured FC3 for DHCP?
 

·
Registered
Joined
·
61 Posts
Discussion Starter #5
I try what you suggested, but it didn't work ... terminal screen said ... "bash: ifconfig: command not found".

"That's odd FC3 didn't automatically see the DHCP server. Are you sure you configured FC3 for DHCP?"

That's what I'm worried about, but I remember enabling the DHCP setting for "eth0". I kind of rushed through the whole install process, but from what I read I could configure it once it was installed, correct?

Well let me know what you think and what else I can try.

BTW thanks for your help Scooped, I appreciate it.
 

·
Registered
Joined
·
370 Posts
Well most importantly are you root? Only root can run those commands. Aside from that try "/sbin/ifconfig eth0" and follow it up with "dhclient eth0"

or maybe "/sbin/dhclient eth0"

Whichever works
 

·
Registered
Joined
·
61 Posts
Discussion Starter #7
I was finally able to get the terminal commands working, not sure why they didn't work earlier. I typed "/sbin/ifconfig eth0" and "dhclient eth0". The output said the IP is bound to "192.168.1.8", which is the IP that I gave the windozzze OS that was on the computer before I installed Linux.

The only other thing I can think of is resetting my router and see if that works. If it doesn't, then I'm out of ideas.

Also, I tryed to save the output of the terminal to the txt editor in linux and then save it to a floppy so I could post it on this forum but it didn't work, why is that?

Anything else I can try.
 

·
Emeritus
Joined
·
1,131 Posts
Try pinging the router. In the terminal you type
Code:
ping 192.168.1.1
Also run /sbin/route

Look for the line with default. It should have the same address as you used to ping the router somewhere on that line.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top