Tech Support banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
OK, I've spent hours reading this forum and have tried a few of the suggestions...all to no avail, so back to basics.

I'm trying to install XP Pro on my system. I am not/do not wish to use RAID and am trying to install on the [non-raid] SATA1 connection.

HARDWARE SETUP:
Motherboard: Asus P4C800 Deluxe
CPU: Intel P4 3.0G
Cooler: Scythe Kamikaze
Memory: 2 x 512Mb
Video: nVidia ??
CD Writer: LG DVD/CDRW combo
DVD Writer: Sony DVDRW
Floppy: generic
HDD 1: Maxtor 160Gb SATA on SATA1
HDD 2: Maxtor 160Gb SATA on SATA2
HDD 3: Maxtor 200Gb PATA on Primary IDE
Sound: integrated
LAN: integrated
Keyboard: PS/2
Mouse: PS/2

HARDWARE Connections:
PCI slots: 1=empty, 2=empty, 3=empty, 4=empty, 5=empty.
Pri IDE: master=Maxtor 200Gb PATA
Sec IDE: master=DVDRW; slave=DVD/CDRW
SATA1: Maxtor 160Gb SATA
SATA2: Maxtor 160Gb SATA
SATA RAID1: n/c
SATA RAID2: n/c
Pri RAID: n/c
Fans: 4 case fans

BIOS Setup:
Version=1019 Important custom settings= none -defaults.

SOFTWARE Setup:
none - trying to install XP

PROBLEM SUMMARY:
1. all devices shown correctly in bios; boot from CD with XP Pro CD; select Drive C which is my SATA1: and delete partition, create partition (it calls it raw). select 'Install Windows' then setup reports:

To install Windows XP on the partition you selected, Setup must write some startup files to the following disk

156328 MB Disk 0 at Id 0 on bus 0 on atapi [MBR]
However, this disk does not contain a windows XP compatible partition. Please return to the partition screen to creat a win-XP compatible partition.

(also tried the other disk on SATA2 which is already formatted to NTFS, but same error occurs)

2. Tried F6 to load IAA chipset (from floppy made from Asus CD that came with board) but got error message "file iaStor.sys caused an unexpected error (4104) at line 2108 in d:\xpsp1 ase\boot\setup\oemdisk.c.
press any key to continue"

Have also tried the promise drivers (just in case - even though I'm not using promise controller) - these installed fine, but still windows would not install on SATA1
Please help! I know the setup works if I install windows to Primary IDE but i want to install to SATA1
 

·
Premium Member
Joined
·
2,430 Posts
Have you tried booting from the maxblaster cd that came with the HD and using it to format and partition the drive before attempting to install windows ? I would also suggest removing the other drives until windows is installed and then putting them back in and resetting the boot order after.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Success! I did not have RAID enabled (or the Promise controller at all) so this was not the problem - thanks for the suggestion though - I did say I had all the defaults selected in the bios settings which wasn't quite true! How I managed it was I went to Intel's website and downloaded fpflpy32.zip, extracted it, ran it to create a driver floppy (for use with F6 in Windows setup). The direct link is here: http://downloadfinder.intel.com/scr...XP+Professional&lang=eng&strOSs=44&submit=Go!

You get several options of chipsets to install - everything I have read has led me to believe that this mobo uses the Intel 82801EB incarnation of the ICH5 chipset. I selected this one from the list presented (after F6 and 'S') and I had the same problem. Frustrated, I tried all the others, one by one. Finally, the last one in the list ["Intel(R) 6300ESB SATA RAID Controller"] worked. I have no idea why!!
 

·
Registered
Joined
·
5,741 Posts
Why the raid driver worked is anyones guess, but hey dont mess with
success. Something for me to keep in mind in the future. Its always the
last driver in the list,,lol. Makes you want to start from bottom and go up.
 

·
Registered
Joined
·
1 Posts
You must have a primary partition on the hard disk to install Windows. I think your Windows XP CD can't create a primary partition because the extended partition already uses the entire hard disk. You must resize the extended partition and create a primary partition(min 3Gb to install XP). For this you can use Partition Magic or a Ubuntu live CD. I've used Ubuntu to solve this problem.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top