Tech Support Forum banner

Cannot delete a folder...

5675 Views 9 Replies 6 Participants Last post by  youngmuslm
And it is driving me mad! :upset: Disobediant machine! I tried everything I could think of, including eliminating any connections I could find to the folder. Even restarting doesn't fix it, even though it usually works for problems like this.

Everytime I try to do anything with the folder besides clicking on it, I get the following:

Error deleting file or folder: Cannot read from the source file or disk.

Now there was no disk involved, other than my HD (obviously), and I don't know what a source file has to do with anything. I downloaded it as .zip file. Something went wrong with the file I tried to execute. It flashed me an error message I can't remember, and the file's window closed. And then it just disappeared from the folder! Now I can't delete the folder it was in. :sigh: Can anyone please help me?
Not open for further replies.
1 - 10 of 10 Posts
boot into safe mode and then try the deletion...

and do a full virus scan as what happened sounds awful like an infestation just occured
Several have been run since then. No virus to be found. The file I got was from a legitimate source. I had re-downloaded it and it installed properly. But I will try booting into safe mode. There's one I didn't think of! Thanks!
If Safe Mode doesn't help, try using a freeware program called Unlocker which you can download here. Once installed, try right-clicking on the offending folder and then selecting 'Unlocker' from the context menu. Then choose delete from the drop down menu and then select 'Unlock All' and that should do it.

Hope that helps :)
Any of the above should work. If not, follow this KB article:
"How to take ownership of a file or folder in Windows XP"
Sometimes when folders or files are left behind from an infection, no users have rights to access them - including those in the administrators group.

I went through hours of this, and tried every 3rd party utility and brute force method of removing two silly files. Then I remembered the security tab, and within seconds the files are gone. And I said "Doh!"
and finally, a last and usually the best solution to this type of situation....

a dual boot system!

I have many times booted into my secondary OS just to fix a problem remotely...has as of yet never failed to work...

and yes you can have a dual boot system of the same OS with the same key....all 3 of my computers have as such..and (knock on wood) I haven't had a problem with Micro$oft as of yet...
I fixed the problem. Safe mode didn't work, nor did the thing in the KB article. All I had to do was make another folder, drag it into the one that wouldn't delete, and delete the lot of them. Thanks for all the help and suggestions!:pray:
now that's what I call a creative technique...glad to hear you got it sorted...
I got this Problem several Times and the best thing for this that I boot with a start-up disk(Format>tick on Create an MS-DOS startup)then I delete it easily I think this Message will never appear on DOS ^^,first time I got this Problem I got mad as I made alot of Restart and it gave me same message every time
1 - 10 of 10 Posts
Not open for further replies.