Tech Support Forum banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello, I'm hoping somone can point me in the right direction.

This involves a Sony VAIO laptop model VGN-NR385E with a Toshiba MK2546GSX HDD2D90 SATA drive running updated Vista. From Sony, the drive should contain a working partition and the hidden recovery partition.

What had started as a restore/repair issue, has now changed most importantly to a recovery issue. Currently, I've removed the drive and am trying to access it with a Vantec SATA to USB adapter (CB-ISATAU2) on my desktop pc running XP. On the first try, I was able to see the full drive structure in my Windows explorer. I viewed some pics, made a test copy of a few files onto an external WD USB drive plugged into my XP machine and thought I was in the clear to continue with the full recovery later that evening. I closed the explorer and shut the drive down, but when I came back later, I couldn't access the drive again. I could eventually see the drive (mapped as J:) in my explorer, but it caused the explorer to hang terribly and I never could see the file structure or contents again. In My Computer, the J: drives shows up but there is no file size info. With the Vantec adapter, the drive powers up and spins, and has never made any noises now or before indicating that is it having troubles (no grinding, clicking, unusual sounds, etc).

Here's the details of what I am currently seeing if I try to access this drive on my XP machine.

1) In Windows explorer, when I click on the J: drive, it hangs my pc for a minute then pops up with a message saying the J: drive is not formatted and asking if I want to reformat the drive - obviously I don't.

2) In Windows explorer, if I right click on J:, then Properties, there is a long delay and finally it shows:
Type: Local Disk
File System: RAW

3) In Device Manager > Disk Drives I see
Toshiba MK2546GSX_200 USB Device Properties
Disk: Disk 3
Type: Basic
Status: Online
Partition Style: Master Boot Record (MBR)
Capacity: 190780 MB
Unallocated space: 0 MB
Reserved Space: 0 MB
Volumes
(J:) 182670 MB
Recovery 8110 MB

4) In Disk Management, I see the two Sony partitions with this info:
Volume - J: Recovery
Layout - Partition Partition
Type - Basic Basic
File system - NTFS
Status - Healthy (Active) Healthy (Unknown Partition)
Capacity - 178.39 GB 7.92 GB
Free Space - 178.39 GB 895MB
% Free - 100% 11%

Note the (J:) is blank in the File System

5) Finally, I opened the DOS prompt via Run> cmd, and try to change to the J: drive (cd j:\) but it shows:
Data error (cyclic redundance check).

That's where I currently stand. In the end, I'd love to get access to the drive to attempt some scanning and repairs, and hopefully a re-install using my recovery disks and the recovery partition, but for now, just getting my data off is the primary task, most importantly pics of my 2 yr old girl since I did a back-up in December.

Thanks for any help !!!!!!!
Scott A


*********
Note: A few words on the back story what proceeded this. The notebook is running Vista, kept up to date and scanned, using Security Center, Malwarebytes, CCleaner, Spybot S&D, etc. A week ago Thursday March 17, it downloaded some Microsoft updates, one for Security Center, the malicious software removal tool and two other updates. I rebooted and within 20 mins of use it locked up.

I had Excel and some IE windows open, and I couldn't shut anything down via Ctrl-Alt-Del, etc. After another 8-10 mins with no activity or way to do anything, I held the power button to shut down. Waited a few then rebooted, but it would not boot past the scrolling bars. If I booted to Safe mode, it would load drivers but always hang just after loading CRCDISK.SYS then kick back out and reboot into an endless loop of stalled bars, rebooting, on and on. I gave it a few more tries knowing something was messed up, so I finally got the recovery disks out. These booted, but the repair option said it found an error but could not fix it. I rebooted and it said it was shut down incorrectly and needed to scan the drive. This kept repeating and could not complete as it just stalled.

I googled CRCDISK hanging in Safe mode and found hundreds of similar reports, often of recently installed MS updates, loosing stability, inability to reboot or repair the disk. Some responses hinted at pcmcia or 1394bus drivers in windows\system32\drivers, others of repairs changing permissions, others reporting they could regain use by changing the drive from SATA types to IDE and back again in the BIOS. I couldn't access a cmd prompt to even access those files, so I tried accessing the Sony BIOS to look at the SATA settings, but it was locked with the most basic of info. Another search yielded a hint that the Sony could boot with F10 into a tool set similar to the recovery disk, but with an option to save some of your data to an external location.

Onto the next day, I tried again by booting with F10 to the on-board tools. This F10 tools did indeed have the option to save data and I could see the ENTIRE file structure still in place, so I selected what I wanted and it started copying to an external USB drive. This ran overnight but locked up with barely anything copied the next morning. I rebooted into the F10 tools, this time using the scan or repair option. It found errors on the C: drive and said it repaired them. Closing that, it lost the volume information and could not see the C: or recovery partitions now. Restarting, it would not begin to boot, stalling at the scrolling bars, rebooting and trying to scan as it was shut down incorrectly, etc. I booted to the recovery disks again, but stalled as it could not find an OS and I could not figure out what drivers it was asking for to select any myself.

At this point, about all I could do was boot with F2 into the meager BIOS page. Nothing could be accessed via the recovery disk, the on-board F10 recovery of the F8 safe mode options. That when I decided to pull the drive and use the SATA to USB adapter to try and see the files in XP. Again that worked the first time I plugged it into my XP machine and worked with copying some 8 files. All seemed good, but exiting explorer seemed to kill my access to the drive and I could never see the contents again.

I have read that perhaps the issue could also be about plug and play or resetting the USB controllers to allow the port to re-find the drive as the adapter is plugged in again. I've gone down that path, unplugged all other USB plugs, changed which port I plug the Vantec into, removing the USB controllers and letting them rebuild when I reboot, but I still cannot access anything on the drive. Plugging the adapter in now, my XP machine does see that a USB drive is being plugged in, it does asign the J: drive letter to it and it does show up in the toolbar letting me shut it down so the USB can be safely unplugged ... just as my details above list, I think it is physically seeing the drive but perhaps it has just lost the file structure (NTFS ??) so that it can't actually see the structure, file folders and individual files.

End of my long story !!! Cheers if you read it all :)
 

·
Enthusiast
Joined
·
4,527 Posts

·
Registered
Joined
·
2,434 Posts
If this were my job the first thing I would do is make an bit stream image of the drive to a good working drive. ie "Clone" that way you can try to do a logical recovery of the files on the clone and get away from doing any more damage to the drive that sounds like its going bad locking up your computer etc. You will have way better chance to get your data back
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks, will try to figure out how to make a bit stream image.

As for the links, the TACKtech site does not offer diagnostic software from Toshiba, the maker of this drive. Also, I will test the RAM in the laptop if I get that functional again, but as this drive is not being seen using the SATA to USB adapter in two separate XP machines, I think the issue lies there rather than the RAM on the laptop.
 

·
Registered
Joined
·
2,434 Posts
allenst65 your symptoms are very typical with drive failures that I see every day which is why in DR the proper tools cost lots of $$$ but they are able to get the most possible data imaged off failing drives with weak heads and marginally readable sectors. If the data you seek is of any value then you may want to consider DR pro for recovery. This will get you the best outcome in the long run. Working on a failing hard drive is a recipe for disaster. In the DR realm we image the drive to a good drive then work on the data that gets the mechanical / electrical problems out of the equation. just sayin
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
I dl'ed a trial copy of GetDataBack NTFS and went ahead and pulled the drive image to a WD external usb drive. Looking at the image in GDB, it shows the two partitions, but the result is leaving me a bit confused. When I looked at the drive using the SATA to USB adapter in my XP desktop, disk management showed the Recovery partition as NTFS, but the working partition had no file system listed.

Now looking at the drive image using GDB for NTFS, it pulls up this info:
1st Partition (Hidden FAT32 Rescue) 7.92 GB
2nd Partition (NTFS) 178GB

My confusion is the FAT32 reference for the rescue partition since this came back as NTFS in disk management.

When I tried scanning the drive image using the NTFS version of GDB, it did seem to find the contents inside the rescue partition. I don't know exactly what should be in there never having seen inside before, but it looks like what I'd expect from the OS and Sony type folders it's showing. If this is really FAT32 though, should the GBD NTFS be able to see it this way?

More importantly though, on the desired operating partition with our files, GDB NTFS has been unable to locate anything inside of it. Who knows, maybe I should download GDB for FAT and see if it can find anything from this drive image???

As for the full DR, based on what I've heard about the cost, I'm afraid it's financially out of reach right now. My wife was laid off recently, a year after having our first child. This is her laptop, so she's more than a bit emotionally tied to those files and pics. What makes it painful is that I was able to see the file contents and even viewed some pics using the SATA to USB adapter the first time I tried it, but have been unable to get back in. For now, I'll keep trying on this drive image while keeping the original SATA in a safe place. Thanks for the help !
 

·
Registered
Joined
·
2,434 Posts
The fat 32 partition is the recovery partition the laptop Sony created on the disk to recover the OS in case of problems or a fresh re-load was needed. Its up to the owner to create a set of recovery DVD's from this as well. most have a app installed for that purpose. The NTFS is the partiotion your data is most likely on. Try using testdisk (first hit in google) and perform the deepsearch after the quick search.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top