Tech Support Forum banner
Not open for further replies.
1 - 4 of 4 Posts

· Registered
2 Posts
Discussion Starter · #1 ·
hey hopefull we can get this working cause I just spent 50 bucks on call of duty 4 and it won't even play. But before we get started, yes I did read the sticky at the top and here are my answers:

1. System requirements: it does (new PC)

2. Restart your computer. Check, didn't do anything.

3. mods: NA

4. other stuff running. I closed everything else

5. Direct x. I updated to directx 10

6. drivers. to the best of my ability I have updated both my video and sound drivers (well actually the ones I have are allegedly the most recent)

7. Patches. If someone can direct me to an official patch Im willing to try it but i wont be installing anything from some skatchy third party

8. scratches. its perfect

9. Reinstall the game. didnt do anything

10. Specs

-intel q6600
-asus nvidea ge force 8800 something or other
-asus p5k mobo (no dedicated sound card)
-windows vista (32 bit)
think i covered all the important stuff

THE PROBLEM: I installed CoD4 and as far as I can tell everything seemed to work. But when I tried to play it (either sp or mp), the splash screen splashes, then it goes fullscreen to a blank black screen for a couple of seconds, and then crashes. the error messege says: iw3sp.exe has stopped working" and gives me the option to "check for a solution online" or close the program, closing the program works, finding a solution doesn't. If i then try to play again it asks if i want to boot in safe mode or not, ive tried both yes and no numerous times but it doesn't work.

ive updated direct x, rebooted, checked the drivers, reinstalled, and googled the S**t out of this but i can't get it working. some of the google results seem to say that CoD4 problems may be related to onboard realtek sound(which i have), ive tried fiddling with every option but it doesn't seem to work

i don't know if this is relavent or not but my PC is hooked up to my speakers via optical coaxial, which works fine. But, direct audio, I don't believe ive got working, if I plug headphones into my case or mobo they won't work...maybe this could somehow be related???

Anyways, if someone could point me in the right direction it would be much appreciated cause going out and buying something only to have it not work sucks. :(



· Registered
1 Posts
i have a similar problem with CoD5 and have yet to find a solution.
while looking i came across one solution that might be of help to you. the clue was the soudn problem you had....

start> control panel>Sound>Recording(tab)>Enable anything that's not enabled in there.

dno if this helps, but i just made a whole account on this bloody site to say that so i do hope it helps! :p
happy christmas

· TSF Team Emeritus
3,464 Posts
If that doesn't work, give this a try:
Go to your Call of Duty 4 folder.
Open your Miles Folder.
Look for the Mssmp3.asi file.
Rename it to Mssmp3.bak.

Then try and run it.
1 - 4 of 4 Posts
Not open for further replies.