Tech Support Forum banner

Should i scrap Windows and go for Mac/Linux instead?!

  • Heck no, windows is virtually bug-free (LOL)

    Votes: 2 40.0%
  • Yup, Mac rocks

    Votes: 1 20.0%
  • Yup, Linux is hardcore

    Votes: 0 0.0%
  • Whats Linux?

    Votes: 2 40.0%
Status
Not open for further replies.
1 - 18 of 18 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 · (Edited)
Ok so, a few days ago my keyboard broke, out of desperation i 'borrowed' my brothers old sticky one! Anyways, i was working away on photoshop and need to print screen, unluckily for me, this keyboard had a "power" button in the same spot as my old one had "print-screen"! Needless to say i was raging! Lost all my current work and stuff, but it seems that was the least of my worries!

So ill start from the begininning and give you a little run through of the DIY stuff ive attempted.

Just to clarify its a packard bell computer, bout 18 months old, running xp sp2.

Right, when the computer was rebooting i was hit with the black screen "your computer wasnt shut down properly.... blah blah" and i was given the options to safe mode it, run previous settings that worked and normal mode. I just chose the previous settings, it got as far as a blue screen with the following displayed:

STOP: C0000218 {Registry File Failure} The registry cannot load the hive (file):\System Root\System32\Config\SAM or its log or alternate. It is corrupt, absent, or not writable.

Now, im aware thats SAM stands for 'Security Accounts Manager' and is to do with logging on the system.

From here i did some research and found that i was going to need to get into the recovery console and type some neat coding. This took me a while to get to as i dont have an XP cd (wasnt supplied with the computer *shrugs*) and i dont have a floppy drive so i cudnt create disks using a wizard! So i managed to get one from a friend.

I followed the advice directly from microsoft (http://support.microsoft.com/?kbid=307545)

I managed to get as far as part one *facepalm* where it gets you to replace the hive files with proper ones from the repair folder, after creating backups. This is where i hit my next roadblock, when trying to copy from c:\windows\repair\sam to c:\windows\system32\config\sam, I was told "the system cannot find the file specified". I think this is something to do with backups right? Im pretty sure ive done these... but i guess i was wrong... Surely they keep good copies on the XP disc?

Anyways, just for good measure i attempted to run the usual sequence of getting on to windows after trying these few tricks, but nothing seemed to change.

But then, i followed some advice from a site that told me to enter something like "ren sam sam.bak" but a few lines later it was asking me to copy from the repair folder again, which is where i stopped once more. Furious i just stopped and rebooted, came back after a quick BIO break to find it had done something to affect the startup! hurray!... or not... It showed my wallpaper in the back ground, a box with the windows xp logo and a comment "Windows xp is starting up..." But there was some error box in the foreground!

It went a little something like this:

Security Accounts Manager initialization failed because of the following error: A device attached to the system is not functioning.
Error Status: 0xc0000001.
Please click OK to shut down this system and reboot into Safe Mode, check event log for more detailed information.


Microsoft has a page for this error too...
(http://support.microsoft.com/kb/316751)

However yet again im asked to do that whole repair thing which of course.. i cant!

Oh and btw, when i reboot in safe mode, it just says the exact same thing... d'oh!

I tried to be as specific and in-depth as possible to my explanation, i know how many problems there are with windows these days! *sighs*

Please, any advice would be so helpful, ive got some work that i need to do before next friday so im pretty desperate! :rolleyes:

And just on a side note, i know some things about computers and stuff, but not loads! so any complicated procedures (that may not see so complicated to you :laugh:)

BTW, i tried a check disk or 2, said there were a few errors, but it wudnt attempt to fix them!

Thanks in advance!

Peter
 

·
Team Manager , Articles Team
Joined
·
11,900 Posts
Hello Peter, Welcome to TSF! :wave:

It looks as though you have really got yourself in a pickle here, to the extent that without a Windows® XP SP2 - CD, you are pretty much "burnt toast".

The only possible solution for this situation would be to ask a friend or colleague if you can borrow their Windows® CD (it cannot be a 'Recovery' type disc, it must be a full version disc).
You will then need to 'Slave' your current HDD in another computer and try to retrieve whatever data you need from it; copy it to CD/DVD or other removeable media; then, totally wipe the Drive and reinstall the OS from scratch.

The reason I say this is that you have completed, (going by your description), only ½ of the instructions required in KB307545, and you now have an innaccessable md tmp file thats stopping you progressing any further.
If you can gain access to a Windows XP SP2-CD, we can assist you with wiping the drive and reinstalling the Operating System.
Sorry that the news is not good.

Please post back with your thoughts.

Kind Regards,
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Hey guys thanks for the replies :D

Oh i think i might have been a little hasty before when writing that, when i said "borrowed it from a friend" i meant i got a hold of the windows xp sp2 cd :D

Maybe you read it wrong, but from there on i was following guides to do with it :laugh:

Again any help at all is well appreciated! And sorry for the late reply, it was getting late last night :p

Thanks again,

Peter
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Oh and ThorXP, ive been trying all of those techniques so far, but as i mentioned, the real problem is when i get to copying the files from the c:\windows\repair folder, they just dont seem to exist as i get the error that the system cant locate them!

Thanks!

Peter
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
another little prolem now! its asking for the admin password in the recovery console when i try 2 access the c:/windows directory, the e:/ one is accessible though... i tried just entering a blank password bt that didnt work! is there anymore default ones?
 

·
Registered
Joined
·
655 Posts
nope..you can load ophcrack its like slax bootable iso, as long as its legitimate you can do it. :) its open source too
that will figure if there is a password and tell u what it is
 

·
Team Manager , Articles Team
Joined
·
11,900 Posts
Hi Peter,

When you go into the Recovery Console, you just leave the password blank, as its usually not required.

As I mentioned in my earlier Post, you will not now be able to continue with the md tmp procedure, as the files are now no longer accessible.
The only avenues left are to:...
1: Try a "repair' of Windows®, or;
2: A full 'clean' Installation of Windows®
Personally I recommend option 2, because you run the risk of the 'repair' going pear-shaped on you, because it might not 'repair' those system files correctly..

Your thoughts please.

Kind Regards,
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
Ok thanks again for the advice Chauffer2 :)

I decided to take go by your recommendation and try the repair function with the CD. It seemed to go pretty well, i pressed enter at the menu, then it asked me if i wanted to attempt to repair the sectors. It went well, showed some screens about copying critical files etc, then it seemed to go into autopilot and start to reinstall all of windows. I couldnt really do much to stop it so i just let it run!

It was nearing completion when it asked me for my CD key, i noticed i had a Windows xp Home edition CD key on a shiny windows-like sticker on the side of my tower, so i tried that. It said it wasnt a valid CD key though! I tried googling my findings and it seems many people get this when trying to reinstall their windows! but i cudnt find any advice on how to get round it :(

When i got the CD from a friend, the windows one, he also gave me his cd key just incase, i tried that too just for good measure, but it said it wasnt valid either! And i double and triple checked the codes i entered were correct but nothing!

I noticed he has also given me some bootcd that has loads of tools, "Hiren's Boot CD" he said it might help me somewhat, are you familiar? It has loads of complicated operations and i have no clue what im doing so i havent tried anything on it yet. Well except create a mini windows, messed around with solitaire for fun while i waited on help here :D

What would you suggest? Ive started looking on the packard bell site for product support etc, not very helpful atm though :(

Regards,
Peter
 

·
Team Manager , Articles Team
Joined
·
11,900 Posts
Hey Peter,

This sounds promising! :sayyes:

When you get to the entry point for your Product Key, the key is a bunch of Letters and Numbers that looks like this...

xxxxx-xxxxx-xxxxx-xxxxx-xxxxx-xxxxx

Just double check that you haven't accidentially typed in a zero instead of an "O", or vice versa.

Now if that still gives you the "Invalid Key" message, and you know that its the one that came with your machine; then, ring your local Microsoft Support Centre and explain the situation to them and they'll be very helpful and assist you with a workaround.

The fact that you managed to get it to start the 'repair' is great news, at least this way you will not loose any of your personal data that was on the machine.

Yes, it does go into Auto-Pilot when its doing the 'repair' installation, you just sit back and relax and let it do its thing, which includes rebooting a couple of time too.

I would say that you are 95% of the way to beating this cantankerous contraption into submission. :grin:
So give Microsoft a quick call and they'll help you with a 'fix'.

I'm off to bed now as its 0145 on Saturday morning in South Australia.

Please let me know the outcome.

Kind Regards,
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #14 ·
I tried about 20 different cd keys ive found so far, none of them worked at all :/ Nada! zilch! Havent been able to get thru to the microsoft people so far! And i have this weird phobia of talking to people on the phone! not good.
 

·
Registered
Joined
·
2,697 Posts
There is another fix for this key thing. You can call the manufacturer of the computer and order a new recovery disk set for the operating system - comes with the proper product ID.

You can try calling the phone number on the authentication screen and explain to Microsoft what the problem is and when the agent believes you they will give you a proper product ID code.
 

·
Team Manager , Articles Team
Joined
·
11,900 Posts
Hi Peter,

I have to agree with ThorXP in this instance...just use the Product Key that is on the sticker of the computer, and call Microsoft.

I tried about 20 different cd keys ive found so far, none of them worked at all :4-thatsba
These are probably pirated numbers/keys that WILL NOT work in any case! :4-dontkno
Nada! zilch! Havent been able to get thru to the microsoft people so far! And i have this weird phobia of talking to people on the phone! not good.
The procedure with Microsoft is virtually painless, because most of the conversation is semi-automated, with the exchange of your Product Key and them issuing another.
This really is the best and only solution here.

Post back with the outcome of your chat with Microsoft.

Kind Regards,
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #17 ·
Ok we have a bit of a situation now!

Right before when i mentioned how that whole setup thing was happening, that it was asking for a cd key and everything. Now... it doesnt quite get there. It loads up everything and after about 20 seconds of saying "Windows is installing..." it changes to a blue screen saying "IRQL_NOT_LESS_OR_EQUAL" ! That cant be good :p All ive done since i last posted was reboot several times re-trying the supplied cd key, seems i must have done it one too many times. By the way, this happens whenever i dont tell the comouter to boot from cd, it just automatically opens up the setup, seems since it started initializing the setup, its completely wiped my old settings and stuff? Recovering my old data doesnt seem to possible now.

This morning i was told to locate a Xp MCE 2005 OEM online somewhere, most likely by torrents, from a guy working in the shop where i got my computer. I did that and burned it to disk. When i first put it in and booted it, things were looking up, it was asking my questions like, create partition or create new \windows folder on existing partition. I decided the later would be better as the first option told me it would be formatting the drive, something i dont quite want to look into at the minute! It said the c:\windows directory was taken so i renamed it to c:\windowz. The setup went for about 5 mins, giving a bar showing progress of "scanning the current hdd" after it finshed it said "The system must be restarted to continue setup" so i let it do that, but from here it didnt continue or anything. Its like nothing happened. Well thats what i thought at first! When i thought this i tried to go into the setup again and see what i could salvage, but when i tried to start the setup questions etc again, i hit another blue screen saying "IRQL_NOT_LESS_OR_EQUAL" Screen :( Rebooted a few times and got the same result. Is it a lost cause now?
 
1 - 18 of 18 Posts
Status
Not open for further replies.
Top