Tech Support Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I am experiencing a very weird problem trying to run my Crucial C300 SSD in AHCI mode on a Gigabyte EP45-UD3P motherboard (Bios F10f). I don't think there is a problem with the C300, but I am posting about it here in the hopes that someone else may have something to suggest, because I have tried everything I can think of. Bear with me, this is a little complicated to explain.

I have Windows 7 x64 installed on the C300 and everything is aligned properly as confirmed by AS SSD. The operating system was initially installed when the drive was running in IDE mode and has been running fine. After reading some threads in forums I decided to change to AHCI. Following the instructions in some other threads regarding how to make the change I got everything running successfully in AHCI mode...temporarily. Everything worked fine for a couple of days. Then yesterday when I turned on the computer the system hung while in the bootup process at the point where the the Bios is trying to detect the AHCI drives. At the point of the hang, the following was displayed:

Code:
Serial ATA AHCI BIOS, Version iSrc 1.20E  
Copyright (c) 2003-2008 Intel Corporation 23  ** 
This version supports only Hard Disk and CDROM drives 
** Please wait.  This will take few seconds.   
Controller Bus#00, Device1#F, Function#02: 06 Ports, 03 Devices
Normally, all of the drives that are on the Intel controller are listed following this message, however in this case the system just froze. Note the number "23" on the second line of the display, that status always appears when this hang condition occurs. Note, that this occurs before even being able to get to the bios settings, so it has nothing to do with actually booting the OS, it hasn't got that far yet.
In order to be able to get to the bios settings screen I had to unplug the C300. I uplugged the C300 and went into bios settings and changed back to IDE mode for the Intel controller. I plugged the C300 back in and rebooted. Everything worked fine when in IDE mode.

I then shutdown and went into bios settings and set the intel controller back to AHCI and rebooted. This time the system rebooted normally and everything was now working fine in AHCI mode again...again temporarily. I tried rebooting the system several times and after about the fourth time the system hung again at the same place as reported earlier. I went through the same cycle described above, setting things back to IDE rebooting, working successfully, setting back to AHCI, working successfully for a while and then encountering the error condition again. I went through the whole cycle several more times with the same result.

I google'd "isrc1.20e" and found several threads containing discussions of similar issues, but no one seemed to have a solution to the problem. One of the threads is here.

I have been working with computers for a long time and this is one of the strangest problems I have encountered. I am hoping that someone on this forum will have some suggestions as to how to resolve this as I would really like to run the C300 in AHCI mode to be able to fully utilize its speed.
 

·
Registered
Joined
·
25,116 Posts
I suggest you try running a standard sata drive off your ACHI controller to see if this is just related to the SSD

have you tried updating your chipset drivers?

BTW: I hope you arent epecting to see more speed from ACHI because I never have; about the only good feature I have seen from ACHI is hot swapping

BTW: you may want to try returning to the newest Non-beta bios file
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top