Tech Support Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys, I'm wondering if you could give me some insight so I can try to tackle this problem when I get home from work.

Comp Specs:
AMD A64 CPU (don't remember exact model but its fairly recent)
Asus M2n-SLI MoBo
4 GB OCZ RAM
XFX 8800 GT Video Card
Thermaltake 850W PSU


Whenever I try to boot my PC The keyboard/mouse/monitor act as if they are reeiving no input (laser mouse doesnt light up, no keyboard lights and montior just flashed as if sleeping). My friend told me to reset my BIOS by removing the battery on my mobo for awhile which I did. After I reset BIOS my PC boots properly until I shut it off or try to restart it which causes me to encounter the same problem when I reboot. I can hear the harddrive working.

I took it to a technician a month ago and he told me it was the video card which didn't make sense to me but I sent my card back and got a new one a week later and still have the same problem -.-

I'm thinking that I should try updating my BIOS when I get home to see if that works. But I may just bring my comp back to the technician and be like ***. Any insight would be much appreciated!
 

·
Registered
Joined
·
656 Posts
Do not mess with upgrading your bios. You only need to do that if your upgrading hardware and need a newer version to support the hardware or if there is a software fix/tweek. If you do end up tring to update your bios and fail, unless you have a board with removable bios chips or a board with a back up bios and know how to run the back up program, you will be without a motherboard. A bad flash/update will turn your mobo into trash with no way to fix it if you have a single soldered in bios chip. Personally, Id look at replacing the battery and checking the bios jumper to make sure (ifyou have one) that it is on all the way. But do the battery first.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks alot I'll definitely try that. Also I remember seeing CHECKSUM error and itprompting me to hit F1 at one of the screens while booting if that helps narrow it down o_O
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top