Tech Support Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
615 Posts
Discussion Starter · #1 ·
Windows 10, Pro.

Problem, in making back up / Copy of a nested big Folder ( carrying many files and sub folders ) - From C: drive to D: an External Drive, outside the CPU tower.

Many of the Big file names are skipped, also due to so many other unknown reasons
The back up / Copy is never perfect of that Big Folder.

So many files and folders are missing in the destination folder after making Copy of that folder to the D: drive.

How to, tell computer ,…….to let Go the Huge File name, without any restriction, while copying ?

I can never get any perfect copy and Loads of files and folders are missing at the destination.

Help, please.
 

· TSF Moderator , Hardware Team , Networking Team
Joined
·
11,903 Posts

· Registered
Joined
·
120 Posts

· TSF Moderator , Hardware Team , Networking Team
Joined
·
11,903 Posts

· Registered
Hardware/Windows
Joined
·
278 Posts
Use X Copy C: D: /s /e
I also add a date switch... /d and set it as a command
Only problem with the date switch is you can be prompted for copying like named files of a different date ( change the file and resave as same name, the date/time sig. is changed)
As you only need to set this command to copy one folder (the /e switch copies everything in it) you would only be prompted once about overwriting.. and all I do is make sure I rename files if I want to keep originals... then A for All at prompt and watch it copy.....
The date switch is used so that the whole folder is not recopied all the time... just new files.. old existing files are never deleted... just new ones (by date stamp) copied.
 

· Registered
Joined
·
615 Posts
Discussion Starter · #9 · (Edited)
Thanks all Folks.

I had a single Hugh, nested folder on my desktop and I was keeping my all on-gong accumulated important there, ( so that every time one folder backup be suffice, but never had satisfactory success and was hard to do guess-work, which files been copied, which skipped,... etc. DOS was also no help,.. doing same in Dos commands - Xcopy . /s ) , zipping/compressed of files and then decompress after copy was not allowed due to Hugh folder,..

So, while backing to D: 6TB external drive,...
never had success and folders and files were missing in destination,..... in 10s and even 100+ always...

It was just one Hugh folder issue ( No cloning or Entire PC Backup issue or any such,.. )
Folder had various documents, few - rebate / upc / shipping label, passport, Cell taken pictures, ( No Vdos ) in folders, No caches, NO system files, No program files or any such,...
and inside sub-folders, some file names were long, -- nonetheless that folder was making a true perfect copy, IF copied on same C: drive, but never on D:

finally , I have done these setting ( per below picture ) to allow Hugh file names,.... and it did near perfect job,... still it missed ( Skipped, few long file names, giving me warning sign, while copying , so I wrote them down and reduced words in source folder and somehow did copy it manually,.. and Now I made new perfect back up, as below pictures.
.
.
.
Settings to allow for Long file name :

After doing,.. RUN, Regedit,...

Rectangle Font Screenshot Parallel Electric blue

.
.
Rectangle Product Azure Font Screenshot

.

Thx all, for suggested other knowledge parts and I will keep this thread in mind.
.
.
 

· Registered
Joined
·
5,922 Posts
DOS was also no help,.. doing same in Dos commands - Xcopy . /s
Use ROBOCOPY instead of XCOPY when copying long pathnames.

Some final info that might be of use to people with similar problems.

To enable long file paths in Windows, open Registry Editor, create a new DWORD named "LongPathsEnabled" in "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem" and set the value to 1. Pro and Enterprise users can enable "Enable Win32 Long Paths" in the Local Group Policy Editor.
or...

Press Win + R keys on your keyboard and type gpedit. msc then press Enter. Group Policy Editor will be opened. Go to Local Computer Policy -> Computer Configuration -> Administrative Templates -> System -> Filesystem, then enable the Enable Win32 long paths option.
 

· Registered
Joined
·
615 Posts
Discussion Starter · #11 ·
^ Sir, ( MPR ) : Regards,.....

ROBOCOPY though I did not try this time,.. last time in March 2022 when my old HP - SSD gave a crash, and had tried at that time to cover all of my imp. stuff from my desktop folders,....and had No satisfactory results, other than more and less that of Xcopy, that I remember,.....

Perhaps my folder was too nested,.. ...
Perhaps some "system made empty/unimoprtant folders" were there and few very rare system files also remains tagged in somewhere ( system makes it by itself ) out of yr knowledge,..

For example, just now,... ( below picture ) when I backed up,..this folder of "Journal" was there which was empty and not created by me but system made for some reason,..

SQLITE files ( below picture ) generated by system for its own reason,...

............................. and such, perhaps when Copy destination folder omits them for a reason, ( being empty folder or unnecessary system file ) and that also gives you miscalculation, in your total number of files and folders and you remain doubtful, that now how to trust that which imp/non imp files might have been missed or not !

Secondly,.. WIN 10 allows limited access in DOS unlike Win 95/97 with limited commands and especially in my case, the longer file names everywhere gives annoyance typing when in DOS way,...

I think, you got the point.

Nonetheless, above set up for long file names,.. ( of setting the parameter to 1 ) everyone should do it, and it did do good job 95% , only 4-6, long skipped files ( which were in nested sub-folders ) and above useless system files, I had to check them manually. Perhaps the Copy command had omitted them purposely, but 1 to 3 were still genuinely skipped long file names, even after applying the parameter to 1, and I took care manually.

------------



Rectangle Font Parallel Handwriting Circle

.
.
.


Product Rectangle Azure Font Parallel

.
.
 
1 - 12 of 12 Posts
Top