Tech Support banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi, This is my first post, so I hope it go's OK,

I am getting ready to put together a new PC with the new
ASUS P4C800E-Deluxe MB, my question is what would be
the best way the hookup my devices, which are,

Raptor 36 GB HD SATA

WD SE 200 GB HD PATA

IOmega 750 MB Zip Drive

Pioneer A06 DVD Burner

Plextor Premium CDRW

I would like to install the OS on the Raptor and boot from
it.

How hard is it to get the OS onto the SATA HD?

Thanks to all,
Mark
 

·
Registered
Joined
·
207 Posts
Ok been there, done most of that. First off I would connect that SATA HD to the non-raid SATA 1 port and do not connect the other hard drive until later. Doing that should remove any headache over multiple hard drivers. I am guessing that you are using the other hard drive for data anyway. After you have the SATA hard drive connected load the OS and all drivers. After the OS/drivers are loaded connect the PATA hard drive to the Primary Master connecter.

When you reboot the system for the first time after connecting the PATA hard drive. Enter Bios and change the hard drive boot order so that the SATA hard drive is first on boot up. Be sure you enter Bios because for some reason this motherboard always assumes that the PATA hard drive should be looked at first. If the PATA hard drive is looked at first and there isn't an OS to load the system will hang (at least that was my experience).

I’m a little fuzzy on this part, as this is my first system build myself. So you might want to wait until some of the more experienced people respond. But if I were to guess, I think you want to connect the DVD Burner to the Primary/Slave. Then connect the CD-RW to the Secondary/Master, and the Zip Drive to the Secondary/Slave. Either that or you should connect the DVD Burner to the Secondary/Master and the CD-RW to the Primary/Slave. Either one should work ok and won’t hurt your system. But one or the other should give you better performance with your DVD Burner, which is what I think you are looking for. Anyway I hope this helps.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks for the responce, I want the system to boot fast and
not hang looking for drives on the ide chains, not sure if this
could be a problem or not, also I am told not to connect a slow
device with a faster device, like the zip with a HD, but I am not
sure about this, the faster of the devices should be by itself,
I think. I just picked up another 200GB HD to add to the mix,
now what do I do, or should I just leave it out?....I am open
to any suggestions, and will do whatever it takes to get a good
fast stable setup.

Thanks,
Mark




I think you want to connect the DVD Burner to the Primary/Slave. Then connect the CD-RW to the Secondary/Master, and the Zip Drive to the Secondary/Slave. Either that or you should connect the DVD Burner to the Secondary/Master and the CD-RW to the Primary/Slave. Either one should work ok and won’t hurt your system. But one or the other should give you better performance with your DVD Burner, which is what I think you are looking for. Anyway I hope this helps.
 

·
Guru
Joined
·
1,315 Posts
I'm basically with Javora on this one. But as usual I have a lot more to add...
Ok been there, done most of that. First off I would connect that SATA HD to the non-raid SATA 1 port... -Javora
I agree with Javora, use the non-RAID SATA1 port for the raptor. In your BIOS setup Main screen, this disk will appear as the "Third IDE Master".
How hard is it to get the OS onto the SATA HD? -MStan
Just attach it as Javora said, and leave the other HD's disconnected when you run the O/S setup. I test-installed XP on a Maxtor SATA attached in this way last week, and it was fine. Another member installed to a WD raptor it and it was also fine.
...and do not connect the other hard drive until later. -Javora
I agree again. At least for Xp, the problem with having all HDD's attached for the initial install is that XP Setup doesn't provide a clear-enough description of which disk is which, when you come to the partitioning step: it names them something cryptic like "device 1, drive 0, partition 1" or some such...??? But if you make it so only one disk is online, there is no question, and you end up with what you wanted.

After the O/S install, then go and plug in any extra HDD's. Next, go back into the BIOS setup Boot- Hard Disk Drives menu (which magically appears when multiple HDD's become present) and "disable" all HDD's except your "3M" drive (3M= Third IDE Master): you won't want to "boot" from these other drives. Next check that your Boot Device Priority specifies the drive on SATA as your boot hard drive. Hit F10 to save & exit. Then boot the O/S and if you have XP or 2K apply the Big Drive Enabler patch since you're over 137GB. Then format & partition the extra drives using PartitionMagic 8.01 or equivalent.




I just picked up another 200GB HD to add to the mix, now what do I do, or should I just leave it out?. -MStan
Since you had a 200GB in your original list, I take it this means you now have two 200GB drives? Plus a Zip, CD burner, and DVD burner, all IDE devices? Well now I kind of need to know what you plan to use the machine for.

For example if it is audio/video recording, from a PCI adapter or firewire, then having a HDD on the ICH5R as a temp for recording, makes good performance sense. It would not be used for much else. The other HDD should be on the Promise, for use as your main data store. This provides good data flow from temp to data store and vice-versa.

If it's just a general purpose machine and you need a lot of storage, then I might just hook both drives up to the Promise ATA-133 "PRI RAID" port as master and slave.




also I am told not to connect a slow device with a faster device, like the zip with a HD, but I am not sure about this, the faster of the devices should be by itself, I think. MStan
Well this gets a bit more involved. You potentially have a full load of devices to consider.

First, I have read that the ICH5R IDE ports are not subject to the same limitations as yesteryear: each IDE bus will run each device at its own native speed. Also the primary and secondary port speeds are equal.

Intutively some fast/slow issues may exist, though. The issue as I see it would be latency: when you have primary and slave devices on a bus, and if a slow device is paired with a fast one, then if the slow device is busy on the bus, the fast one will have to wait until the bus clears before it can perform I/O. But once the bus does clear, the fast device will run at its native speed whatever that is, until the slow device grabs the bus again. So I guess "it depends" might be a good characterization of this issue.

Second, your Zip drive user manual sheds some interesting light on its bus-placement limitations. So this sort of dictates the rest of your setup...
  • The Iomega Zip 750 internal Atapi for PC drive max transfer rate is quoted as 7.3MB/s (they don't quote sustained rate). And the manual recommends that you "connect the Zip ATAPI drive as the “Slave” device with your CD-ROM drive on the secondary IDE channel or as the “Only” device on the secondary IDE channel... CAUTION! Iomega recommends that you connect the Zip ATAPI drive to the secondary IDE channel. Do not connect it to the same IDE channel as your hard drive." So that is that: HDD doesn't share bus with the Zip.
  • The Plextor Premium reads at 1.6 to 7.8MB/s, writes at 1.5 to 7.8 ideally, but mine tested out somewhere in the 21X/16X range I think, or about 2.4 to 3.0MB/s, your third fastest peripheral. The Zip manual says it wants a 40-conductor IDE cable, but I'll bet an 80 would work also, to satisfy your Plextor which can go faster.
  • The Pioneer A06 DVD RW reads at 4.8 to 16.6MB/s, writes at 1.5 to 5.5MB/s, your second fastest peripheral. As Javora suggested, you could swap the CDRW and DVDRW, it may or may not matter.
  • The WD website is down, but we can assume the WD SE 200GB transfer rate will have the fastest transfer rate. You will want to use an 80-conductor ATA-66+ cable for this connection.
With the Iomega cautions in mind, and keeping the DVD vs. CDRW device speeds grouped, I would put one HDD as primary Master, the DVD as primary slave, the CDROM as secondary master, the ZIP as secondary slave, and the other HDD on the Promise ATA-133 "PRI RAID" port.
This arrangement also puts a HDD as primary master. Although your O/S would not be on that drive, I hear some apps can get confused if your first IDE HDD is some on slave device. Depends on the app, though, I don't have any citable ref.'s on this.



The other very important thing to consider with all of this is the cabling: the master has to be the device at the farthest end of the cable, and the slave is max 6 inches away from that. So under those limitations I would...
  • Put the CDROM (Sec master) in the top drive bay, with the Zip (Sec slave) in the next bay below.
  • Assuming your HDD's mount in the bottom of your case, put your DVD (Pri slave) in the lowermost drive bay, then stretch to the HDD (Pri master).
  • If the spacing isn't to your liking, you may need to use rails to actually mount the extra HDD in a front bay, then you would have more flexibility over peripheral placement.

FWIW I think it may also be possible to configure the two 200GB's as RAID on the Promise, but I'm not 100% sure: I don't do RAID. The mobo manual implies it works, but the manual is sketchy.
[25Sept2003 update: yes, RAID0 on the PRI RAID port does work, but as suspected (see below) it runs at about half speed compared to SATA RAID1/2. Randallizer demonstrated this here.]

But IMO running ATA RAID here cannot possibly be as efficient as SATA RAID, because in the ATA case you have only one controller, with 2 drives on it and sharing one bus. This means while the Master was writing its half of the RAID data, the Slave would have to wait, and vise-versa. So it might work, but wouldn't be as efficient as with the two presumably independent SATA controller ports. RAID-1 might be possible over ATA on the Promise too, but IMO the same latencies still apply: the mirror drive can't be written until the data drive has finished, and vice-versa. But again, I don't do RAID, so take this with a grain of salt.

Hope this helps,

-clintfan
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top