Tech Support banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter · #1 ·
I downloaded a demo of AOE III and when I went to run it it said that my cpu speed was only like 533mhz and it may not run correctly, but when I go to run and then type in dxdiag for info on my system is says that my cpu is 1.8mhz. Any idea why the discepency?

Thanx.
 

·
Registered
Joined
·
18,118 Posts
What kind of CPU do you use? Some can throttle back when not under use to lower temps and save energy. My laptop can go from 1.8Ghz for 922, so the drop you're seeing isn't quite normal. Visit www.lavalsy.com and download Everest Home to get more information.
 

·
Registered
Joined
·
462 Posts
wow i didn't know that CPU's could drop their speed like that, anyway isnt there an option in AOE3 to try and run it anyway?
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #4 ·
It allowed me to play it, but it had some lag to it. Not sure if I should buy it or not...not sure how close the Demo's are to the real thing in terms of performance.
 

·
Registered
Joined
·
462 Posts
ur right there, demos can be a bit wrong, but does it lag when you have EVERYTHING on lowest possible? if it does then i wouldnt bother buying it but i guess that's my personal opinion
 

·
Registered
Joined
·
462 Posts
Could you tell me more about your pc? then maybe i can help further
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #8 ·
I've heard of something called "overclocking" your cpu...is that something you can do if you're speed is a bit lacking in terms of the requirements for a game?
 

·
Registered
Joined
·
462 Posts
i thought you managed to get it to run? anyway as i said in my previous post could you give me your specs?
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #10 ·
When I get home I'll try to remember to get the specs off it. I think it's only got 256 Megs of RAM and a 32 Meg video card also, so it's like very borderline for the higher end games.
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #12 ·
Yeah, it ain't much, but Age of Mythology and the Titans expansion pack runs on it just fine. But that is a couple of years old.
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #13 ·
I've attached a copy of the Everest Home report. I don't really know how to use this program, but from what I can see it seems to go back to the problem I mentioned. It lists the cpu as 1.8ghz, but it's only running at 5 something..
 

Attachments

1 - 13 of 13 Posts
Status
Not open for further replies.
Top