Tech Support Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all, hope someone can help me. A friend gave me his laptop to look at as it would not boot. The problem is, when it's switched on it goes to Acer erecovery management no matter what I try, this includes all the safe mode options. It also will not quit from this and the power button needs to be held down to quit. I don't want to do a recovery/install just yet as there is files which he wants from it (Photos,music and docs) any help with this would be great,
thanks in advance
 

·
Enthusiast
Joined
·
4,527 Posts
When Acer eRecovery repeatedly appears it means you must continue with it if you want to get Windows working again.

If your friend had kept backups of all his files in a different location you wouldn't be in the situation you're in now. That's the whole point of keeping backups. What if the hard drive fails at some point in the future? -- his files would then be gone forever.

If you want to get files off the drive before doing the Recovery you'll have to remove the drive & install it into an external 2.5 inch hard drive enclosure, then plug the enclosure into a USB port on a different PC or laptop that's working properly.

After retrieving the files on to a CD or DVD, remove the drive from the enclosure and put it back inside his laptop. Then proceed with eRecovery.

But please tell him how important it is to keep backups of his files on a different drive or on to CD/DVD in future! Then he'll be able to proceed with Recovery in future without worrying about his files!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Thanks for the help pip22, I did whatyou said and put the drive in an eclosure but if I try to access my computer on my system withhis drive plugged in it fails to respond as does disk management basically anything to do with windows explorer. I was wondering could I copy the folder if used a linx live cd on my system then plug his drive in would that work?
again thanks for the help
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Hi again, here's an update on this problem.
So the drive would not read if connected internally (it actually crashed my pc ) I was unable to get any of the F8 functions to work at all, if connected it to an external drive and plugged it in and tried to explore it, it would crash my system.
So i tried this , I downloaded Ubuntu 10.10 and ran it as a live cd on my pc then plugged in the external drive and Ubuntu was then able to read the drive, I was able to copy all the files that were needed. I then put the drive back into the laptop and ran the erecovery software and restored the system back to factory settings.
I hope this helps anyone else facing the same problem
P.S. many thanks to pip22
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top