Tech Support Forum banner

Acer Aspire 1410 missing device drivers

20419 Views 16 Replies 4 Participants Last post by  d.logan
I had to reinstall xp pro on my Acer Aspire 1410 laptop and afterwards the following problems are noted in device manager:
Ethernet Controller
Mass Storage Controller
Multimedia Audio Controller
Network Controller
Video Controller
Video Controller (VGA Compatible)
I went to Acer's website and downloaded the following files I thought pertained to these items based on their description:
After extracting them I attempted to repair the devices listed above to no avail. I'm not sure where to go from here.
The following is my system info:
Acer Aspire 1410
XP Professional SP 2
60 GB hd
512 Memory
Not open for further replies.
1 - 17 of 17 Posts
Re: Acer Aspire 1410 missing device drivers (partly resolved)

I got a response from a different forum on where to locate these drivers and all were successful with the exception of the mass storage controller and the network controller. I still can't seem to locate the drivers for those. Any help will be most appreciated.
Try this site:
The mass storage device maybe the card reader. It list 3 or 4 LAN drivers I am not sure witch one you have. Did you install the chipset driver?
Hope this helps.

Thank you for the info. This did resolve the mass storage controller driver issue but not the network controller driver issue. I got a reply from Acer America and what they said was that they don't support non Acer OEM operating systems which kind of sounds ridiculous. True, I did put XP professional on as opposed to XP home edition but I didn't think this was considered that much different and it was bought direct from Microsoft so there is no problem with authenticity. Anyway, I can't use wireless capabilities until I can get this figured out.

Thanks for your interest and help, at least the other issue was resolved.
Did you try the ambit wireless driver. Your model list 2 wireless drivers an intel and an ambit I am unsure whitch one you have. If you have the driver cd it maybe on it. XP pro or home should not make a difference. The funny thing is ACER supports XP Pro or home. Here is a spec sheet (look at the very bottom).
Thanks for the info but I didn't see the "spec sheet" reference you mentioned. I am showing under 'network adapters' in device manager as having a 1394 adapter and a broadcom 440x 10/100 integrated controller. Problems under 'other devices' was only showing Network Controller until today when I started up my computer and I noticed that now it is back to showing Network Controller and Video Controller (VGA compatible) as problems which I already resolved once. I have no idea why the video controller issue has reappeared.

Are either of the network adapters I listed above either of the two you mention that are listed for my computer? Where did you find the information you are referring to? I would love to get this figured out.
Thanks for your help, it is appreciated.
I just checked at the Acer website and I did download both of those wireless drivers and I'm still getting the network controller missing error in device manager. Could this network controller be referring to something else that isn't related to the wireless? I assumed it was to do with the wireless because I'm not able to use that feature but maybe it's something else??
Did you install th chipset driver? This is the first driver that should have been installed. The acer site list all the drivers you need:
You have a wireless driver and a lan driver. The broadcom 440x is the LAN.
I am unsure of the wireless, it could be intel or ambit.
Also, does this have Bluetooth capabilities?
The spec sheet is at this link:
Hope this helps.
Yes, I installed the chipset driver first and then the others. I've also tried uninstalling everything and reinstalling but this hasn't fixed the missing network controller either.
Can you run Everest under my sig. and post the results. I like to see what we have inside this computer.
I know this may not be of much help now but, when I installed the drivers for my Acer Travelmate I had no problems except that the modem now didn't work. It simply wasn't recognized. As it is built in the only thing I could do was to install a PCMCIA version and the drivers for it. This works perfectly and as I don't use the card slot for anything else it is just the job.
You may have to consider an add-on piece of hardware of you can't get drivers to work for you.
Fingers crossed though.
Please Help! I am having the EXACT same promlem. I just used the "official" acer restore disks with the "Official" windows xp version and the device manager is having a problem with a network controller. I have loaded up my realtek adaptor and it looks OK. This Network Controller is the only bad apple in device manager. I bought this machine about 2 years ago and this is hte first time I've tried hooking up ht einternet on it and it does not work. Thanks for your help! Jonathan
Hey goodpasture - try the web site for up-to-date drivers or even 'old' drivers if they still have those versions.

If you still have problems try contacting realtek if it doesn't cost anything else, you could try removing the current driver for the Network card then rebooting and reinstalling 'any' driver you have. Sometimes the machines' software 'sees' the driver the second time around. Sounds strange I know but, worth a go if it fixes things for you.

Remember that drivers can leave info lying around so an uninstall first followed by reboot is always best option to a straight update of the driver - if you are having problems.

If you are still getting nowhere and don't want to or can't get help from Acer then you may not have any other choice but to replace the Network module if you can. If it is part of the mainboard then you may have to buy an external usb or PCMCIA card type (shouldn't cost too much and you can probably find one cheap on Ebay).

Good luck.
Well actually I fixed this problem (sort of). I have an Acer Aspire T135 Board and I went to Acer's website and found the drivers page and there was a "BIOS Update R1B4". I loaded this to up hte BIOS (don't forget to go to your existing BIOS first and enable write capabilities first) and then the error of missing driver for network controller went away.

Now I have NO errors showing in my device manager but I still get the same end results. I plug in hte cable and it says "Limited Or No Connectivity" on my interenet connection. I've tried everything; even another NIC card but no good. I even reinstalled windows from the acer disks but no good. I plugged the cable in another computer and have internet no problem. Please help!
You say it is the Internet connection you don't have - I thought it was your Network card. Are you talking of your Modem?? Anyway I think you need to find an external device from somewhere, whether it is your Modem or your Network card and try this route along with installing the necessary drivers.
Go for a well known brand which is almost bound to work.
I have a Psion Gold PCMCIA card fitted permanently as my Modem as the internal Acer (Lucent Technologies one) stopped working after having to reinstall Windows. The Psion works well and easily available from Ebay cheaply.
Good luck.
Ok let me try to clear things up. The whole problem started with plugging in my internet patch cable from a switch. I got a "limited or no connectivity" error. I looked at device manager and got a big yellow error with "network controller" as the culprit. This seems to be a common problem with Acer's. I used the above mentioned BIOS update and that goes away. There is No yellow in device manager and all is good. I still get "limited or no connectivity" error on trying to get the internet working. I installed another network adaptor (Linksys) and get the exact same error. Now I have 2 network adaptors (all look good in device manager) and no internet. I dragged the cable to another machine I have in the house and it connects right up to the internet indicating it's still something in this Acer machine and not in my cable modem, switch, etc..

Please help... The problem is I plug my cable into the network adaptor and i get no internet with a pop-up error saying "limited or no connectivity". Any ideas to try?

thanks, Jonathan
See less See more
Hi jonathon - here is something to try.
Check all settings for your modem and your network card.
You should have settings from your ISP for the modem (username, password, telephone number, etc) sometimes the port that the modem uses has been selected wrongly for some reason, you can change this manually in the modem settings and simply try it our using the modem diagnostics tab. Make sure you have no other extarnal devices plugged in.
Your network card I'm not sure about as I don't use a home network but, there may be something in Windows Firewall stopping the connections. Try posting a question on one of the Windows forums. It does sound like a software/settings problem now that you seem to have no faults showing with the hardware but...
Good luck again.
1 - 17 of 17 Posts
Not open for further replies.