Tech Support banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Greetings.

I am running Cygwin under Windows 7 64-bit on a new machine. That's fine, except that when I try to run a2ps, it does nothing visible. This is the case even for something as innocuous as a2ps --version. When I echo $? after this exciting inactivity, I get 127. Huh? In errno.h, error 127 refers to a socket already selected.

So finally I tried running strace on the command:

strace -n --mask all a2ps --version

I got two error boxes in succession:

+----------------------------------------------------------------+
| There is no disk in the drive. Please insert a disk into drive
| \Device\Harddisk4\DR4
| [Cancel] [Try again] [Continue]
+----------------------------------------------------------------+


When I click any of these buttons, I get another box that tells me The application was unable to start correctly (oxc00000013).

I tried bluffing the program by creating the directory C:\Device\Harddisk4\DR4 but that did not resolve the problem.

By the way, I get the same boxes if I run strace with no options. Also, I just ran strace against bash so I can tell it's not a problem with strace.

Any clue out there as to what a2ps wants? I kinda depend on it from a previous XP environment. Any ideas about this?

Thanks much!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
JC,

First, thanks for making a logical attempt.
As a matter of fact I was not running the Cygwin/Bash window in elevated mode. I just ran it that way - choosing [Run as Administrator] from the right-click menu. In this mode I ran a2ps --version and got the same [non-] result. And running with strace gave the same boxes as before. :sigh:

In retrospect, it seems illogical that running in privileged mode would allow it to access a non-existent device file. But error messages are very good at misdirecting the debugger.

I really can't accept that this might be a 32/64 bit issue. I have Virtual Dimension in 32-bits running without a problem.

I'm all ears for suggestions. If I could just get it to start!

I will add that I downloaded and tried to compile a2ps v.4.14 and got a compiler error. FWIW, Here is the end of the "make" output:

/bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/local/share/locale\" -DSYSCONFFILE=\"/usr/local/etc/a2ps.cfg\" -I. -I.
-I.. -I.. -I../intl -I. -g -O2 -c -o hashtab.lo hashtab.c
gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/local/share/locale\" -DSYSCONFFILE=\"/usr/local/etc/a2ps.cfg\" -I. -I. -I.. -I.. -I../intl -I. -g -O2 -c hashtab.c -o hashtab.o
source='path-concat.c' object='path-concat.lo' libtool=yes \
DEPDIR=.deps depmode=none /bin/sh ../auxdir/depcomp \
/bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/local/share/locale\" -DSYSCONFFILE=\"/usr/local/etc/a2ps.cfg\" -I. -I. -I.. -I.. -I../intl -I. -g -O2 -c -o path-concat.lo path-concat.c
gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/local/share/locale\" -DSYSCONFFILE=\"/usr/local/etc/a2ps.cfg\" -I. -I. -I.. -I.. -I../intl -I. -g -O2 -c path-concat.c -o path-concat.o
In file included from path-concat.c:30:
/usr/include/string.h:58: error: parse error before "void"
make[3]: *** [path-concat.lo] Error 1
make[3]: Leaving directory `/home/Jake/scratch/a2ps/a2ps-4.14/lib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/Jake/scratch/a2ps/a2ps-4.14/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/Jake/scratch/a2ps/a2ps-4.14'
make: *** [all] Error 2

The error had me looking in _ansi.h and I note that there is no -DCYGWIN in these defines. This may indicate something wrong with the a2ps "configure" script. But that makes little sense, since it was working on my previous XP system.

Is it possible that the the 4.13 version included with this Cygwin download was linked file that should have failed, that it was a bad compile/link that made it through somehow? I recall old C compilers letting that happen, though I would expect that not to be possible anymore.

Is that out of your domain, JC?

Again, thanks.

-- R.P.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top