Tech Support Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 97 Mazda 626 with a 2.5 v6. I'm having a problem with acceleration, If I feather the pedal and pick up speed gradually, it seems to be ok, but if I take off normally or try to acceterate faster it starts to bog down and sometimes even stalls out, acts like it is out of gas. Any help would be greatly appreciated. Thanks, Billy
 

·
Registered
Joined
·
205 Posts
hi billy


you may try to put a fuel filter on it.

for more detailed diagnostic it would be good to know how much fuel pressure the pump is giving. sounds as if your fuel pressure is low and the car is running out of gas when you take off due to the pump not giving the engine enough pressure.

a clogged catalytic converter can also make a car lag badly on acceleration.

good luck
Bud.
 

·
Registered
Joined
·
144 Posts
I have a 97 Mazda 626 with a 2.5 v6. I'm having a problem with acceleration, If I feather the pedal and pick up speed gradually, it seems to be ok, but if I take off normally or try to acceterate faster it starts to bog down and sometimes even stalls out, acts like it is out of gas. Any help would be greatly appreciated. Thanks, Billy
Hi Bill, I just wanted to add my thoughts on the issue. I am not an expert but I own a Mazda GLC. On the electrical side, you might try to check the vacuum advance unit for proper operation. With the engine idling connect a vacuum guage to the advance unit and apply vacuum. The timing should be advanced according to the vacuum applied. Replace unit if faulty.
Note, faulty unit will also cause overheating on the freeway.:sigh:

I have a check for the CAT as well, loosen the exhaust manifold bolts and try the acceleration again. Improvement means the CAT is plugged.
Note the CAT problem was caused by another problem (excess fuel usage?)
Excess fuel damages the CAT.:eek:
Later DAZE...
 

·
Registered
Joined
·
18,118 Posts
There are also a few sensors that ought to be checked, especially the O2 sensor. A rich mix can be what's possibly clogging the catalytic if that is the problem. A vacuum seal may also be bad or a cracked PVC joint. You're gonna have to crawl all over the engine.
 

·
Registered
Joined
·
1 Posts
i am having the same problem with a 91 626 with a 2.2 when starting out & going through the gears it just bogs down like its out of gas then it`ll kick in for a sec & bog down again. the fuel pump was replaced also the fuel filter, pressure regulator and air filter. i checked all hoses for cracks and pvc. the only thing i didn`t replace is the o2 sensor & cat. i tried to get a obd 1 but they don`t sell them anymore. i found a link on here on how to check codes. i connected to the green single pin and the battery ground but all i get is a flash & pause over & over. no long or short flashes. any help would be appreciated. thanks.
 

·
Registered
Joined
·
1 Posts
Tran_Mechanic
If this vehicle has a cracked hose at the air intake to the mass air flow sensor, it will open up as the engine torques to the right during accel. and will suck air thru the cracked hose. Light throttle allows for now engine lift so engine seems to run OK.
Hope you fix it!
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top