Tech Support Forum banner

'96 Sunfire, Battery Problem

2307 Views 3 Replies 3 Participants Last post by  bruiser
Well, I was driving along one day and the timing chain snaps. I park it in my buddy's yard for a few months before I decide to get it fixed. I pay a mechanic to replace the chain (the car was in NC and I was in VA) and he does so, but when I return to NC to pick up my car the engine is shaking violently. I'm thinking it just needs a tune-up (mechanic said it may have just gotten some carbon buildup on the heads) so I drive it back to VA and plan on giving her a good once over in a couple days. But on the way when I stop for gas, the car refuses to start a couple times. It would want to start to turn over, but it sounded like it wasn't getting enough energy to do so, and the inside lights would dim when I tried (would make a loud clicking noise too.) But after letting it sit a couple minutes it would get enough juice to crank and I'd drive off. I get to VA and go to work the next day, but again she wouldn't crank. Eventually the battery just died outright. So I boost it, but shortly after I take the cables off the boost it dies. I replaced the alternator and now it'll idle on it's own after I boost it, but it's still not charging the battery because when I turn it off and try to crank it it's not getting enough juice to do so. Also, if I turn the headlights on, the dash/radio lights cut off completely. I replaced the battery before I replaced the alternator and it killed that battery too. So I've got a brand new battery that's dead, with brand new cables (replaced the battery cables after the batt died.) None of the terminals/cables are corroded. Can't figure it out.

Edit: The Voltage Regulator is encased in the alternator. I had the old alt. tested, and it tested good so I thought it was the regulator only to discover the above. Also, one of the cylinders isn't firing at all (when I remove the plug, the engine doesn't change at all.) Replaced the plugs and that one cylinder still doesn't fire (the cable is getting fire, but that's as far as the spark goes.)
See less See more
Not open for further replies.
1 - 4 of 4 Posts
Did you have the new battery checked out? It isn't uncommon to have a defective battery on the shelf.
As far as the dead cylinder. You could have a faulty injector. What motor do you have ?
Not yet

It's the 4cyl, 2.2L engine.

As far as the battery goes, I let it idle for 45 minutes and then I cut it off and tried to start it, it almost started. Boosted it and let it idle on it's own for a couple hours and just tried it again and it started right up. It seems to be charging awfully slowly.

Going to drive it to Autozone to get my $55 back for the old alternator core and when I do I'll have the battery checked out. Thanks for the tip on the injector, will check that out too.
If your battery is even slightly marginal, the test Autozone uses will certainly bring that out. The load their tester puts on the battery might even finish it off, and you'll have to buy a new battery.
1 - 4 of 4 Posts
Not open for further replies.