Tech Support banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
This car has the 2.2 liter engine and an automatic transmission. When the car is put into drive and the gas depressed the acceleration is constantly intermittent. The rpms drop to almost 0 then back to normal then back to 0 again over and over again until the car stalls. The pulsing has a frequency of about 0.5 seconds rpm fine 0.5 seconds stalling. This does not happen if the car is driven in reverse. It accelerates smoothly and properly in reverse just not in drive and it does not seem to matter if the car is in low or normal drive. This problem started a couple of weeks ago and has just started getting worse and worse. Now it does it every time I step on the gas. Any help would be greatly appreciated.
 

·
Registered
Joined
·
35 Posts
check the air inlet hose from the air cleaner box to the throttle body if it is ripped open the mass air flow sensor will a false reading and the car wont run well. It doesnt happen in reverse because the motor flexes the other way on the motor mounts. if the hose is ripped it can be purchased only from the dealer or a salvage yard. please post and let me know if this fixed the problem

bye the way the hose usualy ripps on bottom
Dan
:wave:
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
That Was It!

Thanks so much! I would have never guessed that one. I really appreciate the information and thanks again everything is working fine again.:pray:
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top