Tech Support Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter · #1 ·
Hi I have a 1980 Chevy Scottsdale K20 4x4 that has a brake issue. The brakes will take effect at about the 9th pump of the pedal but once I take my foot off the pedal it loses pressure; I have to pump about 9 times before they come back. No leaks anywhere that I can see. I am 14 and WILL NOT sell this truck. (Back brakes leaked severely, clamped lines shut no pressure or fluid leaks from that area.)
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #3 ·
Hi Corday I have bled the brakes at least four times and no difference. As far as I know, no wheel cylinders or master cylinder replaced. Was my grandpa's truck and he gave it to me for free. Brakes worked great after I got it running two years ago. This issue started about a year ago.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #5 ·
Hi Corday I have done that with the fronts but, as stated before, I have the back brake lines clamped off so I have no fluid to the back brakes, as they leaked severely. Fluid was changed.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #10 ·
Hi I have changed the brake fluid and have done as suggested. It takes about 6 hard pumps before it holds pressure IF I keep my foot on the pedal. When my foot is on the pedal, it does not move. When I let off, pressure is gone in about 3 seconds. It holds a little pressure but not enough to operate the brakes. I pump the pedal about 6 times, they "take hold" (for lack of a better term).
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #14 ·
Hi My grandfather owned it and he gave it to me. The bleed screws are on the top. I plan to get it to a shop near home at some point, but it is not too important. It is only used around the farm and it isn't licensed. Wolfen1086, I live very near Flandreau, SD. Small town.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #24 ·
Stupid pickup. I now have a no start issue. I can't smell any fuel. I am afraid that the lift pump went out. It would start great until about five days ago. I am starting to think of selling it and buying a 2002 chevy duramax. Anybody help is, again, greatly appreciated. Wolfen1086, I didn't get around to the vacuum test. Might get it fixed or just park it again.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #26 ·
Hi, yes, I might fix it, but I don't think anybody would buy it or take a trade for the d*** thing. I do plan to buy the duramax earlier mentioned - it is located about 5 1/2 miles from me. Just one obstacle-my dad. I'd have to talk him into it first.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #30 ·
Hi, I tried on it yesterday, it was dead (blower motor has a short) I can now smell fuel, it did try to run but it didn't quite get there. The Duramax purchase is not happening. The head gaskets are out on it. If anybody has one (2001-2004) that they would be willing to sell for cheap, let me know.
 
1 - 20 of 20 Posts
Top