Go Back   Tech Support Forum > Alternative Computing > Mac Support

User Tag List

Use a rusted USB connector?

This is a discussion on Use a rusted USB connector? within the Mac Support forums, part of the Tech Support Forum category. Hi, Iíve been using a 500 GB LaCie portable for backing up data on my Mac. Unfortunately, due to some


Closed Thread
 
Thread Tools Search this Thread
Old 08-20-2015, 06:00 AM   #1
Registered Member
 
Join Date: Jul 2010
Location: Atlanta
Posts: 165
OS: OS X 10.6



Hi,

Iíve been using a 500 GB LaCie portable for backing up data on my Mac.

Unfortunately, due to some negligence on my part the metal of the USB at the end of the connector that plugs into the port in the computer has got rusted.

Now Iíve recently got a new MBP and am worried if using the rusted connector can harm the new MBPís USB port in any way.

Getting a new connector for the external is not possible.

Should I get a new external HDD or is it okay to use the old one?

Thanks!
AM_SOS is offline  
Sponsored Links
Advertisement
 
Old 08-20-2015, 06:24 AM   #2
Team Manager
Microsoft Support
 
Corday's Avatar
 
Join Date: Mar 2010
Location: Midlands of South Carolina
Posts: 25,982
OS: Windows10. In the past CP/M, DOS, Windows 95, 2000, 98SE, ME, Vista & Windows 7

My System


Coating is usually nickel or copper. Are you sure it's rust? You could try to remove it with any rust removal product that contains oxalic acid. Protect yourself (rubber gloves). Rust is actually harmful.
__________________

The stability of an OS is in direct proportion to the stability of the user.
Corday is offline  
Old 08-20-2015, 03:51 PM   #3
Moderator - Alternative Computing Team
 
MartyF81's Avatar
 
Join Date: Jan 2013
Location: Chicago
Posts: 900
OS: Mac OS, Windows, iOS

My System


its the connecter on the Drive? or the connector on the cable? I am not understanding why you cannot just replace the cable? It just a USB cable.
__________________
MartyF81 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
no audio after installing XP Pro SP3 to IBM T60
Sound worked fine before installing XP Pro SP3......after instal, no audio. No audio after installing XP Pro SP3 (from disc) on an IBM/Lenovo T60 ThinkPad. IBM/Lenovo drivers from Lenovo Support site for "Audio Device on High Definition Audio Bus" are not recognized when trying to install...
Ray G Windows XP Support 19 11-20-2012 07:15 AM
Problem viewing Youtube Videos on win 7 - display adapter problem
Hi, Hoping someone can help shed some light on my problem, I use youtube quite a bit, but over the last week, when i play a youtube video, my computer randomly shuts down on me, as far as i am aware i haven not changed any set up within my pc and have not had this problem before, now, this...
Reeksy Windows 7 , Windows Vista Support 11 03-20-2011 05:28 AM
[SOLVED] A little clarification needed please?
Hi folks, Hoping you can give me some advice on something, I need to update my friends computer with more ram he is currently running 2 x 256mb for a poor total of 512MB RAM, I had a spare 512MB ram module, which i had previously taken out of another pc, however i cannot get it to seem to fit...
Reeksy RAM and Power Supply Support 8 02-27-2011 09:03 AM
Infinite Hourglass in Windows Explorer
Hello, TSFers! I'm experiencing a problem that consistently forces me to a hard shutdown. Occasionally--but without fail at some point--when I'm using Windows Explorer to navigate to a file on my external drive, I get a "permanent" (i.e., it'll go on indefinitely) hourglass once I click on the...
misha.spisok Windows XP Support 9 01-29-2011 04:11 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 02:50 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts