Go Back   Tech Support Forum > Alternative Computing > Mac Support

User Tag List

Logic Board Recap

This is a discussion on Logic Board Recap within the Mac Support forums, part of the Tech Support Forum category. Imac G5/20"/2.0/1 GB/250 GB/SD Serial# Qp5190A5SDW, A1067, May, 2005. Second generation. Logic Board# 30098 W85188BRSCLZw Q45D best 2.0 Ghz I'm


Closed Thread
 
Thread Tools Search this Thread
Old 11-07-2017, 01:41 PM   #1
Registered Member
 
Join Date: Nov 2007
Posts: 189
OS: Windows XP Version 2002



Imac G5/20"/2.0/1 GB/250 GB/SD
Serial# Qp5190A5SDW, A1067, May, 2005. Second generation.
Logic Board# 30098 W85188BRSCLZw Q45D best 2.0 Ghz

I'm recapping this logic board and can't find replacements for 2 Rubycon capacitors:

(1) T0442 105c
(2) 500 mf

Where can I obtain these replacements? Can they be cross referenced? Also, are there online schematics for these boards?
manhattanman is offline  
Sponsored Links
Advertisement
 
Old 11-07-2017, 02:47 PM   #2
Team Manager
Microsoft Support
 
Corday's Avatar
 
Join Date: Mar 2010
Location: Midlands of South Carolina
Posts: 25,986
OS: Windows10. In the past CP/M, DOS, Windows 95, 2000, 98SE, ME, Vista & Windows 7

My System


Cross Reference here: Cross Reference Search / Rubycon Corporation
__________________

The stability of an OS is in direct proportion to the stability of the user.
Corday is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
no audio after installing XP Pro SP3 to IBM T60
Sound worked fine before installing XP Pro SP3......after instal, no audio. No audio after installing XP Pro SP3 (from disc) on an IBM/Lenovo T60 ThinkPad. IBM/Lenovo drivers from Lenovo Support site for "Audio Device on High Definition Audio Bus" are not recognized when trying to install...
Ray G Windows XP Support 19 11-20-2012 07:15 AM
What socket is my board?
Hi guys, this is my current board (old i know) WinFast 6150M2MA FAB2.0 I think this model may have been bought out by a different company, and foxconn have something under the same name, however I don't know if this is the exact same board. If any knows what socket CPU my board needs it would be...
Vijatoffee Motherboards, Bios & CPU 6 01-27-2012 09:14 AM
[SOLVED] ASUS Server Board Issues
Hi guys, so im building a new server and got the asus board and was doing the bench test on it before i started to install it in the chassis so i get 1 long and 2 short beeps right off the back this is only when board is plugged to PSU, cpu, and one RAM Stick so i start looking for what it...
loda117 Motherboards, Bios & CPU 9 08-12-2011 09:56 PM
Motherboard Fried?
Last night my 500 watt power supply was acting up. It started then shut down automatically. After 20 trys I got mad and switched the voltage to high. Now when i started it it shut off completely. Now I get no green light on Motherboard. Its like its dead now. DID I FRY the MOTHER BOARD??? ...
gmasi08 Motherboards, Bios & CPU 6 01-06-2011 01:35 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 02:39 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts