Go Back   Tech Support Forum > Microsoft Support > Windows 8, 8.1 Support

User Tag List

SSD very Slow after Sleep Mode

This is a discussion on SSD very Slow after Sleep Mode within the Windows 8, 8.1 Support forums, part of the Tech Support Forum category. Hi, I just installed a brand new Samsung 256GB EVO Pro SSD into a system and installed on the drive


Closed Thread
 
Thread Tools Search this Thread
Old 03-22-2015, 10:32 PM   #1
Microsoft MVP
Microsoft Team Moderator
Articles Team Manager
Hardware Team Moderator
 
Masterchiefxx17's Avatar
 
Join Date: Feb 2010
Location: Wisconsin, USA
Posts: 39,491
OS: Windows 10 Professional 64bit

My System


Hi,

I just installed a brand new Samsung 256GB EVO Pro SSD into a system and installed on the drive is Windows 8.1 Pro 64bit. (8GB of RAM - Desktop PC)

The system is running smoothly, however, when the PC enters sleep mode things change. It enters sleep mode just fine, but when resuming sleep mode everything is very slow and sluggish.

The mouse and keyboard fail to function unless I turn one of them off and back on again, then I receive a Windows error saying that have stopped working.

You cannot browse the internet, it basically never gets to finish. Then to make matters worse, once the PC is out of sleep mode and you try to restart, it just sits at the restart screen for over five minutes.

Everything is fully up-to-date, including the SSD firmware. SFC did not find any errors.

I believe this is a Windows based issue as the SSD is lightening fast when operating in normal mode, before it falls asleep.

This page here explains my problem exactly:

Trouble Waking Up After a Deep Sleep? | Other World Computing Blog

Only thing is that is for a Mac, I'm on Windows.

There is an older hard drive that is also in the PC as a storage drive that runs on the Marvell SATA ports.

Edit: Here's something I just noticed. After coming out of sleep mode, the secondary hard drive is pinned at 100% and you cannot access the drive. Could this hang the restarting process? Any reason its running at 100%?
Masterchiefxx17 is offline  
Sponsored Links
Advertisement
 
Old 03-22-2015, 10:53 PM   #2
Registered Member
 
OLD MAN EMU's Avatar
 
Join Date: Mar 2015
Posts: 50
OS: Windows7

My System


Hi.
Crucial say not to let their SSD or any SSD enter Sleep Mode.

I run all SSD'S on three OS's and always turn off Sleep/Hibernation.
OLD MAN EMU is offline  
Old 03-22-2015, 11:42 PM   #3
MPR
TSF Enthusiast
 
Join Date: Aug 2010
Posts: 5,232
OS: Win 8.1



Take a look at this article MasterChief. The issue may be one with failure of the drive to be properly Trimmed in Windows 7, which doesn't have the user-activated Optimize command that Windows 8 does, combined with the SSD being set to shut down in sleep mode, where it can't perform its garbage collection tasks. You may not have a Crucial per se but other SSDs probably work in a similar fashion.

Quote:
Crucial SSDs have a maintenance feature called Active Garbage Collection built into the controller. Active Garbage Collection is triggered when the SSD has power but no data throughput, and does background cleanup on the SSDs. The purpose of this feature is to maintain the SSD's performance in environments where for any reason TRIM is not a possibility, by cleaning out the cells on the SSD as data is removed. If TRIM is present it will handle this background cleanup, but if for any reason TRIM can't reach the SSD, Active Garbage Collection is there to take care of the drive.

However, in order for Active Garbage Collection to have an effect, the SSD needs to have periods of idle time, since that is the only time when the feature is able to run. If the SSD is not given any idle time, for example in a computer that is powered on, constantly working, and then immediately powered off, then Active Garbage Collection will never be triggered. Almost as important as idle time, is that the SSD has empty space to work with. TRIM and Active Garbage Collection both rely on the ability to move data between sectors as a part of the clean-up effort, and without sufficient empty space on the SSD, the clean-up will either be ineffective, or worse, won't take place at all.

An SSD that is not receiving TRIM commands and where Active Garbage Collection never runs properly, will never have the cells on the drive cleaned out after data is deleted. That will over time lead to an accumulation of 'junk' data, which slowly will clog up the drive. Eventually this well result in a drop in performance, and sometimes even a complete lack of response from the SSD.

If that has happened to your SSD, you may simply need to force Active Garbage Collection to run on the drive by powering the SSD on and leaving it idle for 6 to 8 hours. After that, your drive’s functionality and performance should be restored.

Follow these steps to trigger Active Garbage Collection on your Crucial SSD:

On a desktop PC, simply disconnect the SATA cable from your SSD and only leave the power cable connected. After switching your PC on, the SSD will be in an idle state but still have power so Garbage Collection can function. On a laptop, power on with the SSD installed and enter your system BIOS (please refer to your system manufacturer’s documentation on how to access the BIOS.) Leave the laptop in the BIOS menu for the 6-8 hours.

On a Mac, press the Options key while powering on to enter the Startup Manager screen. Leaving the Mac on that screen provides the SSD with power but keeps it in an idle state so Garbage Collection can function, just like the BIOS screen on a Windows laptop.

To prevent the SSD performance from degrading again in the future you can adjustment your power settings, to make sure that the SSD stays powered on when your computer goes into sleep mode.

In Windows:

- Go to Control Panel
- Go to Hardware and Sound
- Go to Power Options
- Select Change Plan Settings
- Select Change Advanced Settings
- Make sure the 'hard disk' field is set to ‘never’ (Laptop users select 'battery and power adapter').

On a Mac computer:

- Go to System Preferences
- Go to Energy Saver
- Make sure 'Put the hard disk(s) to sleep when possible' is unchecked.

My SSD used to be so much faster... What happened? - Crucial Community
MPR is offline  
Sponsored Links
Advertisement
 
Old 03-23-2015, 10:48 AM   #4
Microsoft MVP
Microsoft Team Moderator
Articles Team Manager
Hardware Team Moderator
 
Masterchiefxx17's Avatar
 
Join Date: Feb 2010
Location: Wisconsin, USA
Posts: 39,491
OS: Windows 10 Professional 64bit

My System


Quote:
Originally Posted by OLD MAN EMU View Post
Hi.
Crucial say not to let their SSD or any SSD enter Sleep Mode.

I run all SSD'S on three OS's and always turn off Sleep/Hibernation.
It won't hurt the SSD to put it into sleep mode.

Quote:
Originally Posted by MPR View Post
Take a look at this article MasterChief. The issue may be one with failure of the drive to be properly Trimmed in Windows 7, which doesn't have the user-activated Optimize command that Windows 8 does, combined with the SSD being set to shut down in sleep mode, where it can't perform its garbage collection tasks. You may not have a Crucial per se but other SSDs probably work in a similar fashion.




My SSD used to be so much faster... What happened? - Crucial Community
The HDD is set to sleep after 20 minutes, but I am performing the sleep operation way before the PC is even awake for 20 minutes. I'll set it to zero and see if that fixes it.

Any reason why the PC would be running the secondary hard drive at 100% after coming out of sleep?
Masterchiefxx17 is offline  
Old 03-23-2015, 12:23 PM   #5
MPR
TSF Enthusiast
 
Join Date: Aug 2010
Posts: 5,232
OS: Win 8.1



Are you referring to shutting down disk activity as "sleep" or putting your computer into sleep mode? I'm a bit confused here.

The article I linked showed that SSD garbage collection requires the SSD to remain on but not accessed for several hours to complete. Now, Windows 7 should be able to trim the disk but maybe it's not doing that. This is what I like about Windows 8 -- it has an active trim command (Optimize) for SSDs, which can be scheduled or run anytime.

Of course, you can check to see if the Windows 7 Trim operation is activated by entering the command

Code:
fsutil behavior query disabledeletenotify
If it returns 0 then it's activated. If not, then the command

Code:
fsutil behavior set disabledeletenotify 0
will activate it. Well, maybe. read this:
Quote:

The DisableDeleteNotify command only indicates that the operating system is passing the TRIM command on to the storage drivers. It does not indicate whether or not the storage drivers are passing the command on to the storage controller IC in the SSD, or whether the storage controller IC supports TRIM. As such, as result of “0” is not a guarantee that TRIM is functioning correctly.
This is why I think that SSDs running under Windows 7 should have some un-accessed active time in order to perform their garbage collection tasks (i.e., computer idle with SSD set to "always on" in power management).
MPR is offline  
Old 03-23-2015, 12:48 PM   #6
Registered Member
 
OLD MAN EMU's Avatar
 
Join Date: Mar 2015
Posts: 50
OS: Windows7

My System


This is where I got my info from re putting SSD's into sleep mode in my previous post
Guess you can't believe everything you read.

https://www.tomshardware.com/forum/272075-32-sleep
OLD MAN EMU is offline  
Old 03-23-2015, 01:17 PM   #7
Microsoft MVP
Microsoft Team Moderator
Articles Team Manager
Hardware Team Moderator
 
Masterchiefxx17's Avatar
 
Join Date: Feb 2010
Location: Wisconsin, USA
Posts: 39,491
OS: Windows 10 Professional 64bit

My System


I'm running the system on Windows 8, not Windows 7. Yes TRIM is enabled on the OS.

I have a feeling the issue lies with the secondary hard drive running at 100% after coming out of sleep.
Masterchiefxx17 is offline  
Old 03-23-2015, 01:32 PM   #8
Microsoft MVP
Microsoft Team Moderator
Articles Team Manager
Hardware Team Moderator
 
Masterchiefxx17's Avatar
 
Join Date: Feb 2010
Location: Wisconsin, USA
Posts: 39,491
OS: Windows 10 Professional 64bit

My System


Could this maybe be the issue?

https://support.microsoft.com/en-us/kb/2922899
Masterchiefxx17 is offline  
Old 03-23-2015, 04:33 PM   #9
Moderator
- Microsoft Support
BSOD Kernel Dump Analyst
 
satrow's Avatar
 
Join Date: Feb 2012
Location: Wales U.K.
Posts: 5,694
OS: W7 SP1 Pro x64

My System


That looks favourite to me, shouldn't take too long to test it.
__________________
satrow is offline  
Old 03-23-2015, 05:52 PM   #10
Microsoft MVP
Microsoft Team Moderator
Articles Team Manager
Hardware Team Moderator
 
Masterchiefxx17's Avatar
 
Join Date: Feb 2010
Location: Wisconsin, USA
Posts: 39,491
OS: Windows 10 Professional 64bit

My System


One thing before I do the command, I never use Power Saving mode, so would I still experience the same issue caused from that?
Masterchiefxx17 is offline  
Old 03-23-2015, 06:54 PM   #11
Moderator
- Microsoft Support
BSOD Kernel Dump Analyst
 
satrow's Avatar
 
Join Date: Feb 2012
Location: Wales U.K.
Posts: 5,694
OS: W7 SP1 Pro x64

My System


Sleep is a power saving mode.

Check the options you have under Power Saving in Control Panel and the Advanced settings, you should find that you can fine tune things from there.

Switching to the Balanced setting should be a valid workaround, according to that article (as is buying a drive that supports APS and/or replacing the 'board or updating the 'board's BIOS).

Also, there are hardware power saving settings under Computer Management (USB, Network/Wireless devices, perhaps more) that you can enable/disable.
__________________
satrow is offline  
Old 03-23-2015, 07:06 PM   #12
Microsoft MVP
Microsoft Team Moderator
Articles Team Manager
Hardware Team Moderator
 
Masterchiefxx17's Avatar
 
Join Date: Feb 2010
Location: Wisconsin, USA
Posts: 39,491
OS: Windows 10 Professional 64bit

My System


Sorry, I should have been more clear.

My power options are selected on Balanced, they were never selected on Power Saving as the Microsoft article suggests.
Masterchiefxx17 is offline  
Old 03-23-2015, 07:13 PM   #13
Moderator
- Microsoft Support
BSOD Kernel Dump Analyst
 
satrow's Avatar
 
Join Date: Feb 2012
Location: Wales U.K.
Posts: 5,694
OS: W7 SP1 Pro x64

My System


Change it to something else and then switch back - some things MS can be a little buggy at times.

Also, there's a chance that a 3rd party software (like Samsung's, for instance) could have altered some powercfg settings in the background.
__________________
satrow is offline  
Old 03-24-2015, 01:01 AM   #14
TSF Enthusiast
 
Join Date: Jul 2009
Location: Australia
Posts: 2,779
OS: W7 Home Premium 64 Bit

My System


The Marvel controller may be the issue here.
You could disable that in the BIOS and or connect the mechanical drive to the Intel SATA port, just to try it.
Panther063 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Coolers on Sleep mode
I own ASRock Conroe1333-1394 motherboard, my BIOS is American Megatrends Inc., version P1.40. Processor Intel Core 2 Duo E6400 @ 2.13 GHz GPU NVIDIA GeForce 9800 GT My problem is that coolers don't turn off on stand by (sleep) mode. On my previous motherboard they did. I have googled the...
mare011 Motherboards, Bios|UEFI & CPU 0 10-30-2014 12:46 PM
Windows 7 Running Slow After Sleep Mode
Hey guys, I have a strange problem. My laptop, an Asus K53, runs extremely slow after coming out of Sleep mode. If I put it in Hibernate or shut it down then it runs fine after I boot it back up, but if I just leave it sitting or just shut the lid (both of which put it to sleep) then when it boots...
Flight Sim Guy Windows 7 , Windows Vista Support 12 08-25-2014 02:45 PM
Mini DisplayPort to VGA Sleep Mode Issues
Hello. I recently bought a StarTech MDP2VGA Mini Display Port to VGA Video Adapter Converter for my laptop, as I had a perfectly good monitor sitting in my closet that I had the idea to use as a second (extended desktop) monitor, but no VGA port built into the laptop. Everything seems to be...
parrotmonkey87 Windows 7 , Windows Vista Support 0 12-28-2011 11:37 AM
Computer makes whoosing sound after coming back from sleep mode
Hello! When my computer comes back from sleep mode, it intermitently makes a whooshing sound. Is this the drive spinning up? It only happens after coming back from sleep mode. If the computer never goes into sleep mode, the problem doesn't occur. Is this something serious or should I just live...
mickd3 Windows 7 , Windows Vista Support 7 11-21-2011 02:47 PM
[SOLVED] Stop windows from going into sleep mode
Windows XP Pro sp3 How do I prevent windows from going into sleep mode when no one is logged in? The Power Options in the Control Panel only affects the user that is logged in. I tried going into the registry and changing the power setting for the Default user (always on), but it is still going...
dmdombroski Windows XP Support 7 02-01-2011 08:51 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 11:05 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts