Go Back   Tech Support Forum > Smart Devices > Android OS

User Tag List

Worried my phone won't start

This is a discussion on Worried my phone won't start within the Android OS forums, part of the Tech Support Forum category. I have a Samsung S3 Mini that I've owned for nearly 2 years. Recently the battery died, but only after


Closed Thread
 
Thread Tools Search this Thread
Old 12-11-2015, 12:46 AM   #1
Registered Member
 
Join Date: Apr 2015
Location: Cape Town, South Africa
Posts: 35
OS: Windows 10



I have a Samsung S3 Mini that I've owned for nearly 2 years. Recently the battery died, but only after I used it until it absolutely wouldn't work anymore. By the end the battery was bloated and could only barely fit in the phone anymore, and it had to be physically stuffed in.

When it finally died, my phone froze and nothing would do anything to fix it, including holding the power button until it would normally reset itself. The other day I finally got a replacement battery, but when I put it in, the phone wouldn't start, even after I left it charging for an hour. Optimistically, I think the battery was a dud. One of those budget ones that didn't even have the sticker stuck on properly.

I'm getting a new battery in a day or two, but in the meantime I want to try and work out if there could be anything wrong with the phone itself, and preferably find out if I can take it in to get fixed or if it's messed up permanently.

As far as I can tell I might have damaged the inner workings by shoving a battery in there so hard that the outer casing cracked from the effort of trying to shut it inside the phone. Aside from that I've noticed that there MIGHT be a panel that fell out at some point? (I have no idea, I rarely open the back of my phone). The panel I'm talking about is on the bottom left with the gold ring in it. For some reason my browser won't let me attach a photo, sorry.

There doesn't seem to be any damage to the blue area - at least, I can't see anything.

Please let me know as soon as possible, I went off the grid sort of abruptly and I need to let people know I haven't spontaneously combusted or something.

Thanks in advance!
Adze95 is offline  
Sponsored Links
Advertisement
 
Old 12-11-2015, 11:16 AM   #2
TSF Moderator
Hardware Team
Networking Team
 
SpywareDr's Avatar
 
Join Date: Jun 2013
Location: Maryland, USA
Posts: 6,608
OS: W10P64 10.0.19041.264; W7U64; W7P64; XPP32; Zorin; Slax; Ubuntu; Kali (BackTrack); Android 6.01



I have seen several physically damaged cellphones due to a swollen battery. It often physically crushes and/or cracks the internal circuitry and chips.
SpywareDr is offline  
Old 12-11-2015, 11:38 AM   #3
Registered Member
 
Join Date: Apr 2015
Location: Cape Town, South Africa
Posts: 35
OS: Windows 10



Quote:
Originally Posted by SpywareDr View Post
I have seen several physically damaged cellphones due to a swollen battery. It often physically crushes and/or cracks the internal circuitry and chips.
Ah hell, that's not good. I guess I'll need to replace it then if the tech shop nearby can't fix it.
Adze95 is offline  
Sponsored Links
Advertisement
 
Old 12-11-2015, 12:17 PM   #4
TSF Moderator
Hardware Team
Networking Team
 
SpywareDr's Avatar
 
Join Date: Jun 2013
Location: Maryland, USA
Posts: 6,608
OS: W10P64 10.0.19041.264; W7U64; W7P64; XPP32; Zorin; Slax; Ubuntu; Kali (BackTrack); Android 6.01



When an electronic component gets cracked, it lets the smoke out. And once the smoke gets out, there is no getting it back in.
SpywareDr is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP: Running Medieval Engineers on a mac through windows 7 with vmware
Title says it pretty clearly, I need help with running Medieval engineers on my mac through windows 7 (as medieval engineers is not yet ported to OSX) with vmware. I managed to install the game on steam, but when I run it I get an error-message as follows: So I checked the error log, and...
EliasManser PC Gaming Support 0 02-21-2015 09:22 AM
~*~Mixed Bag of Problems~*~
Hi, everyone! I have had a lot of problems with my computer lately and I'm hoping someone would be able to help me out. The most pressing issue right now is that my e-mail is sending out Spam links when I'm not even on my computer. The first time it happened, I changed my password, but tonight the...
TabbyCat725 Virus/Trojan/Spyware Help 156 07-09-2012 07:50 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 04:55 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts