Go Back   Tech Support Forum > Smart Devices > Android OS

User Tag List

usb c connection issues

This is a discussion on usb c connection issues within the Android OS forums, part of the Tech Support Forum category. hi all, recently I've been having trouble using wired headphones on my Xperia XZ2 using an adapter. I've tried two


Closed Thread
 
Thread Tools Search this Thread
Old 06-11-2019, 03:26 PM   #1
Registered Member
 
Join Date: Jun 2019
Posts: 2
OS:



hi all, recently I've been having trouble using wired headphones on my Xperia XZ2 using an adapter. I've tried two different adapters, two different sets of headphones and I've tried cleaning out as much as I can from the port to no avail.

the device will charge with no problem whatsoever but when using headphones the media playing will inexplicably pause, sometimes even playing through the phone's speakers when I hit resume even though the headphones are still connected. I'm not sure what's going on or how to fix it, I've tried booting in safe mode, uninstalling antivirus, disabling headset buttons in case of faulty connection, a factory reset and essentially anything else under the sun that doesn't involve taking the phone apart, all not working. Not even the built in support app could help.

at the moment I'm using a small workaround called Lesser AudioSwitch, however the music will still pause and stutter, all the app does is eliminate the need to press play again by forcing audio through the headphones only. I just want to listen to music with no interruptions.

can anyone help me out?
slfrflxns is offline  
Sponsored Links
Advertisement
 
Old 06-12-2019, 02:05 AM   #2
Moderator
Windows Tech Team
Hardware Tech Team
 
Join Date: Aug 2008
Location: INDIA
Posts: 2,976
OS: Windows 10 | CentOS | Manjaro



Audio and Power travel through different leads in the connector, so there are a lot of chances that the audio leads might have failed or corroded however the power leads are clean (probably due to repeated use). If this is a hardware problem, I think the pause could be due to the headset connector temporarily disconnecting and connecting back, when this happens Audio players usually just go into pause/stop mode. (My perception)

My approach usually is to get a thin bristle brush use Isopropyl alcohol to moisten the bristle (Not wet), put the bristles in at one end and push and lift gently to the other end, this will remove any lint or dust from the connectors and possible surface dust on the leads, I have a more advanced method, but if done incorrectly, you can burn your phone, so let's try this first.
__________________


tristar is offline  
Old 08-01-2019, 04:08 PM   #3
Registered Member
 
Join Date: Jun 2019
Posts: 2
OS:


hi all,

so unfortunately the issue from my previous post is persisting with only a small period of reprieve, however this time around I'm recieving an error message.

this is slightly paraphrased but it's along the lines of "cannot restart USB auto-detection. please make sure the usb port is dry or undamaged." followed by the usb disconnecting itself, restarting auto-detection and pausing the music I'm listening to, which is the biggest annoyance of the whole saga.

I've even had this message pop up when connecting my charger, however this has only happened once.

is there anything I can do? I've literally only had this phone for around 4 months and it's given me more issues than iOS ever did.

EDIT - I attached a notification I get if usb auto-detection doesn't restart itself
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190802-001026_1564701050761.png
Views:	3
Size:	480.4 KB
ID:	324078  
slfrflxns is offline  
Sponsored Links
Advertisement
 
Old 08-01-2019, 04:58 PM   #4
Moderator, Editor, Articles Team
 
Deejay100six's Avatar
 
Join Date: Nov 2007
Location: Doncaster, Great Britain
Posts: 11,810
OS: Windows 7 Professional SP1

My System


Hi, and welcome to TSF.

I merged your threads, please do not create multiple threads about the same issue.

Tech Support Forum Rules & Conduct.
__________________
Regards, Dave.


Submit New Articles Here

Help us to help you by posting your System Specs
Deejay100six is offline  
Old 08-02-2019, 01:06 AM   #5
Moderator TSF
Hardware Team Moderator
 
Stancestans's Avatar
 
Join Date: Apr 2009
Posts: 5,151
OS: Windows 10



Quote:
Originally Posted by slfrflxns View Post
is there anything I can do? I've literally only had this phone for around 4 months
Turn it in for service/repair/replacement since it's still under warranty. That looks like a hardware defect.
Stancestans is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 03:49 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts