Go Back   Tech Support Forum > Smart Devices > Android OS

User Tag List

Samsung Galaxy S5: Proximity sensor still active AFTER ENDING A CALL

This is a discussion on Samsung Galaxy S5: Proximity sensor still active AFTER ENDING A CALL within the Android OS forums, part of the Tech Support Forum category. I have used google to search for this answer for 3 months now. This problem keeps occurring and I have


Closed Thread
 
Thread Tools Search this Thread
Old 01-27-2016, 10:26 AM   #1
Registered Member
 
Join Date: Feb 2009
Location: Albuquerque, NM
Posts: 89
OS: Windows 10


EEK!

I have used google to search for this answer for 3 months now. This problem keeps occurring and I have not found anyone else who has encountered this issue.

I have tried the answers found for fixing the issue with the proximity sensor not working correctly during a call, but it did not fix what I originally started with.

So the issue:

I will receive a call on my phone. EVERYTHING WORKS FINE. I end the call. But the proximity sensor is still active. What I mean by active is if I put my finger towards the proximity sensor the screen will turn off. Remember this is AFTER I have already ended the call and closed the app. The proximity sensor is still active.

So every time something gets close to the proximity sensor it shuts off my screen. Even as my finger pulls the ring to unlock the phone it thinks I am putting my ear onto the device and shuts the screen off.

Now by doing this the phone locks itself again. So it gets stuck in a seemingly endless cycle of unlocking and locking the phone. Annoying as **** but I found a small work around through my frustration that works like a charm to temporarily fix this problem. Which is to initiate a call through the phone's app and immediately HANG UP. It fixes it 100%. So my suspicions are pointing at the phone's installed phone calling app having a small code error, or even possibly a memory leak.

I have tried to "update" the phone's calling app.... problem is I can't find it on google play... I can't delete the app to force a re-installation. I have endlessly searched in google play store to find the correct app but NO DICE.

So I am left wondering how I am going to solve this problem. Especially considering it seems to be a COMPLETELY ISOLATED CASE.

Any help would be greatly appreciated.
The_Con-Sept is offline  
Sponsored Links
Advertisement
 
Old 01-27-2016, 11:05 AM   #2
Microsoft-Team Manager
Hardware - Team Manager
 
joeten's Avatar
 
Join Date: Dec 2008
Location: Glasgow Scotland
Posts: 68,182
OS: win 10 Home



Hi, have you tried the suggestions here https://www.reddit.com/r/galaxys4/co...taying_off_or/ please read carefully and pay note to the the info from the poster about not being a developer.

Also see this thread it may provide the name of the software involved [Q] Proximity sensor on all the time | Samsung Galaxy S 5
__________________






Eliminate all other factors, and the one which remains must be the truth.
joeten is offline  
Old 01-27-2016, 02:49 PM   #3
Registered Member
 
Join Date: Feb 2009
Location: Albuquerque, NM
Posts: 89
OS: Windows 10


Neither of those worked. I have cleaned my sensor but once again it is not the issue.

I know for a fact it is the phone app that comes per installed. It only happens when I get an incoming call. So again it has to be something with the phone app itself. And there isn't any way to reinstall the app. All I can do is force stop it. But it doesn't fix the problem. It still happens.
The_Con-Sept is offline  
Sponsored Links
Advertisement
 
Old 01-28-2016, 03:11 PM   #4
Microsoft-Team Manager
Hardware - Team Manager
 
joeten's Avatar
 
Join Date: Dec 2008
Location: Glasgow Scotland
Posts: 68,182
OS: win 10 Home



Factory restore may be the best option.
__________________






Eliminate all other factors, and the one which remains must be the truth.
joeten is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 02:35 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts