Go Back   Tech Support Forum > Smart Devices > Android OS

User Tag List

Google Play Services Using More Than 20% Of Battery

This is a discussion on Google Play Services Using More Than 20% Of Battery within the Android OS forums, part of the Tech Support Forum category. Suddenly Google Play Services has started using more than 20% of battery resources. I have tried turning off ALL notifications


Closed Thread
 
Thread Tools Search this Thread
Old 05-03-2019, 02:08 AM   #1
Registered Member
 
geishaslave's Avatar
 
Join Date: Feb 2008
Location: California
Posts: 56
OS: Microsoft Windows 10 Pro 64Bit



Suddenly Google Play Services has started using more than 20% of battery resources.

I have tried turning off ALL notifications in the GPS app, disabling location, installed the latest Beta of GPS. Then I backed up and reset the phone to factory state. Within 24 hours the battery usage went back to over 20%.

Essential PH-1
Android 9 P
geishaslave is offline  
Sponsored Links
Advertisement
 
Old 05-08-2019, 12:00 AM   #2
Registered Member
 
geishaslave's Avatar
 
Join Date: Feb 2008
Location: California
Posts: 56
OS: Microsoft Windows 10 Pro 64Bit



RESOLVED

The Essential PH-1 May 2019 update for Android 9 Pie fixed it (and the issue with shutdown where the phone buzzes for a bit then restarts).
geishaslave is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
I just got my first Windows 10!
Finally upgraded my own laptop that almost made it to 10 years with Windows 7 installed to a brand new Windows 10 All in one Desktop PC. WOW! It's so vast and exciting to see many features. I want to get TOP notch security and programs but at the same time keeping it simple and not install...
wii_zil Windows 10 Support 64 07-31-2017 08:21 PM
Hard drive usage at %100 - Looking for ideas
Hey guys! Please don't bash me for posting this (as I can see others have posted about it also). I just want to make sure I can get as many ideas as possible, before I do a clean install/new hdd. _______ I am helping a family friend fix their desktop. It is only about 3 years old and has a...
Labarr15 Windows 10 Support 9 01-12-2017 05:48 PM
Internet works for a few seconds on startup and then goes off
Ok so I'm not really a computer guy so you're gonna need to walk me through this pretty detailed please. So I have a windows 7 PC that has worked fine for the last year now. However recently something happened. When I turn my computer on and go straight to internet i have about 3 mins of internet...
DidYouSeeUs Windows 7 , Windows Vista Support 13 08-28-2013 03:17 AM
~*~Mixed Bag of Problems~*~
Hi, everyone! I have had a lot of problems with my computer lately and I'm hoping someone would be able to help me out. The most pressing issue right now is that my e-mail is sending out Spam links when I'm not even on my computer. The first time it happened, I changed my password, but tonight the...
TabbyCat725 Virus/Trojan/Spyware Help 156 07-09-2012 07:50 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 05:00 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts