Go Back   Tech Support Forum > Microsoft Support > BSOD, App Crashes And Hangs

User Tag List

[SOLVED] BSOD hal.dll and ntoskrnl.exe (0x124)

This is a discussion on [SOLVED] BSOD hal.dll and ntoskrnl.exe (0x124) within the BSOD, App Crashes And Hangs forums, part of the Tech Support Forum category. Hi, Recently I have been getting frequent BSODs, my computer is so unstable i am afraid to do anything that


Closed Thread
 
Thread Tools Search this Thread
Old 05-01-2014, 11:06 PM   #1
Registered Member
 
Join Date: May 2014
Posts: 11
OS: Windows 7



Hi,

Recently I have been getting frequent BSODs, my computer is so unstable i am afraid to do anything that might jeopardize my work.

If you want to see my mindump you can find it here:
  1. https://1drv.ms/1mk3MCd
  2. https://1drv.ms/1mjoi1F

OS - Windows 7
System Type - x64
What was original installed OS on system? Windows 7 (custom built)
Is the OS an OEM version (came pre-installed on system) or full retail version (YOU purchased it from retailer)? full retail
Age of system (hardware) 4 years
Age of OS installation - have you re-installed the OS? 6 months
CPU - Amd Phenom II 965 x 4
Video Card - Amd Radeon HD 7800
MotherBoard - Asus M4A87TD EVO
Power Supply - brand & wattage - Corsair 750W

NB:
perfmon /report pulls the window up and suddenly is not responding.
Attached Files
File Type: rar Windows7_Vista_jcgriff2.rar (1.86 MB, 119 views)
nicotugz is offline  
Sponsored Links
Advertisement
 
Old 05-02-2014, 12:33 AM   #2
Registered Member
 
Join Date: May 2014
Posts: 11
OS: Windows 7



... Fixed use this attachment it has the report inside of it.
Attached Files
File Type: rar Windows7_Vista_jcgriff2.rar (2.05 MB, 804 views)
nicotugz is offline  
Old 05-02-2014, 12:36 AM   #3
TSF Team, Emeritus
 
Patrick's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2012
Location: Ring 0
Posts: 4,349
OS: W8.1 x64



Hi,

All of the attached DMP files are of the WHEA_UNCORRECTABLE_ERROR (124) bug check.

A fatal hardware error has occurred. This fatal error displays data from the Windows Hardware Error Architecture (WHEA).

If we run an !errrec on the 2nd parameter of the bugcheck (address of the WER structure) we get the following:

Code:
===============================================================================
Section 2     : x86/x64 MCA
-------------------------------------------------------------------------------
Descriptor    @ fffffa8005c59138
Section       @ fffffa8005c592c0
Offset        : 664
Length        : 264
Flags         : 0x00000000
Severity      : Fatal

Error         : DCACHEL1_DRD_ERR (Proc 0 Bank 0)
  Status      : 0xb611a0008b000135
  Address     : 0x00000001627cdc00
  Misc.       : 0x0000000000000000
DCACHEL1_DRD_ERR implies an L1 Cache Data Read error, specifically on Processor #0 (primary CPU core), and Cache Bank 0.

There is only so much you can do with a bugcheck like this until it comes down to a faulty processor that will need to be replaced. Start from 1 and work downward:

1. Ensure your temperatures are within standard and nothing's overheating. You can use a program such as Speccy if you'd like to monitor temps - Speccy - System Information - Free Download

2. Clear your CMOS (or load optimized BIOS defaults) to ensure there's no improper BIOS setting - How To Clear CMOS (Reset BIOS)

3. Ensure your BIOS is up to date.

4. The only software conflict that can usually cause *124 bugchecks are OS to BIOS utilities from manufacturer's like Asus' AI Suite. If you have something like this software-wise, remove it ASAP.

5. If all of the above fail, the only left to do is replace your processor as it is faulty.

Regards,

Patrick
Patrick is offline  
Sponsored Links
Advertisement
 
Old 05-02-2014, 12:47 AM   #4
Registered Member
 
Join Date: May 2014
Posts: 11
OS: Windows 7



Hi Patrick,

Thanks for your response, i used Speccy and SpeedFan Temps are normal ~ 40s CPU/GPU
~30s Mobo/HDD.

My BIOS is updated the only thing i think is enabled is their Express Gate: What is asus express gate?

I'll try to clear my CMOS and see how it goes.
nicotugz is offline  
Old 05-02-2014, 01:33 AM   #5
Registered Member
 
Join Date: May 2014
Posts: 11
OS: Windows 7



reset CMOS now i have to watch and see what happens.

The only problem i'm seeing as well is that my internet say no internet access when there actually is and either i wait for a good while or i try and troubleshoot the problem after 2 mins. Tried Disable then re-enable still says no internet access until i wait a while then troubleshoot.

One thing i noted while i was in the BIOS is that my CPU temp is actually 60C, a lot hotter than i what the software says, maybe the fans aren't being controlled. When i felt the top of the case (closest open point to the CPU) i could feel the heat (While in the BIOS Setup). When the OS ran i felt it again and it was a lot cooler.
nicotugz is offline  
Old 05-02-2014, 01:44 PM   #6
TSF Team, Emeritus
 
Patrick's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2012
Location: Ring 0
Posts: 4,349
OS: W8.1 x64



Sometimes the BIOS despite being what it is may not always be accurate. Go ahead and uninstall/disable Express Gate.

Regarding the internet problem, possibly unrelated and may be fixed with an uninstall/reinstall of the latest network drivers via the manufacturers website.

Regards,

Patrick
Patrick is offline  
Old 05-02-2014, 06:47 PM   #7
Registered Member
 
Join Date: May 2014
Posts: 11
OS: Windows 7



Hi Patrick,

I have disabled the Express Gate i havn't had a chance to use the computer like i normally do due to work but since its the weekend i can see if i get any BSODs.

The network/driver issues is really mind boggling, it keeps on failing to connect to the internet after many minutes.
I uninstalled / re-sintalled and updated the drivers again and it's the same issue. I used the old drivers that came with the motherboard CD same issue.
nicotugz is offline  
Old 05-02-2014, 07:03 PM   #8
TSF Team, Emeritus
 
Patrick's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2012
Location: Ring 0
Posts: 4,349
OS: W8.1 x64



In any case, keep me updated on the BSOD issue.

Regards,

Patrick
Patrick is offline  
Old 05-03-2014, 03:15 PM   #9
Registered Member
 
Join Date: May 2014
Posts: 11
OS: Windows 7



My latest BSOD happened today, just couple mins ago.

DRIVER_IRQL_NOT_LESS_OR_EQUAL that error happened and it was caused by: NETIO.SYS

Different Error: 0xd1

Here is the dump so you can check out: https://1drv.ms/1mpxuBy
nicotugz is offline  
Old 05-03-2014, 06:08 PM   #10
TSF Team, Emeritus
 
Patrick's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2012
Location: Ring 0
Posts: 4,349
OS: W8.1 x64



DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)

This indicates that a kernel-mode driver attempted to access pageable memory at a process IRQL that was too high.

A driver tried to access an address that is pageable (or that is completely invalid) while the IRQL was too high. This bug check is usually caused by drivers that have used improper addresses.

It's faulting NETIO.sys, therefore something 3rd-party is causing NETBIOS conflicts.

-------------------

1. AODDriver2.sys is listed and loaded in your modules list which is AMD Overdrive; also in EasyTune6 for Gigabyte motherboard. Known BSOD issues in Win7 & 8.

Please uninstall either software ASAP! If you cannot find either software to uninstall, or it's not installed, please navigate to the following filepath:

C:\Program Files\ATI Technologies\ATI.ACE\Fuel\amd64\AODDriver2.sys

and rename AODDriver2.sys to AODDriver.2old

and then Restart.

2. I still see various Asus drivers loaded... AsIO.sys (PC Probe), ASACPI.sys (ATK Utility), etc. Please uninstall all Asus software.

3. Uninstall SpeedFan ASAP.

4. Uninstall PowerISO ASAP.

Regards,

Patrick
Patrick is offline  
Old 05-03-2014, 06:29 PM   #11
Registered Member
 
Join Date: May 2014
Posts: 11
OS: Windows 7



Hi Patrick,

I updated my AMD GPU drivers to the latest version, and i uninstalled SpeedFan, powerISO and Asus Cool & Quiet. I don't know where to go to uninstall the others you did/did not highlight:
PC Probe
ATK Utility

They are not under Program & Features uninstaller nor are they inside Program Files / Asus /

Additionally this is what has been happening to me: imgur: the simple image sharer

Computer is probably on for max 15 - 20 mins until the above photo happens
nicotugz is offline  
Old 05-03-2014, 09:06 PM   #12
TSF Team, Emeritus
 
Patrick's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2012
Location: Ring 0
Posts: 4,349
OS: W8.1 x64



Try checking with Revo - Download Revo Uninstaller Freeware - Free and Full Download - Uninstall software, remove programs, solve uninstall problems

Regards,

Patrick
Patrick is offline  
Old 05-03-2014, 09:42 PM   #13
Registered Member
 
Join Date: May 2014
Posts: 11
OS: Windows 7



Hi Patrick,

I checked with the link you supplied, it doesn't list ASuS / Austek anywhere. I did however locate where the ASUS files where (Other HDD) since i load windows on my SSD (which has been updated).

One thing i noted was that my CPU is > 70% usage sometimes stays at 100%. Which may cause my net to be dropping and PC freeze / display tear.

I checked with Event viewer, see the attached file.
Attached Files
File Type: txt error_from_event_viewer.txt (9.0 KB, 124 views)
nicotugz is offline  
Old 05-03-2014, 11:25 PM   #14
TSF Team, Emeritus
 
Patrick's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2012
Location: Ring 0
Posts: 4,349
OS: W8.1 x64



Do you have the HOSTS Anti-PUP software installed? If so, uninstall it for troubleshooting purposes. Regarding Asus, let's just leave it now until it becomes an apparent problem.

Regards,

Patrick
Patrick is offline  
Old 05-03-2014, 11:41 PM   #15
Registered Member
 
Join Date: May 2014
Posts: 11
OS: Windows 7



Uninstalled. Restarted,

Errors:
Level Date and Time Source Event ID Task Category
Error 5/4/2014 12:42:55 AM Service Control Manager 7026 None "The following boot-start or system-start driver(s) failed to load:
RzFilter"
Error 5/4/2014 12:42:54 AM Report Server Windows Service (MSSQLSERVER) 107 Management Report Server Windows Service (MSSQLSERVER) cannot connect to the report server database.
Error 5/4/2014 12:42:38 AM Service Control Manager 7000 None "The S service failed to start due to the following error:
The system cannot find the file specified."
Error 5/4/2014 12:42:35 AM Service Control Manager 7000 None "The AODDriver4.3 service failed to start due to the following error:
The system cannot find the file specified."
Error 5/4/2014 12:42:27 AM Microsoft-Windows-Kernel-EventTracing 3 Session "Session ""Microsoft Security Client OOBE"" stopped due to the following error: 0xC000000D"
nicotugz is offline  
Old 05-04-2014, 01:17 AM   #16
TSF Team, Emeritus
 
Patrick's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2012
Location: Ring 0
Posts: 4,349
OS: W8.1 x64



RzFilter is a Razer driver, did you uninstall your Razer software/drivers recently? If not, update your Razer drivers.

AODD is normal considering we've renamed it and broke it from loading. The others, not so sure. If they become an apparent problem, we'll deal with them accordingly.

Regards,

Patrick
Patrick is offline  
Old 05-04-2014, 07:58 AM   #17
Registered Member
 
Join Date: May 2014
Posts: 11
OS: Windows 7



I uninstalled Razr Comms which had that driver so that error is gone now.
I fell asleep after

woke up to these:

Level Date and Time Source Event ID Task Category

Error 5/4/2014 8:50:22 AM Microsoft-Windows-Dhcp-Client 1001 Address Configuration State Event Your computer was not assigned an address from the network (by the DHCP Server) for the Network Card with network address 0x00FFC1541882. The following error occurred: 0x79. Your computer will continue to try and obtain an address on its own from the network address (DHCP) server.
Error 5/4/2014 8:50:21 AM Service Control Manager 7011 None A timeout (30000 milliseconds) was reached while waiting for a transaction response from the LanmanWorkstation service.
Error 5/4/2014 8:49:51 AM Service Control Manager 7011 None A timeout (30000 milliseconds) was reached while waiting for a transaction response from the CryptSvc service.
Error 5/4/2014 8:49:21 AM Service Control Manager 7011 None A timeout (30000 milliseconds) was reached while waiting for a transaction response from the Dnscache service.
Error 5/4/2014 8:48:51 AM Service Control Manager 7011 None A timeout (30000 milliseconds) was reached while waiting for a transaction response from the Dnscache service.
Error 5/4/2014 8:33:22 AM Service Control Manager 7011 None A timeout (30000 milliseconds) was reached while waiting for a transaction response from the Dnscache service.
nicotugz is offline  
Old 05-04-2014, 03:44 PM   #18
TSF Team, Emeritus
 
Patrick's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2012
Location: Ring 0
Posts: 4,349
OS: W8.1 x64



Try uninstalling and reinstalling your network drivers.

Regards,

Patrick
Patrick is offline  
Old 05-04-2014, 06:11 PM   #19
Registered Member
 
Join Date: May 2014
Posts: 11
OS: Windows 7



Tried that already, still got problems.
Amongst other things i tried contacted ISP did all sorts of troubleshooting with them to no avail. Got tired of it not working and I needed my computer before Monday.

So I did a clean install of windows everything is working back fine backed up files that i need. No more errors / slow browsing didn't install any ASUS Utilities.
nicotugz is offline  
Old 05-04-2014, 08:48 PM   #20
TSF Team, Emeritus
 
Patrick's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2012
Location: Ring 0
Posts: 4,349
OS: W8.1 x64



That's definitely one way to do it! Good to hear things are okay. What I imagine happened was OS corruption over time from crapware/bloatware tools such as Asus, etc.

I've marked as solved, but don't hesitate to come back if any issues pop up!

Regards,

Patrick
Patrick is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Persistant BSOD ntoskrnl.exe +MSKSSRV.sys + hal.dll
I have been having persistant BSODs with my computer, 15 to be exact, Of the 15, 13 have been ntoskrnl.exe as the main cause while 1 MSKSSRV.sys and 1 hall.dll Required Checklist OS: Windows 7(pirated version) x64 Pre-installed OS:computer has always been windows 7 Hardware age: i built the...
GWAlistair BSOD, App Crashes And Hangs 4 01-25-2014 05:48 PM
BSOD ntoskrnl.exe
BSOD ntoskrnl.exe Hi all, I have been getting BSOD every once in a while and after starting laptop. HP pavilion dv6 Notebook pc Home premium Windows 7 amd phenom(tm) II p960 quad -core processor 1.80 ghz 6.00 gb (5.74 gb usable) 64 bit.
immigranta BSOD, App Crashes And Hangs 8 12-14-2012 09:42 AM
BSOD hal.dll / ntoskrnl.exe
Hi, I have recently been getting a huge load of BSODs off my recently bought laptop (around 4-5 months ago) which is an ASUS G53Sw 3D. I can only understand that the causes are hal.dll and something else that i'm not quite sure of. Regardless, I have no idea how to fix this. Please do help. Below...
Duffed BSOD, App Crashes And Hangs 1 11-14-2011 06:47 AM
[SOLVED] BSOD problems.
Vista x64 What was original installed OS on system? None. Custom built. OEM: Full Retail Version Age of system (hardware): 3 years Age of OS installation - have you re-installed the OS? 3 years. Yes. CPU: Intel Core 2 Duo E8400 Wolfdale Video Card: EVGA GEforce 8800 GT...
ajcc323 BSOD, App Crashes And Hangs 25 02-24-2011 05:31 AM
BSOD ntoskrnl.exe [moved from Vista/ Windows 7]
================================================== Dump File : 021011-40092-01.dmp Crash Time : 10-2-2011 18:50:11 Bug Check String : SYSTEM_SERVICE_EXCEPTION Bug Check Code : 0x0000003b Parameter 1 : 00000000`c0000005 Parameter 2 : 00000000`fffff880 Parameter...
mmmcool BSOD, App Crashes And Hangs 31 02-12-2011 09:45 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 07:31 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts