Go Back   Tech Support Forum > Hardware Support > Sound Cards

User Tag List

Weird audio Glitch

This is a discussion on Weird audio Glitch within the Sound Cards forums, part of the Tech Support Forum category. Hi, sorry if this is the wrong thread, I'm not sure if it is. Basically, my problem is that audio


Closed Thread
 
Thread Tools Search this Thread
Old 09-04-2015, 07:44 PM   #1
Registered Member
 
Join Date: Sep 2015
Posts: 1
OS: Windows 8.1



Hi, sorry if this is the wrong thread, I'm not sure if it is. Basically, my problem is that audio devices break after being plugged into my computers. I've had two computers, both gaming laptops. One was an Asus and the other was a Lenovo. When I plug in my Turtle Beach PX22s into my computer and talk into them, there is a weird crackling noise that disrupts my talking. I tried them on my mom's desktop and they worked fine. Also, my brother has a webcam that he uses on his desktop that has a microphone. When i used it on my laptop, it worked fine for a bit, then started sounding extremely robot-ish. This happened on both laptops. Thanks for your help
FireMonkeyGamin is offline  
Sponsored Links
Advertisement
 
Old 09-07-2015, 02:39 PM   #2
Team Manager - Networking
Moderator - Hardware
 
JimE's Avatar
 
Join Date: Apr 2009
Location: St Louis, MO
Posts: 19,813
OS: Win 7 SP1

My System


I'm assuming these are both 3.5mm analog jack type devices? Most common cause of this type of distortion are the audio drivers.
__________________
Jim

JimE is offline  
Old 09-08-2015, 10:12 AM   #3
TSF Team, Emeritus
 
WereBo's Avatar
 
Join Date: Apr 2008
Location: SE London, UK
Posts: 57,109
OS: Win-10 Home-Premium (64bit)

My System


Hi FireMonkeyGamin and welcome to TSF

Check that none of the volume-sliders are more than 75%-80% of full volume, that's usually the worst source of distortion on PCs.

Also, check the audio-enhancements aren't set to various 'room/theatre/auditorium' settings, they can add the robotic effects.
__________________






Live, Laugh, Hope - If that don't work Load, Aim and Fire....
WereBo is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound Help Please!
Ok, so I play World of Warcraft. I want to hear gamesound from my speakers, but I want to also have my headset on; and hear youtube videos, skype ect from my headset. For some reason when I try and do this and I plug both of them in to my PC, neither of them work. Yet, alone they both work...
Greenybwa Windows 7 , Windows Vista Support 2 06-23-2013 02:32 AM
[SOLVED] Windows XP BSOD Possibly ATI X1900 related
I found the thread BSOD posting for Windows 7 and Vista, but I'm running XP. As soon as someone points me to the proper place, I'll go through those motions. Please forgive any breech of protocol. Kind of flying blind here, so I beg your patience. First system info: ------------------ System...
DrZin Windows XP Support 11 06-03-2011 11:49 AM
Startup time from 75 seconds to 165 seconds. What is wrong?
Hello forum. I have a month-old Dell Inspiron N7010 Core i5 460M with 6 gigs of ram running on Windows 7. Until recently, it has been starting up in about 75 seconds. However, out of nowhere, it suddenly began starting up in between 2 and a half minutes to 3 minutes. I am completely baffled,...
SimTmiCro Windows 7 , Windows Vista Support 6 05-10-2011 09:01 AM
Roller coaster Tycoon 3 Platinum - No ingame sound/music
hay everyone, lately about every second game I buy has no ingame sound... i dont kno if im just having bad luck but it would mean so much if someone could help me out.. the games i struggle to get ingame sound + music are *star wars unleashed 2 *Bully and now rollercoaster tycoon 3 id like...
Rodrigo.Carter PC Gaming Support 4 04-22-2011 12:06 AM
Slow/Not responsive
My pc has lately as expected gone very slow and not as responsive. At the start-up especially. I have to wait a good 2mins before touching anything or things start to 'Not respond' and such. I was wondering if you guys could recommend me ANYTHING that I could do to speed up my pc significantly....
bhstr99 Windows 7 , Windows Vista Support 18 03-26-2011 03:38 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 03:20 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts