Go Back   Tech Support Forum > Hardware Support > Sound Cards

User Tag List

Turtle Beach Headset Issue

This is a discussion on Turtle Beach Headset Issue within the Sound Cards forums, part of the Tech Support Forum category. Hi, I'm new here, so I apologize if this is not be the appropriate section. And I'm not the most


Closed Thread
 
Thread Tools Search this Thread
Old 12-11-2014, 09:35 AM   #1
Registered Member
 
Join Date: Dec 2014
Posts: 2
OS: Win7



Hi, I'm new here, so I apologize if this is not be the appropriate section. And I'm not the most experienced person when it comes to hardware/software.

I just recently got a turtle beach Ear force kilo black ops 2 special edition headset, and at first it was working fine on my Windows 7 computer.

But today i unplugged it from my PC to use it on my PS3, and it worked fine, but when i plugged it back into the computer, windows did not recognize it.
It gave me the error message of This USB device could not be recognised and error on installation, but the sound of the headset works fine, but the mic doesn't.
I thought it would be a driver problem, since i had that issue with a past headset, so I unnistaled the drivers and let windows install them again, but it just does not recognize my headset anymore.
Emidan is offline  
Sponsored Links
Advertisement
 
Old 12-13-2014, 07:34 AM   #2
Team Manager - Networking
Moderator - Hardware
 
JimE's Avatar
 
Join Date: Apr 2009
Location: St Louis, MO
Posts: 19,813
OS: Win 7 SP1

My System


Try a different USB port. Test on a different computer.

Does it still work on the PS3?
__________________
Jim

JimE is offline  
Old 12-13-2014, 08:14 AM   #3
Registered Member
 
Join Date: Dec 2014
Posts: 2
OS: Win7



It works on my mac, works on PS3 and does not work on any USB port on my PC, the headset/sound part works, but mic does not. Windows says the USB device could not be recognized.
Emidan is offline  
Sponsored Links
Advertisement
 
Old 12-13-2014, 02:15 PM   #4
Team Manager - Networking
Moderator - Hardware
 
JimE's Avatar
 
Join Date: Apr 2009
Location: St Louis, MO
Posts: 19,813
OS: Win 7 SP1

My System


Is it listed in Device Manager? If so, remove from Device Manager, then reboot.
__________________
Jim

JimE is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turtle Beach PX5 headset pc help
After reading up on the required components needed to successfully install my px5 headsets to my pc I came to some unknown variables. Firstly my pc does not have an optical digital audio output or bluetooth features, does the Earforce DSS unit that comes with the px5 headset provide the optical...
socalfusions PC Gaming Support 13 08-14-2012 04:19 PM
PS3 Wireless headset issue
i am having trouble with my "official" PS3 bluetooth headset. my mic is on and is connected to the ps3 and everything but i can not talk to other people with it or hear other players through it. for example the other day my friend and i were playing some red dead and wwe were in a posse i...
Breaking_grace Console Gaming Support 1 01-27-2011 11:22 PM
[SOLVED] HEADSET ISSUE: I hear my voice in my headphones.
I have XP 32-bit. The headset i am having problems with is called the Razer Carcharias. (yes, i have installed the appropriate drivers, please dont go there, i know you mean well but trust me.) HERES MY PROBLEM: Somehow, the sound going into my mic is being transmitted through my headset. As a...
Pez Dex Other Hardware Support 9 01-26-2011 02:28 PM
[SOLVED] Headset issue
Alright so I re-formatted my PC today, and when it's back up and running the headset I have plugged into the back panel (3.5 mm jack) doesn't work. He sound or mic. It doesn't work because the computer isn't even recognizing it as a device. When I go to sound in control panel no devices show...
AmIEfficient Other Hardware Support 12 01-03-2011 02:28 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 05:38 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts