Go Back   Tech Support Forum > Hardware Support > Sound Cards

User Tag List

Steelseries Siberia 200 Mic Problem

This is a discussion on Steelseries Siberia 200 Mic Problem within the Sound Cards forums, part of the Tech Support Forum category. I have a problem with my Steelseries Siberia 200 Microphone. Headset works perfectly but I just can't use my mic.


Closed Thread
 
Thread Tools Search this Thread
Old 12-17-2015, 04:21 AM   #1
Registered Member
 
Join Date: Dec 2015
Posts: 1
OS: Windows 7 Ultimate


Question

I have a problem with my Steelseries Siberia 200 Microphone. Headset works perfectly but I just can't use my mic. I have Windows 7 with Realtek HD Audio Manager. I've tried every setting in Windows Recording Devices and Realtek HD Audio Manager, I've tried both front and rear inputs and every volume setting in mic is maxed out. I can hear voice if I put mic in my mouth and scream, so it does recognize something. If you've had this same problem, please tell me how you fixed it

PS. I've tried it with Open Broadcaster Software and yes, there too I have tried every setting.
iamsaressi is offline  
Sponsored Links
Advertisement
 
Old 12-17-2015, 04:56 AM   #2
Team Manager - Networking
Moderator - Hardware
 
JimE's Avatar
 
Join Date: Apr 2009
Location: St Louis, MO
Posts: 19,813
OS: Win 7 SP1

My System


I would first test the headset/mic on another computer. That will confirm if you have a mic or PC issue.
__________________
Jim

JimE is offline  
Old 01-02-2016, 01:39 PM   #3
Registered Member
 
Join Date: Jan 2016
Posts: 1
OS: Windows 8.1



I have the same headsets and had the same problem as you. The only solution I found was to uninstall the realtek hd audio manager drivers from my pc and use the default drivers from Microsoft which installed automaticaly. Now my mic works fine.
Hope it works for you too :)
Frias is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
...exe has encountered a problem and needs to close
Yes, I know, I should just probably just give up on this old XP computer. But for several reasons (listed in post scriptbelow*) I need to run XP Pro SP3. Despite working on this problem for a week (including google searches and a complete rebuild of the system) I still receive "....exe has...
DellAnderson Windows XP Support 12 02-27-2015 12:43 PM
[SOLVED] Realtek weird mic problem!
Hey , For some unknown reason realtek drivers can't detect my mic and thinks that I am using speakers (I'm using headset) no idea how to fixed this , google whole day couldn't find anything , tried uninstalling , installing new drivers , tried windows drivers no luck, here's a screenshot maybe...
Farkeman Driver Support 2 06-07-2011 11:38 PM
warning of impending hd failure. SMART scan.
Hi yesterday I got this win 7 warning that I've never seen before, warning me of impending harddisk failure, urging me to make a backup asap. I then backed up the important stuff to my other harddisk (on same laptop), and went browsing the problem on the net. I found others had the same...
sen123 Hard Drive Support 6 03-06-2011 10:00 AM
fraps /w mic problem
I'm guessing its the right section, anyway... I've been wanting to do some playthroughs/Let's Plays for a while now, and finally I got around to doing one, now after finishing it, and looking back through it, I realized that the my voice was not in sync with the visuals. The in-game audio was...
Xaniith PC Gaming Support 4 02-16-2011 08:23 PM
ARENA Surround mic problem pls help
Hi,Im new to the forums and I have a problem...I bought headphones-ARENA Surround... and since my cd rom isent working ( isent reading any of the cd-s) I installed the drivers for the headphones from a usb,I think I only instaled 3 out of 6 apps that are in there... anyway to the problem,I enter...
Xtali Sound Cards 1 01-06-2011 02:55 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 03:12 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts