Go Back   Tech Support Forum > Hardware Support > Sound Cards

User Tag List

Need help with Creative SB0670

This is a discussion on Need help with Creative SB0670 within the Sound Cards forums, part of the Tech Support Forum category. Hi, I am having trouble setting up my soundcard to play sound. My pc says that there is sound however


Closed Thread
 
Thread Tools Search this Thread
Old 03-09-2016, 05:36 PM   #1
Registered Member
 
Join Date: Mar 2016
Posts: 3
OS: win 7 sp 1



Hi,

I am having trouble setting up my soundcard to play sound. My pc says that there is sound however there is non being outputted through any of the ports.

I have downloaded all the drivers from creative and disabled the intergrated soundchip on my motherboard (which doesnt really have one anyways, it only outputs in SPDIF).

One thing I have noticed:
I have two audio outputs in the audio output settings. SPDIF OUT (Creative X-Fi) and Speakers (Creative X-Fi). I can select the SPDIF to be the default and I can play mp3 files with sound detected in the volume settings, however no sound is actually outputted. If I try changing the default to Speakers it says that an application is already using this and it cannot be set as the default, I cant do a sound test on it either. If I try playing an mp3 now i receive an error message.

Any help is well appreciated, thanks!
oh_paddy is offline  
Sponsored Links
Advertisement
 
Old 03-11-2016, 06:30 AM   #2
Registered Member
 
Join Date: Feb 2016
Posts: 417
OS: XP, 7pro, 10

My System


Hi,

Do you have any audio applications (for example iTunes) running in the background? If so, try disabling it.

Also turn "exclusive control for applications" off in Control Panel - how to:
Go to Control Panel > Sound. Highlight Speakers, then click Properties.
Click image for larger version

Name:	s1.jpg
Views:	100
Size:	73.9 KB
ID:	274482

Another window opens. Click the Advanced tab, then untick "Allow applications to take exclusive control...". Click Apply, then OK.
Click image for larger version

Name:	s2.jpg
Views:	104
Size:	74.7 KB
ID:	274490

Restart the PC if your sound doesn't start working.
prodigal74 is offline  
Old 04-13-2016, 12:59 PM   #3
Registered Member
 
Join Date: Mar 2016
Posts: 3
OS: win 7 sp 1



Quote:
Originally Posted by prodigal74 View Post
Hi,

Do you have any audio applications (for example iTunes) running in the background? If so, try disabling it.

Also turn "exclusive control for applications" off in Control Panel - how to:
Go to Control Panel > Sound. Highlight Speakers, then click Properties.
Attachment 274482

Another window opens. Click the Advanced tab, then untick "Allow applications to take exclusive control...". Click Apply, then OK.
Attachment 274490

Restart the PC if your sound doesn't start working.
I have no idea why it's not working at this point. I reinstalled windows 7 ultimate from scratch on the hard drive and downloaded chrome and the drivers, without applying any updates and nothing. I applied the updates and still nothing.
I got the drivers from their official support site.

The build is pretty aged but from what I remember the card used to work perfectly before. I dont have the original driver disc since once again the build is pretty old and i dont really have any of the original packaging and driver discs for any of the components.

I tried disabling the onboard sound (HDMI audio in the bios even though there is no integrated sound on the mobo). The motherboard used to come with its own soundcard but I have no idea where that one is.
I disabled the option that allows the soundcard to be used exclusively by some programs but that didn't help either.

The soundcard requires 2.1 PCI-e and i just checked my motherboard and it says it supports PCI 2.0. Could this be the issue?



I managed to get the soundcard to work a bit in Counterstrike GO
By using Creative Alchemy ( Restores hardware accelerated audio for EAX effects and 3d audio while playing direct sound 3d games) I am getting a very bit munched sound while playing csgo.
Everything else is still the same and not working. The sound only works in game and is VERY bit munched.
oh_paddy is offline  
Sponsored Links
Advertisement
 
Old 04-14-2016, 04:43 AM   #4
Registered Member
 
Join Date: Feb 2016
Posts: 417
OS: XP, 7pro, 10

My System


I'm pretty sure the Creative SB0670 (X-Fi XtremeMusic) is a PCI card - not PCI-E. The difference is easy to see by looking at the slot-connector, it's much wider on a PCI card.

X-Fi XtremeMusic (SB0670) card:


PCI 2.1 cards should be backwards compatible with PCI 2.0 motherboards, unless the card/driver needs a specific PCI 2.1 feature.

There seems to be a lot of problems with the older X-Fi cards on Windows 7.
I think you should uninstall the driver in Device Manager:
Open Device Manager and find your soundcard under "Sound, video and game controllers". Right-click and choose "Uninstall".

Click image for larger version

Name:	devman.jpg
Views:	92
Size:	97.6 KB
ID:	278369

When confirming the device uninstall - tick "Delete the software for this device".

Then go to Control Panel and uninstall all Creative software.

Turn the computer off (not restart). Disconnect the PC from main power, then move the soundcard to another PCI slot.

Start the computer and let Windows install a driver automatically.
When/if the sound is working you can always use a third-party mixer to optimize the sound.
prodigal74 is offline  
Old 04-14-2016, 09:14 AM   #5
Registered Member
 
Join Date: Mar 2016
Posts: 3
OS: win 7 sp 1



Quote:
Originally Posted by prodigal74 View Post
I'm pretty sure the Creative SB0670 (X-Fi XtremeMusic) is a PCI card - not PCI-E. The difference is easy to see by looking at the slot-connector, it's much wider on a PCI card.

X-Fi XtremeMusic (SB0670) card:


PCI 2.1 cards should be backwards compatible with PCI 2.0 motherboards, unless the card/driver needs a specific PCI 2.1 feature.

There seems to be a lot of problems with the older X-Fi cards on Windows 7.
I think you should uninstall the driver in Device Manager:
Open Device Manager and find your soundcard under "Sound, video and game controllers". Right-click and choose "Uninstall".

Attachment 278369

When confirming the device uninstall - tick "Delete the software for this device".

Then go to Control Panel and uninstall all Creative software.

Turn the computer off (not restart). Disconnect the PC from main power, then move the soundcard to another PCI slot.

Start the computer and let Windows install a driver automatically.
When/if the sound is working you can always use a third-party mixer to optimize the sound.
I managed to make it work using daniel_k's SB X-Fi Series Support Pack 3.8.
I just installed it and restarted my pc and sound is working perfectly.
Thanks for the help anyways, i appreciate it. The pack should be pinned somewhere it's really useful:

daniel_k's SB X-Fi Series Support Pack 3.8 (10/22/2015)
oh_paddy is offline  
Old 04-14-2016, 01:05 PM   #6
Registered Member
 
Join Date: Feb 2016
Posts: 417
OS: XP, 7pro, 10

My System


Glad you got it working - thanks for posting the solution.
Creative's drivers for "older" soundcards on "newer" operating systems are wonky, to say the least...
Took me quite a while to make my ancient Audigy 2 Platinum play nicely with Windows 7.
prodigal74 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get rid of Backdoor.Rbot.aveq MARK II
I have a Backdoor.Rbot.aveq though sometimes it's Backdoor.Rbot.awi Vba32 keeps picking it up and deleting it, but I feel it's linked to the temp folder or something because everytime I try to install anything Vba32 tells me "C:\Users\admin\AppData\Local\Temp\CR_04BFF.tmp\setup.exe" contains...
climoo Inactive Malware Help Topics 5 04-07-2013 04:06 PM
Malware/Adware - Ads placed on web pages
Hello, I seem to have gotten some sore of computer infection. I know so by the fact that most of the web pages I go to are placed with ads inside of them that aren't actually supposed to be a part of them. Very weird. Seems to slowed down loading as well but could just be my mind playing tricks...
ca4224 Resolved HJT Threads 26 11-16-2012 05:00 AM
PC crashes; Have to manually power off
Hi, I am seeking help from you guys. I'm just about to give up and stop playing... So, whenever I play a somehow high ressource demanding game for 1-2 hours, my PC inevitably crashes. What happens is everything freezes and the sound seems to be looping (sometimes can be very loud). Then, I have...
Nyanja BSOD, App Crashes And Hangs 1 09-07-2011 07:54 AM
Browser redirect
Hi, I suspect I have a brower redirect/rootkit problem. Main symptom is occasional redirections of firefox to random sites but most commonly and incresingly to the "scour" site. I have AVG 9 installed. The attached archive contains two copies of the GMER log as I seems to have problems...
donkeyfan237 Resolved HJT Threads 12 02-21-2011 09:34 PM
Explorer.exe not fully loading + some
I have been having trouble with Explorer.exe fully loading at startup. I can get it to load eventually through cmd. Also, when I go into task manager it doesn't show what processes are my login and which are system anymore. Windows update wont load and I think I have the redirect thing too. If I...
Invertediq Resolved HJT Threads 12 01-19-2011 06:01 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 12:10 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts