Go Back   Tech Support Forum > Gaming Forum > Online/Network Gaming Support

User Tag List

Left 4 Dead is not working online

This is a discussion on Left 4 Dead is not working online within the Online/Network Gaming Support forums, part of the Tech Support Forum category. Hi! I recently installed left 4 dead.And i can use multiplayer,server browse, without using steam.But when i want to join


Closed Thread
 
Thread Tools Search this Thread
Old 03-30-2014, 07:16 AM   #1
Registered Member
 
Join Date: Mar 2014
Posts: 4
OS: Windows 8



Hi! I recently installed left 4 dead.And i can use multiplayer,server browse, without using steam.But when i want to join a server it just saying ''joining game'' and it goes to unlimited time! I can't play every time i'm joining a server it's working but it won't load. :( I wait for 10 minutes but still nothing.

Is there any solution to connect to servers? What is the problem?
THE_Militia is offline  
Sponsored Links
Advertisement
 
Old 04-09-2014, 12:16 AM   #2
Registered Member
 
Join Date: Apr 2014
Location: Singapore
Posts: 13
OS: Windows 7



Whoa... you still playing Left 4 Dead?
Ben81 is offline  
Old 04-09-2014, 12:17 AM   #3
Registered Member
 
Join Date: Apr 2014
Location: Singapore
Posts: 13
OS: Windows 7



How do you join the game? Via console ~ or from the list?
Ben81 is offline  
Sponsored Links
Advertisement
 
Old 04-09-2014, 06:23 AM   #4
Moderator - Games Team
Articles Team
 
Flight Sim Guy's Avatar
 
Join Date: Dec 2011
Location: S.W. Colorado
Posts: 6,103
OS: Windows 10 Pro 64bit

My System

Moved to Online/Network Gaming Support.

Welcome to TSF!

You mentioned that you're not using Steam. Is this correct?
__________________



If I don't reply within two days PM me as I sometimes get busy and forget threads.
Flight Sim Guy is offline  
Old 04-09-2014, 06:33 AM   #5
Registered Member
 
Join Date: Mar 2014
Posts: 4
OS: Windows 8



Well yea i got some Non steam version.In game i have ''browser server'' tab and i can choose on what servers to play.But still i can't make some servers to get working.It just say ''joining game'' but it goes to unlimited time.And game is working without steam i can get to Achievement or versus tab and so on.But i don't think that we should discuss of this thread anymore because game is old and no body knows how to make it working.
THE_Militia is offline  
Old 04-10-2014, 07:24 AM   #6
Moderator - Games Team
Articles Team
 
Flight Sim Guy's Avatar
 
Join Date: Dec 2011
Location: S.W. Colorado
Posts: 6,103
OS: Windows 10 Pro 64bit

My System


Where did you get the game from? And just because it's old doesn't mean it won't work.
__________________



If I don't reply within two days PM me as I sometimes get busy and forget threads.
Flight Sim Guy is offline  
Old 04-10-2014, 07:31 AM   #7
TSF Moderator
Hardware Team
 
bassfisher6522's Avatar
 
Join Date: Jul 2012
Posts: 2,316
OS: Windows 10 Pro



I'm an avid L4D/L4D2 player....love the game...1142 hours played on L4D2 and still going.


You could have some corrupted files. Have you tried refreshing your game cache through steam?
__________________
bassfisher6522 is offline  
Old 04-10-2014, 09:59 AM   #8
Administrator
Team Manager, Gaming
Team Manager, Microsoft Support
Team Manager, Hardware Team
Microsoft MVP
 
Wrench97's Avatar

Microsoft Most Valuable Professional
 
Join Date: May 2008
Location: S.E. Pennsylvania
Posts: 54,007
OS: Win7



Are all the old non steam servers still running?
Wrench97 is online now  
Old 04-10-2014, 02:11 PM   #9
Registered Member
 
Join Date: Mar 2014
Posts: 4
OS: Windows 8



Well yea servers are running.When i open ''browse servers'' it opens a tab and i can find servers.But problem is that only some of them works like 2/10.Most of internet servers just go to ''joining game'' but it doesn't respond.And when i go to games like history or favorites then i can join game whit out that tab saying ''joining game''.Dude i got a game via internet.And it's fine everything is working i don't think there are corrupted data.But i will see if i can do something else.
THE_Militia is offline  
Old 04-10-2014, 02:23 PM   #10
Moderator - Games Team
Articles Team
 
Flight Sim Guy's Avatar
 
Join Date: Dec 2011
Location: S.W. Colorado
Posts: 6,103
OS: Windows 10 Pro 64bit

My System


Do you happen to remember the website you got it from?
__________________



If I don't reply within two days PM me as I sometimes get busy and forget threads.
Flight Sim Guy is offline  
Old 04-11-2014, 10:30 AM   #11
Registered Member
 
Join Date: Mar 2014
Posts: 4
OS: Windows 8



Yea about that i got it via Uttorent.So game is pirate :P Probably because of that game doesn't work and that Non steam is patch that removes steam and you can play without him,but it seems that i was wrong about downloading that.Also when i play over internet sometimes it disconnect and says ''steam validation is invalid'',''Your country Serbia is not allowed to join this server''.I don't think i can repair this but it is ok.
THE_Militia is offline  
Old 04-11-2014, 11:02 AM   #12
Moderator - Games Team
Articles Team
 
Flight Sim Guy's Avatar
 
Join Date: Dec 2011
Location: S.W. Colorado
Posts: 6,103
OS: Windows 10 Pro 64bit

My System


Yep, that's your problem. And we don't offer support for illegal software.

Thread closed.
__________________



If I don't reply within two days PM me as I sometimes get busy and forget threads.
Flight Sim Guy is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help removing Rootkit.zaccess.trojan
Can anyone help me remove the Rootkit.Zaccess.trojan or do I need to reformat my hard drive like other sites have suggested? I read that this is a backdoor virus that allows hackers to enter your computer and steal identity info, and that it can never really be guaranteed to be removed.
eghostrider Resolved HJT Threads 41 10-10-2013 08:42 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 02:11 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts